We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem z domeną i DNS


Anshin
29-09-2009, 13:50
Witam podepnę sie trochę pod ten post żeby nie robić bałaganu na forum. Jakiś czas temu przeniosłem domenę na swój serwer RPS (domena rejestrowana w az.pl) wszystko pięknie chodzi, domena działa wiec więcej nic nie było robione. Znajomy ostatnio zwrócił mi uwagę czy dobrze mam skonfigurowany bind. Jak sie okazało RPS, który robi za główny ns nie odpowiada(dane pobierane sa z sdns1.ovh.net). Takie przynajmniej sa moje spostrzeżenia po sprawdzeniu domeny http://thednsreport.com/?domain=andiw.net

Pliku named.conf.options wygłąda tak.
Kod:
options {
        directory "/var/cache/bind";

        auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { any; };
        listen-on { any; };
        version "DNS";
        allow-query { any; };
        allow-transfer { any; };
};
Komenda dig zwraca:
Kod:
; <<>> DiG 9.5.1-P3 <<>> andiw.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 20442
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;andiw.net.                     IN      A

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Sep 29 13:47:49 2009
;; MSG SIZE  rcvd: 27
plik strefy:
Kod:
$TTL 86400 $ORIGIN andiw.net.

@       IN      SOA   r26546.ovh.net. andiwz.gmail.com. (
        2009090307
        10800
        3600
        2419200
        10800 )
;
        IN      NS              r26546.ovh.net.
        IN      NS              sdns1.ovh.net.
;
        IN      MX     10        ASPMX.L.GOOGLE.COM.
        IN      MX     20        ALT1.ASPMX.L.GOOGLE.COM.
        IN      MX     20        ALT2.ASPMX.L.GOOGLE.COM.
        IN      MX     30        ASPMX2.GOOGLEMAIL.COM.
        IN      MX     30        ASPMX3.GOOGLEMAIL.COM.
        IN      MX     30        ASPMX4.GOOGLEMAIL.COM.
        IN      MX     30        ASPMX5.GOOGLEMAIL.COM.
;
@       IN      A               87.98.164.206
r26546.ovh.net. IN A            87.98.164.206
sdns1.ovh.net.  IN A            213.251.188.140
www     IN      A               87.98.164.206
mail    IN      CNAME           ghs.google.com.
ftp     IN      CNAME           andiw.net.
Widać ze cos jest nie tak, ale mimo wszystko domena działa poprawnie. Jakiś pomysł, co dalej?

Z góry dziękuje za pomoc

dawid111
30-05-2009, 18:59
Cytat Napisał uetam
Twoj bind slucha tylko na 127.0.0.1 lub masz firewalla Dorzuc sobie do named.conf w sekcji options:
listen-on-v6 { any; };
listen-on { any; };
Bardzo Ci dziekuje za pomoc. Okazalo sie ze mialem ustawione

listen-on { 127.0.0.1; };

uetam
30-05-2009, 18:24
Twoj bind slucha tylko na 127.0.0.1 lub masz firewalla zle skonfigurowanego.

# telnet 87.98.164.244 53
Trying 87.98.164.244...
telnet: connect to address 87.98.164.244: Connection refused

Dorzuc sobie do named.conf w sekcji options:
listen-on-v6 { any; };
listen-on { any; };

dawid111
30-05-2009, 16:47
Cytat Napisał mwwilk
Lepiej ustaw jako drugi DNS sdns1.ovh.net.
Rozpowszechnianie adresu domeny trwa pare,kilka godzin (24h,36h do pelnego dzialania).
BIND działa na porcie 53
Obawiam sie, ze wina cos jest nie tak z konfiguracja, bo adres domeny jest juz rozpowszechniony. Whois podaje mi ns1.mojadomena.net i ns2.mojadomena.net. Juz nie wczytuje sie ta strona o ktorej pisalem - po prostu przegladarka stwierdza, ze nie ma takiej strony i tyle.

Po wpisaniu dig mojadomena.net na serwerze otrzymuje

Kod:
 <<>> DiG 9.5.1-P1 <<>> mojadomena.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33792
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;mojadomena.net.               IN      A

;; ANSWER SECTION:
mojadomena.net.        3600    IN      A       87.98.164.244

;; AUTHORITY SECTION:
mojadomena.net.        3600    IN      NS      ns1.mojadomena.net.
mojadomena.net.        3600    IN      NS      ns2.mojadomena.net.

;; ADDITIONAL SECTION:
ns1.mojadomena.net.    3600    IN      A       87.98.164.244
ns2.mojadomena.net.    3600    IN      A       87.98.164.244

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat May 30 14:12:33 2009
;; MSG SIZE  rcvd: 117
Niestety nie moze znalezc hosta z zewnatrz

host mojadomena.net 87.98.164.244, wywala mi cos takiego - wyglada, ze nie widac go z zewnatrz :|

Kod:
;; connection timed out; no servers could be reached

mwwilk
30-05-2009, 14:47
Lepiej ustaw jako drugi DNS sdns1.ovh.net.
Rozpowszechnianie adresu domeny trwa pare,kilka godzin (24h,36h do pelnego dzialania).
BIND działa na porcie 53

Zeby sprawdzic czy domena juz jest na nowych dnsac możesz uzyc whois (jeśli już jest na nowych to tylko czekac aż DNSy z których korzystasz się zaktualizują)

http://whois.domaintools.com

dawid111
30-05-2009, 13:30
Witam,

Mam problem z podpięciem domeny pod mojego RPSa w OVH. Domena jest wykupiona w OVH.

W panelu administracyjnym mam ustawiony DNS jako ns1.mojadomena.net i ns2.mojadomena.net - usunąłem także w panelu wszystkie strefy - jest tylko adres dns mojego serwera, na ktorym jest uruchomiony bind9

Plik named.conf wygląda tak

Kod:
zone "mojadomena.net" {
        type master;
        file "/etc/bind/db.mojadomena.net";
        };
Plik db.mojadomena.net wygląda tak

Kod:
$TTL 86400
$ORIGIN mojadomena.net.
@       IN      SOA     ns1.mojadomena.net. root.mojadomena.net. (
        2009053003 ;; serial
        1200       ;; refresh
        1200       ;; retry
        2419200    ;; expire
        86400      ;; TTL
        )
;
@               IN      NS      ns1.mojadomena.net.
@               IN      NS      ns2.mojadomena.net.
;
@               IN      MX      10    mail.mojadomena.net.
;
@               IN      A       87.98.164.244
www             IN      A       87.98.164.244
mail            IN      A       87.98.164.244

ns1             IN      A       87.98.164.244
ns2             IN      A       87.98.164.244
robiłem tez iptables -F


Bind starytuje i wydaje sie byc dobrze uruchomiony

Kod:
 command channel listening on 127.0.0.1#953
May 30 13:07:00 stock named[15694]: zone 0.in-addr.arpa/IN: loaded serial 1
May 30 13:07:00 stock named[15694]: zone 127.in-addr.arpa/IN: loaded serial 1
May 30 13:07:00 stock named[15694]: zone 255.in-addr.arpa/IN: loaded serial 1
May 30 13:07:00 stock named[15694]: zone localhost/IN: loaded serial 2
May 30 13:07:00 stock named[15694]: zone mojadomena.net/IN: loaded serial 2009053005
May 30 13:07:00 stock named[15694]: zone mojadomena.net/IN: sending notifies (serial 2009053005)
May 30 13:07:00 stock named[15694]: running
Wpisanie adresu mojej domeny kieruje natomiast na stronę http://imp.ovh.net/ pomimo, że w panelu jest tylko mój adres DNS :/