We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Php - Upload Foto - Avatar


Meduza
24-09-2008, 11:17
W logach nic ciekawego o tym nie widze...nie wiem jaka opcja to moze byc..gdybym wiedzial to bym to jakos ustawil...ale kto wie teraz jaka opcja jest za to odpowiedzialna?

jedynie takie cos

+0200] "GET /avatar/ad.jpg HTTP/1.1" 404 2157 "mojastrona.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16"
jakiesip - - [21/Sep/2008:14:55:56 +0200] "GET /avatar/ad.jpg HTTP/1.1" 404 2162

[Sun Sep 21 14:55:56 2008] [error] [client jakiesip] File does not exist: /var/www/virtual/mojastrona.pl/htdocs/avatar/ad.jpg, referer: mojastrona.pl

najpierw bylo tak :
; upload_tmp_dir =
dalem tak :
upload_tmp_dir = /var/tmp najpierw zmienilem na to...pozniej basedir wlaczylem, pozniej wylaczylem...pozniej zostawilem tak :
upload_tmp_dir =

i niestety nic nie dalo ;/ takie bledy wyskakuja a wlasnie nic nie wgrywa ;/ ech


Warning: filesize() [function.filesize]: open_basedir restriction in effect. File(/var/tmp/phpSrnsqH) is not within the allowed path(s): (/var/www/virtual/domena.pl/:/usr/share/php/:/tmp/) in /var/www/virtual/domena.pl/htdocs/function.php on line 623

Warning: copy() [function.copy]: open_basedir restriction in effect. File(/var/tmp/phpSrnsqH) is not within the allowed path(s): (/var/www/virtual/domena.pl/:/usr/share/php/:/tmp/) in /var/www/virtual/domena.pl/htdocs/function.php on line 633
Plik logo.jpg został pomyślnie przesłany.

Warning: copy(avatar_male/48.jpg) [function.copy]: failed to open stream: Permission denied in /var/www/virtual/domena.pl/htdocs/wgraj.php on line 34

Warning: imagejpeg() [function.imagejpeg]: Unable to open 'avatar_male/48.jpg' for writing: Permission denied in /var/www/virtual/domena.pl/htdocs/wgraj.php on line 45

widze ze tu np taki jeden tez ma taki problem podobny http://www.przemo.org/phpBB2/forum/v...c.php?p=139586

mlodszy
24-09-2008, 10:17
Ktora opcja systemowa? Masz jakies logi? Sprawdz czy sa jakies bledy. Glownie patrz do apache.

Meduza
24-09-2008, 09:58
Ja mam takie pytanko...posiadam dedyka i nikt nie potrafi mi odpowiedziec na takie pytanie:

mam dwie strony...jedna kolega w CMS druga moja w php również..i tam jak wiadomo jest funkcja wgraj avatar...i wybieram sobie z dysku obrazek i robie wgraj...niestety obrazek nie wgrywa sie na serwer...chmody do katalogu sa na 777...co moze byc przyczyna? moze cos jest wlaczone lub wylaczone na dedyku? prosze o info dzieki