We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Aktualizacja/rekompilacja Apache


mariano
14-08-2008, 08:26
Poszukaj narzedzia "apxs" w "/usr/local/apache/bin" albo "/usr/local/apache2/bin". Jak juz bedziesz znal wlasciwa sciezke, mozesz podac ja jako parametr do "configure":

Kod:
./configure --with-apxs=/usr/local/apache2/bin/apxs

doppel
13-08-2008, 16:01
Siemka!
Od niedawna jestem użytkownikiem RPS1 (z Release OVH). Fajna zabawka, duże możliwości, ale... No właśnie. Próbowałem zainstalować Subversion, coby postawić sobie repozytorium i udostępniać je po webdav. Niestety subversion nie kompiluje się krzycząc coś takiego:
Kod:
checking for static Apache module support... no
checking for Apache module support via DSO through APXS... ./configure: line 3794: /usr/sbin/apxs2
: No such file or directory
configure: error: no - APXS refers to an old version of Apache
                     Unable to locate /mod_dav.h
Wygląda na to, żę domyślna wersja Apache'a nie obsługuje DAV'a. Dlatego też mam pytanko: Czy zemergowanie aktualnej wersji apache'a z repozytorium nie zepsuje aktualnej konfiguracji?
Pytanie może głupie, ale na wszelki wypadek wolę je zadać, bo jednak domyślnie jest zablokowany.