We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Aliasy dla folderów


qermit
07-08-2008, 23:33
jezeli chcesz to moge tobie skonfigurować te vhosty i mod_rewrite (z ukrywaniem adresow)

qreqorek
07-08-2008, 18:29
.htaccess
Kod:
RewriteEngine On
RewriteRule ^logowanie$ http://ns111111.ovh.net/cgi-bin/sqwebmail
teraz po wejściu na http://mojadomena_1.pl/logowanie jestem przekierowany na http://ns111111.ovh.net/cgi-bin/sqwebmail , więc to mojego problemu nie rozwiązuje

Natomiast wszelkie próby dojścia do sytuacji, gdzie będę miał zawartość http://ns111111.ovh.net/cgi-bin/sqwebmail wywołując stronę http://mojadomena_1.pl/logowanie nie są mi dane zakończyć się sukcesem.

Próbowałem różnych wariacji z dopiskami 'Directory' dla VirtualHost'a kodów tego typu:
Kod:

ServerAdmin webmaster@mojadomana_1.pl
DocumentRoot /home/moja1/www
SuexecUserGroup moja1 users
ServerName www.mojadomana_1.pl
ServerAlias mojadomana_1.pl
CustomLog logs/moja1-access_log combined
ScriptAlias /cgi-bin/ /home/moja1/cgi-bin/
        
                Options FollowSymLinks ExecCGI Indexes MultiViews
                SetHandler cgi-script
        
AddHandler x-httpd-php5 .php
lecz wciąż po wywołaniu http://mojadomena_1.pl/logowanie sqwebmail otwiera sie jako plik tekstowy

qermit
06-08-2008, 11:54
napraw konfigurację :>

rewers nie ma nic do rzeczy

qreqorek
06-08-2008, 10:46
Faktycznie, ścieżka http://mojadomena_1.pl/cgi-bin/logowanie wygląda bardziej obiecująco zważywszy na wpis w apache

Kod:
ScriptAlias /cgi-bin/ /home/moja1/cgi-bin/
po wykonaniu (cgi-bin już istniał utworzony przez skrypty przy zakładaniu VirtualHost'a)
Kod:
cd /home/moja1/
cd cgi-bin && ln -s /home/ovh/cgi-bin/sqwebmail logowanie

otrzymuję przy wejściu na http://mojadomena_1.pl/cgi-bin/logowanie taki oto rezultat:

Kod HTML:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@mojadomena_1.pl and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Trochę czytałem o zmianie reversu, może w tym kierunku powinienem pójść, ale nie wiem czy dobrze rozumiem temat i czy da się zrobić z tego zamiast ServerName ns111111.ovh.net bezpośrednio mojadomena_1.pl

borec
05-08-2008, 11:29
Cytat Napisał qreqorek
Wielkie dzięki, najwyraźniej zadziałało.

Problem w tym, że skrypt cgi nie został zinterpretowany, przy wejściu na adres http://mojadomena_1.pl/logowanie mam coś takiego (fragment):

Kod:
�CRIT: Consider increasing the number of pre-forked sqwebmaild processes
����CGI environment exceeds allowed maximum size.�sqwebmailn�DOCUMENT_�GATEWAY_�HTTP_�HTTPS=�SSL_�QUERY_STRING=�SQWEBMAIL_�REMOTE_�REQUEST_�SCRIPT_�SERVER_�CONTENT_�PATH_INFO=�CGI�fcntl�sendmsg(filedescriptor)�select�write�socket�Cache-Control: no-store�Pragma: no-cache�Cache-Control: private�Pragma: private�������˙˙˙˙����˙˙˙˙�����������������2������<�
���$����h��������,�
Próbowałem metodą prób i błędów podmiany linijki
Kod:
ScriptAlias /cgi-bin/ /home/moja1/cgi-bin/
na jedną z ponizszych
Kod:
ScriptAlias /cgi-bin/ /home/moja1/www/logowanie/
ScriptAlias /cgi-bin/ /home/ovh/cgi-bin/
ale nie przyniosło spodziewanego rezultatu.

Update:2008-07-31 11:31
Próbowałem rozszerzyć linijkę z Options
Kod:
Options FollowSymLinks ExecCGI
ale jak rozumiem, mogę w vhostach nie dodawać tej linijki, gdyż i bez niej link sam w sobie działa, tyle że nie interpretuje CGI, a to zapewne dlatego, iż w httpd.conf jest wpis
Kod:

    Options Includes ExecCGI MultiViews FollowSymLinks Indexes
    AllowOverride All
Chodzi raczej o to że powinno być http://mojadomena_1.pl/cgi-bin/logowanie zgodnie ze ScriptAlias (nie na 100%, daaawno apacha nie używałem).
Kod:
cd /home/moja1/www/
mkdir cgi-bin
cd cgi-bin && ln -s /home/ovh/cgi-bin/sqwebmail logowanie
No chyba, że jeszcze polecisz mod_rewrite:
Kod:
RewriteEngine On
RewriteRule ^logowanie$ cgi-bin/logowanie [L]
(to oprócz tego co napisałem wyżej)
ale nie dam sobie głowy uciąć że to zadziała.

qreqorek
30-07-2008, 16:11
Wielkie dzięki, najwyraźniej zadziałało.

Problem w tym, że skrypt cgi nie został zinterpretowany, przy wejściu na adres http://mojadomena_1.pl/logowanie mam coś takiego (fragment):

Kod:
�CRIT: Consider increasing the number of pre-forked sqwebmaild processes
����CGI environment exceeds allowed maximum size.�sqwebmailn�DOCUMENT_�GATEWAY_�HTTP_�HTTPS=�SSL_�QUERY_STRING=�SQWEBMAIL_�REMOTE_�REQUEST_�SCRIPT_�SERVER_�CONTENT_�PATH_INFO=�CGI�fcntl�sendmsg(filedescriptor)�select�write�socket�Cache-Control: no-store�Pragma: no-cache�Cache-Control: private�Pragma: private�������˙˙˙˙����˙˙˙˙�����������������2������<�
���$����h��������,�
Próbowałem metodą prób i błędów podmiany linijki
Kod:
ScriptAlias /cgi-bin/ /home/moja1/cgi-bin/
na jedną z ponizszych
Kod:
ScriptAlias /cgi-bin/ /home/moja1/www/logowanie/
ScriptAlias /cgi-bin/ /home/ovh/cgi-bin/
ale nie przyniosło spodziewanego rezultatu.

Update:2008-07-31 11:31
Próbowałem rozszerzyć linijkę z Options
Kod:
Options FollowSymLinks ExecCGI
ale jak rozumiem, mogę w vhostach nie dodawać tej linijki, gdyż i bez niej link sam w sobie działa, tyle że nie interpretuje CGI, a to zapewne dlatego, iż w httpd.conf jest wpis
Kod:

    Options Includes ExecCGI MultiViews FollowSymLinks Indexes
    AllowOverride All

borec
30-07-2008, 15:32
Z tego co pamiętam z Apacha, zrób coś takiego:

1. w vhostach, tam gdzie konfigurujesz www.mojadomena_1.pl, dodaj:
Kod:
Options FollowSymlinks
2. wejdź do /home/moja1/www i zrób symlinka do /home/ovh/cgi-bin/sqwebmail:
Kod:
cd /home/moja1/www && ln -s /home/ovh/cgi-bin/sqwebmail logowanie
Powinno śmigać

qreqorek
30-07-2008, 14:40
Oto kawałek httpd.conf z vhostami:


ServerAdmin postmaster@ns111111.ovh.net
DocumentRoot /home/ovh/www
SuexecUserGroup vpopmail vchkpw
ServerName ns111111.ovh.net
CustomLog logs/ovh-access_log combined
ScriptAlias /cgi-bin/ /home/ovh/cgi-bin/
AddHandler x-httpd-php5 .php


NameVirtualHost 91.111.111.11:80


ServerAdmin webmaster@mojadomana_1.pl
DocumentRoot /home/moja1/www
SuexecUserGroup moja1 users
ServerName www.mojadomana_1.pl
ServerAlias mojadomana_1.pl
CustomLog logs/moja1-access_log combined
ScriptAlias /cgi-bin/ /home/moja1/cgi-bin/
AddHandler x-httpd-php5 .php



ServerAdmin webmaster@mojadomana_1.pl
DocumentRoot /home/ovh/www/phpMyAdmin
ServerName sql.mojadomana_1.pl
CustomLog logs/sql-moja1-access_log combined
AddHandler x-httpd-php5 .php



ServerAdmin webmaster@mojadomana_2.com
DocumentRoot /home/moja2/www
SuexecUserGroup moja2 users
ServerName www.mojadomana_2.com
ServerAlias mojadomana_2.com
CustomLog logs/moja2-access_log combined
ScriptAlias /cgi-bin/ /home/moja2/cgi-bin/
AddHandler x-httpd-php5 .php



ServerAdmin webmaster@mojadomana_2.com
DocumentRoot /home/ovh/www/phpMyAdmin
ServerName sql.mojadomana_2.com
CustomLog logs/sql-moja2-access_log combined
AddHandler x-httpd-php5 .php

borec
30-07-2008, 13:39
Cytat Napisał qreqorek
- "należy to zrobić przez odpowiedni wpis w apache".
Otóż to, może pokaż swój plik z vhostami to napiszę Ci dokładnie co i jak.

qreqorek
30-07-2008, 12:17
@AcidWeb: dzięki za podpowiedź, nie udało mi się niestety znaleźć nigdzie dokładniejszych opisów jak zrobić taki alias.

Wstawiłem na swojej stronie mojadomena_1.com plik index.php o poniższej zawartości:


content="text/html; charset=utf-8">
Tytuł

$adres="http://nsxxxxxx.ovh.net/cgi-bin/sqwebmail";
echo "";
?>


I w zasadzie uzyskałem oczekiwany efekt, po wejściu na stronę mojadomena_1.com wyświetla mi się zawartość strony http://nsxxxxxx.ovh.net/cgi-bin/sqwebmail, a widniejący adres to mojadomena_1.com.index.php ale wiedząc, że można to zrobić za pomocą aliasu nie czuję się usatysfakcjonowany. Ponadto teraz mam stronę w ramcę, czego raczej nie chcę. Jako stawiający pierwsze kroki w administrowaniu serwerem będę wdzięczny za dokładniejsze wskazówki odnośnie ustawienia aliasu.

--------------------------------------------------------------
Nie traktuj życia zbyt poważnie, i tak nie wyjdziesz z niego żywo.

AcidWeb
22-07-2008, 19:26
Jeżeli adres http://nsxxxxxx.ovh.net/cgi-bin/sqwebmail jest stały to co ci stoi na przeszkodzie by zrobić na niego alias na którejś z twoich domen?
Zainteresuj się ustawieniami serwera DNS.

qreqorek
22-07-2008, 10:41
Witam,

Pytanie: mam dedyka i kilka domen, uruchomiłem na nich emaile dla osób trzecich typu:
ktos_1@mojadomena_1.com
ktos_2@mojadomana_2.pl

Osoby te mogą wejść na http://nsxxxxxx.ovh.net/cgi-bin/sqwebmail i logować się. Jest to nie do końca eleganckie.
Czy można nadać alias na ten link, aby było np: http://mojadomena_1.pl/logowanie ???

Będę wdzięczny chociaż za wskazówki typu:
- "tak, należy to zrobić w .htaccess" czy
- "należy to zrobić przez odpowiedni wpis w apache".

--------------------------------------------------------------
Nie traktuj życia zbyt poważnie, i tak nie wyjdziesz z niego żywo.