We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Wildcard - raz działa raz nie :/


raven
16-07-2008, 15:30
Ten dodatkowy wpis to nie problem. to jest ich rekord "glue" potrzebny do funkcjonowania dnsa (w sumie nie do końca, ale powielają aby był taki sam jak na wyższym dnsie tld - nie ważne)

mosh
16-07-2008, 13:22
dzięki za czas poświęcony żeby mnie oświecić
(od msca mam dedyka więc dużo rzeczy to dla mnie czarna magia)

tak jak pisałeś wydelegowałem markata.info na FreeDNS::SGH (atsuki thx za pomoc, faktycznie to banalne... nie skumałem na początku że w "Nazwa strefy" trzeba podać nazwę domeny a nie serwera )

i teraz mam tak:
Kod:
; <<>> DiG 9.3.2 <<>> markata.info @ns359322.ovh.net
; (1 server found)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45434
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;markata.info.                  IN      A

;; ANSWER SECTION:
markata.info.           3720    IN      A       91.121.157.5

;; AUTHORITY SECTION:
markata.info.           3720    IN      NS      ns359322.ovh.net.
markata.info.           3720    IN      NS      fns1.sgh.waw.pl.

;; Query time: 0 msec
;; SERVER: 91.121.157.5#53(91.121.157.5)
;; WHEN: Wed Jul 16 12:42:34 2008
;; MSG SIZE  rcvd: 105
Kod:
; <<>> DiG 9.3.2 <<>> markata.info @fns1.sgh.waw.pl
; (1 server found)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19511
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;; QUESTION SECTION:
;markata.info.                  IN      A

;; ANSWER SECTION:
markata.info.           3720    IN      A       91.121.157.5

;; AUTHORITY SECTION:
markata.info.           3720    IN      NS      fns1.sgh.waw.pl.
markata.info.           3720    IN      NS      ns359322.ovh.net.

;; ADDITIONAL SECTION:
fns1.sgh.waw.pl.        86400   IN      A       194.145.96.21

;; Query time: 36 msec
;; SERVER: 194.145.96.21#53(194.145.96.21)
;; WHEN: Wed Jul 16 12:42:52 2008
;; MSG SIZE  rcvd: 121
czyli to samo po za tym że w w FreeDNS::SGH jest:

Kod:
;; ADDITIONAL SECTION:
fns1.sgh.waw.pl.        86400   IN      A       194.145.96.21
ale to już chyba nie problem ? czy może jednak ? bo w panelu FreeDNS::SGH nigdzie nie widzę takiego rekordu A (żeby go usunąć ?)

właśnie przedelegowałem 2 domeny w nazwa.pl - prim został stary, sec w FreeDNS::SGH (udało się wiec chyba dns jest dobry)

jeśli to jest koniec moich problemów w tym temacie to jestem Wam bardzo wdzięczny

raven
16-07-2008, 00:50
Cytat Napisał mosh
panel ovh dla dedyka (manager) jedyne co umożliwia to dodanie domeny..
czyli dodaje wpis domeny do dns sec. (w końcu domeny działają normalnie)
i nic więcej już nie ma


Jeju. To ją dodaj. Tzn. wpisz subdomene a nie domene w pole domena, czyli dodaj w panelu ovh cs.markata.info do seconadry dns.
Chyba rozumiesz ze podział domena-subdomena jest tylko myślowy. wszystko jest subdomeną w obrębie domeny "." (która w reprezentacji wizualnej jest pomijana)

to oczywiście nie zapewnia ci zadnego wildcarda, bo do kazdej subdomeny musisz recznie w panelu ovh wklepac wpis.

trudniejsze warianty:
Natomiast jesli chcesz zmienić taktyke i skorzystac z innego dnsa seconadry (nie tego który zapewnia ovh) to mozesz skorzystac z tego darmowego co ci tam radzą. Nie musisz nic konfigurowac tam "seconadry", jako ze serwer dns który jest "secondary" o tym nie wie i jest to tez fikcyjna myślowa nazwa (tak jak i czas propagacji domen). Drugi serwer dns jest tak samo czesto odpytywany co pierwszy i musi udzielac takich samych odpowiedzi co pierwszy.

(wiele osób się nie zgodziło sie by)Lepiej i łatwniej jednak wkazać ten sam serwer dns co primary, może to nie zgodne z przyjęta konwencją, ale wygodne, plus i tak masz tylko jeden serwer, więc jak ci pada to kaput, nie myśl o retundancji - ustaw po prostu na domenach w SOA mały fail retry. W tej syt. musisz jednak podać inny adres domenowy który wskazuje IP twojego serwera, a ten adres domenowy nie może używac twoich serwerów dns w procesie odwzorowania (resolve). Można to uzyskać praktycznie tylko stosując inny dns (bez sensu) lub najlepiej stosując tzw rekordy "glue" w swojej domenie. Wiekszosc powaznych rejestratorów domen w swoich panelach pozwala utworzyc rekordy glue w obrebie swojej domeny (ovh pozwala, home.pl pozwala itd itd)

Na początek dodaj sobie do panelu ovh swoje subdomeny. Jak bedziesz chciał prawdziwego wildcarda to zacznij dalszą robotę


Kilka lat pracy z domenami i skumasz co robisz Jak chcesz zacząc proces kumania to przeanalizuj sobie wynik komendy
dig cs.markata.info +trace
to mniej wiecej mówi wszystko co próbowałem ci tutaj przekazać, dosyć bezskutecznie. trzeba to tylko umieć odczytać i zinterpretować. Narzędziem dig można praktycznie każdy problem z dnsem zdiagnozować.



edit. Teraz widze ze wogóle delegowałeś sobie markata.info na dns fns1.sgh.waw.pl, podczas gdy on nie zawiera żadnych wpisów
dig markata.info @fns1.sgh.waw.pl (musi pokaza to samo co dig markata.info @ns359322.ovh.net)
dig cs.markata.info @fns1.sgh.waw.pl (musi pokazać to samo co dig cs.markata.info @ns359322.ovh.net)

atsuki
15-07-2008, 23:50
no bo to w zasadzie jest latwe

dodajesz rekord A w postaci:
domena.pl. -> ip
www -> ip
jak masz subdomeny to
subdomena -> ip
www.subdomena -> ip

i juz bedzie www smigac

---

a co do wildcarda, dajesz wpisy CNAME
* -> domena.pl.
www.* -> domena.pl.

mosh
15-07-2008, 23:34
skoro to takie łatwe mam nadzieje że się nie obrazisz jak jutro podeśle Ci pw z kilkoma pytaniami.. bo dziś się trochę z tym zamotałem i nie wiedziałem o co kaman

atsuki
15-07-2008, 23:14
na freedns.sgh.waw.pl nie ustawiasz zadnych sekond dns czy cos.. parkujesz swoja domene na dnsach freedns i tam tylko konfigurujesz swoja strefe dns.. wsio.

mosh
15-07-2008, 23:11
Cytat Napisał raven
resolv.conf nie ma kompletnie nic do całego procesu.

Na sdns1.ovh.net musisz mieć wpis dla cs.markata.info. Efekt jest natychmiastowy jeśli to nastąpi, co możesz sprawdzić tak jak mówiłem
dig cs.markata.info @sdns1.ovh.net
strona teraz u mnie działa ale "dig" nie.. czyli dalej lipa

Cytat Napisał raven
Ta komenda musi dawać TAKĄ SAMĄ odpowiedź co
dig cs.markata.info @ns359322.ovh.net

Nie korzystam z serwera dns ovh więc nie znam szczegółów, ale zapewne ovh w swoim panelu umożliwia tworzenie rekordów na tym ich dnsie (zrob rekord A).
Wątpie zeby była możliwość tworzenia rekordów *.domena w tym panelu.
panel ovh dla dedyka (manager) jedyne co umożliwia to dodanie domeny..
czyli dodaje wpis domeny do dns sec. (w końcu domeny działają normalnie)
i nic więcej już nie ma

Cytat Napisał raven
Wątpie także żeby dało się ustawić sdns1.ovh.net zeby zasysało samo ustawienia z twojego dnsa.
skoro tak to będę musiał się zainteresować np. FreeDNS::SGH
w sumie już to zrobiłem ale nie mam pojęcia jak tam postawić dns sec dla swojego dedyka :/

jutro kolejny dzień...

raven
15-07-2008, 18:35
resolv.conf nie ma kompletnie nic do całego procesu.

Na sdns1.ovh.net musisz mieć wpis dla cs.markata.info. Efekt jest natychmiastowy jeśli to nastąpi, co możesz sprawdzić tak jak mówiłem
dig cs.markata.info @sdns1.ovh.net

Ta komenda musi dawać TAKĄ SAMĄ odpowiedź co
dig cs.markata.info @ns359322.ovh.net

Nie korzystam z serwera dns ovh więc nie znam szczegółów, ale zapewne ovh w swoim panelu umożliwia tworzenie rekordów na tym ich dnsie (zrob rekord A).
Wątpie zeby była możliwość tworzenia rekordów *.domena w tym panelu.

Wątpie także żeby dało się ustawić sdns1.ovh.net zeby zasysało samo ustawienia z twojego dnsa.

mosh
15-07-2008, 16:35
dzięki za pomoc
wychodzi na to że coś jest nie tak u mnie na dedyku albo po stronie ovh
ale nie widzę żeby ludzie "płakali" z podobnego powodu jak ja

po dniu czytania, konfigurowania itp
mam takie błędy (tak mi się wydaje że to błędy):

zawartość resolv.conf:

Kod:
nameserver 127.0.0.1
nameserver 91.121.157.5 (moj dedyk)
nameserver 213.186.33.99 (cdns.ovh.net)
a gdzie sdns1.ovh.net ???

dig cs.markata.info @cdns.ovh.net daje poprawną odpowiedź
czyli wychodzi na to że to jest jakiś stary dns.. ale ja podałem ten nowy u rejestratora domeny.. no bo czemu mam dać stary

zmieniłem zawartość resolv.conf na

Kod:
nameserver 127.0.0.1
nameserver 91.121.157.5 
nameserver 213.251.188.140 (sdns1.ovh.net)
nameserver 213.186.33.99
to chyba już powinno pomóc ?

może warto dodać też w named.conf
w każdym zone "domena.com" linie:
Kod:
allow-transfer { 213.251.188.140;};
tak też zrobiłem (ale to chyba zbędne bo cdns.ovh.net jakoś zassał ustawienia mojego binda)

tak więc pozostaje czekać cierpliwie na efekty.. oby tym razem się udało..

raven
15-07-2008, 01:03
markata.info jest obsługiwana przez dnsy:
sdns1.ovh.net
ns359322.ovh.net

Oznacza to że subdomeny w tej domenie także muszą mieć wpisy w tych dnsach.

Na ns359322.ovh.net jest poprawny wpis A dla cs.markata.info odwzorowujący na IP 91.121.157.5.

Na sdns1.ovh.net nie ma wpisu dla subdomeny cs.markata.info.

Oznacza to że domena tylko w 50% zadziała, a wprzypadku trafienia na nie działające 50% rezultat zostanie zapamiętany w systemie odwiedzającego na wiele godzin.

Rozwiazanie:
Umieść poprawny wpis A dla subdomeny cs.markata.info na sdns1.ovh.net
(efekt sprawdzić możesz komeną dig cs.markata.info @sdns1.ovh.net)
lub
Zmień drugi dns pod domena markata.info na nazwę inną domenową odwzorowującą (nie przez twoj dns,glue) IP twojego serwera.

Efekt w przegladarce odwiedzajcego jak wspomniałem może nie być widoczny natychmiast ze wzgledu na cache dns. Na windowsie ipconfig /flushdns , ale chyba zeby faile wyczyscic to trzeba zresetowac system bo sama komenda nie pomoze.




edit: Przeczytałem wyżej że ty próbujesz zdaje się ustawić wildcard *.markata.info. Musiał byś w takiej sytuacji umieścić wpis wildcardowy na serwerze dns ovh z którego korzystasz. Nie wiem czy takie możliwości są, wątpie. A więc musiał byś skorzystac z innego dnsa (np. swojego (jeszcze raz ten sam)) z możliwością ustawienia takich rekordów, lub dodawać rekordy A na serwerze dns ovh dla każdej subdomeny (czyli zrezygnować z wildcarda)

mosh
14-07-2008, 22:44
sorki za "post pod postem" ale widzę temat zamarł.. a mój problem dalej trwa
tyle że nie dotyczy już tylko wildcard'a ale bardziej ogólnie subdomen

Jeżeli dodam subdomene to kilkanaście godzin działa kilkanaście nie (adres nie znaleziony), testowałem już wszelkiego rodzaju konfiguracje binda i kupa...

jedyne spostrzeżenie jakie mam to że jedynie w 2 domenach subdomeny i wildcard działa bez zarzutu.. i są to domeny .pl
inne .com i .info krzacza się (tzn. domena działa subdomeny - czy to z wildcarda czy dodane ręcznie raz działają raz nie)

(jedyny wyjątek to subdomena forum.wiaderko.com która działa normalnie.. ale na jej wzór dodałem tak samo szukaj.wiaderko.com i ona już dzaiła niestabilnie)

mosh
08-07-2008, 22:19
i jednak me wszęście nie trwało zbyt długo
problem znowu powrócił
i moje subdomeny dalej raz działają raz nie

przykładowo teraz działa
http://cos.markata.info/
a nie działa:
http://cs.markata.info/

wildcard dla tej domeny był konfigurowany ok tydź temu, więc czas propagacji już dawno się skończył..
a http://cs.markata.info/ wczoraj działa dziś nie.. jutro pewnie zaskoczy...


W czym tkwi problem w takim zachowaniu serwera ?
Skorzystanie z darmowego DNS (tak jak pisał kolega wyżeej - http://freedns.sgh.waw.pl - mogło by coś zmienić ?)
edit: czy jest możliwe że odpowiada za to nieprawidłowa konfiguracja firewall ? jak tak to jak to można sprawdzić ? )

mosh
03-07-2008, 15:19
Dzięki wszystkim za pomoc...
problem polegał na tym, że byłem za mało cierpliwy
i po konfiguracji wildcarda czekałem zbyt krótko (wychodzi na to że propagacja może trwać do 48h.. o ile nie dłużej)

2 dni temu skonfigurowałem wszystkie domeny tak jak napisałem w 1 poście
posprawdzałem wszelkimi "dns check'ami" dostępnymi w sieci (nie zwracały błędu)
i wychodzi na to że wszystko jest ok (jak bym się mylił, odkopie temat )

marczak
01-07-2008, 16:25
Cytat Napisał mariano
Kod:
marcin@agape:~$ dig wiaderko.com @ns359322.ovh.net.
; <<>> DiG 9.4.2 <<>> wiaderko.com @ns359322.ovh.net.
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 43727
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;wiaderko.com.                  IN      A
status = SERVFAIL. Sprawdz konfiguracje binda na swoim dedyku.
Pamiętaj, że mozesz skorzystć z darmowych DNS-ów. Polecam CI http://freedns.sgh.waw.pl sam tam ostatnio podpinałem domene z wildcardem.

mariano
01-07-2008, 10:44
Kod:
marcin@agape:~$ dig wiaderko.com @ns359322.ovh.net.
; <<>> DiG 9.4.2 <<>> wiaderko.com @ns359322.ovh.net.
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 43727
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;wiaderko.com.                  IN      A
status = SERVFAIL. Sprawdz konfiguracje binda na swoim dedyku.

mosh
01-07-2008, 07:23
niestety nic to nie zmieniło...
dalej część subdomen działa, część nie

edit: a może to ma jakiś związek z dns'ami których używam (blade pojęcie mam w tym temacie)
aktualnie primary na dedyku : ns35xxx.ovh.net
sec: sdns1.ovh.net

coraz bardziej mnie ten problem irytuje :/

marczak
29-06-2008, 16:38
tak daj bedzie dzialalo

ServerName wiaderko.com:80
ServerAlias wiaderko.com www.wiaderko.com
ServerAlias *.wiaderko.com

i jeszcze Dodaj wpisy w dns-ach


* IN CNAME wiaderko.com.
www.* IN CNAME wiaderko.com.

borec
28-06-2008, 16:51
Może tak?

Kod:
ServerName wiaderko.com
ServerAlias *.wiaderko.com

mosh
28-06-2008, 09:06
Witam
mam dystrybucję Gentoo Base System version 1.6.14

Podłączyłem sobie na dedyka 4 domeny, do każdej dopisałem wildcard'a i tylko
w przypadku jednej to działa normalnie... co jest nei tak ? :/

httpd.conf:
Kod:

        ServerAdmin webmaster@wiaderko.com
        DocumentRoot /home/xxx/www
        SuexecUserGroup xxx users
        ServerName www.wiaderko.com
        ServerAlias wiaderko.com *.wiaderko.com
        CustomLog logs/xxx-access_log combined
        ScriptAlias /cgi-bin/ /home/xxx/cgi-bin/
	AddHandler x-httpd-php5 .php
do wiaderko.com.hosts dodałem:
Kod:
*.wiaderko.com. 14400  IN      A       91.121.x.x
jak pisałem, zrobiłem to samo z 4 domenami w jednej to działa stabilnie
w reszcie raz działa raz nie - działa jedna subdomena, druga nie, następnego dnia odwrotnie albo w ogóle :/

coś robię nie tak.. czy co ?