We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

przenoszenie jportala z innego serwera


deqko
10-12-2005, 12:08
Temat rozwiazany
[zamykam]

wicko
10-12-2005, 10:27
Cytat Napisał wasylgkps
no qurde Wicko dlaczego dopiero teraz do tego doszedleś????
Bo dopiero wczoraj założyłem tutaj konto i przeniosłem jportala
BTW odpowiedziałem na zadane przez Ciebie pytanie we wskazanym topicu.

wasylgkps
09-12-2005, 17:46
Cytat Napisał wicko
2. I to w zasadzie był główny problem jaki mnie spotkał, chociaż po uploadzie pliku admin/.adm.php na serwer też było całkiem wesoło. Okazało się, że strona działa dobrze, jednak gdy wchodzę do panelu admina nie mogę się po nim poruszać. Logowanie działa poprawnie, jednak gdy klikam na przykład na 'Newsy' nic się nie dzieje, cały czas mam defaultowy ekran z panelu admina. I co teraz? Wchodzimy do głównego katalogu jportala i edytujemy plik config.php. W linijce:
$globals = true; zmieniamy na false i od tej pory wszystko ładnie pomyka.
Pozdrawiam.

no qurde Wicko dlaczego dopiero teraz do tego doszedleś???? jak ja juz jportala skasowalem no szkoda teraz mam inny problem lecz nikt nie odpowiada, moze Ty bedziesz wiedział - problem jest tu w ostatnim moim poscie: problem

wicko
09-12-2005, 16:14
No już sobie poradziłem z tym problemem, więc napiszę teraz co trzeba zrobić, aby było dla potomnych:
1. Zaczynamy od początku, czyli od skopiowania jportala ze starego serwera. I tu pierwsza uwaga, bo czasem plik admin/.adm.php jest ukryty i wtedy trzeba uważać bo na przykład TotalCommander domyślnie nie pokazuje plików ukrytych. Dlatego gdy przekopiowałem jportala ze starego serwera na hd okazało się że część plików została.
2. I to w zasadzie był główny problem jaki mnie spotkał, chociaż po uploadzie pliku admin/.adm.php na serwer też było całkiem wesoło. Okazało się, że strona działa dobrze, jednak gdy wchodzę do panelu admina nie mogę się po nim poruszać. Logowanie działa poprawnie, jednak gdy klikam na przykład na 'Newsy' nic się nie dzieje, cały czas mam defaultowy ekran z panelu admina. I co teraz? Wchodzimy do głównego katalogu jportala i edytujemy plik config.php. W linijce:
$globals = true; zmieniamy na false i od tej pory wszystko ładnie pomyka.
Pozdrawiam.

wicko
09-12-2005, 14:33
No więc tak jak w temacie, przenoszę sobie jportala z innego serwera, już mi się wydawało że wszystko elegancko działa, baza ładnie weszła, pliki przez ftp zgrane. No to loguję się do panelu admina a tam taki error:
Kod:
Warning: include(admin/.adm.php) [function.include]: failed to open stream: No such file or directory in /home/w/i/c/wicko/www/admin.php on line 31
i potem:
Kod:
Warning: include() [function.include]: Failed opening 'admin/.adm.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/w/i/c/wicko/www/admin.php on line 31
No więc wchodzę przez ftp patrzę sobie a tam elegancko w katalogu www jest sobie pliczek admin.php No to patrzę sobie co też jest takiego w linii 31, a tam taka funkcja:
Kod:
include('config.php');
include("admin/01.adm.php");
include("admin/02.adm.php");

function module($op)
{
    global $error;

    if(file_exists('admin/'.$op.'.adm.php'))
    {
        include('admin/'.$op.'.adm.php');
    }
    elseif($op=='')
    {
        $cmd = 'options';
        include('admin/.adm.php');

    }
    else
    {
        $error = 'e1';
    }
}
a linia 31 to dokładnie:
Kod:
include('admin/.adm.php');
czyli warunek w ifie nie jest spełniony, a co za tym idzie wygląda jakby pliki:
admin/01.adm.php
admin/02.adm.php
nie istniały, a tymczasem one sobie leżą elegancko w katalogu admin.
I co z tym robić? Może chodzi o to że funkcja modules nie wywołuje się dla 1 i 2? Ma ktoś jakiś pomysł?