We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Drupal - instalacja


boniek00
21-04-2008, 09:46
Jaka domena?

Pozdrawiam,

ander
19-04-2008, 19:43
Ponawiam prosbe o pomoc

ander
18-04-2008, 10:44
Witam,

Mam identyczny problem z tym ze po usunieciu wpisow:
"Options -Indexes", "Options +FollowSymLinks" oraz "DirectoryIndex index.php"

Problem nadal pozostaje i wyswietla sie komunikat:

Kod HTML:
Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.

Jeżeli jesteś właścicielem tego konta i szukasz informacji na temat probmemów z błędem wewnętrznym, zapraszamy na stronę http://60free.ovh.org/pl/support/ lub sprawdź czy:

- uprawnienia do uruchamianego zasobu '/' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,
- w pliku '.htaccess' nie znajdują się nieprawidłowe wpisy
Po usuniecie pliku .htaccess instalacja drupla sie uruchamia ale jednak w trakcie okazuje sie ze .htaccess jest potrzebny bo zawiera np.

php_value register_globals 0

Bardzo prosze o pomoc.

Pozdrawiam,
Rafal

mariano
27-03-2008, 14:16
Bez mod_rewrite tego nie zrobisz, ta opcja jest jednak wylaczona na 60free.

nawiedzonypablo
27-03-2008, 13:15
Dzięki! Teraz wszystko działa Mam jeszcze jedno pytanie. Jak ustawić przyjazne URLe, tak by przed adresami nie było "?q="? Z tego co czytałem to musi być włączony mod_rewrite ? W dokumentacji są informacje na ten temat (http://drupal.org/node/15365) ale do końca nie wiem jak to zrobić by adresy były w "przyjazny" sposób wyświetlane.

mariano
25-03-2008, 11:49
Musisz wywalic "Options -Indexes", "Options +FollowSymLinks" oraz "DirectoryIndex index.php". Domyslne ustawienia na 60free i tak sa podobne.

nawiedzonypablo
22-03-2008, 11:49
Hey! Mam problem z zainstalowaniem CMS'a o nazwie Drupal. Przez managera nie da rady, gdyż nie ma akurat takiego modułu do wybrania. Jak próbuje przez ftp'a to też nic i dostaje komunikat:
Kod:
 Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.

Jeżeli jesteś właścicielem tego konta i szukasz informacji na temat probmemów z błędem wewnętrznym, zapraszamy na stronę http://60free.ovh.org/pl/support/ lub sprawdź czy:

- uprawnienia do uruchamianego zasobu '/t/r/e/trendus/www/' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,
- w pliku '.htaccess' nie znajdują się nieprawidłowe wpisy
Czy powinienem zmienić jakieś uprawnienia do plików? Probowałem nic nie pomogło. Może w pliku .htaccess jest coś nie tak? .htaccess wygląda tak:
Kod:
#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.

  Order allow,deny


# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Customized error messages.
ErrorDocument 404 /index.php

# Set the default handler.
DirectoryIndex index.php

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1.

  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0


# PHP 4, Apache 2.

  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0


# PHP 5, Apache 1 and 2.

  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0


# Requires mod_expires to be enabled.

  # Enable expirations.
  ExpiresActive On

  # Cache all files for 2 weeks after access (A).
  ExpiresDefault A1209600

  # Do not cache dynamically generated pages.
  ExpiresByType text/html A1


# Various rewrite rules.

  RewriteEngine on

  # If your site can be accessed both with and without the 'www.' prefix, you
  # can use one of the following settings to redirect users to your preferred
  # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
  #
  # To redirect all users to access the site WITH the 'www.' prefix,
  # (http://example.com/... will be redirected to http://www.example.com/...)
  # adapt and uncomment the following:
  # RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
  # RewriteRule ^(.*)$ http://www.example.com/$1 [L,R=301]
  #
  # To redirect all users to access the site WITHOUT the 'www.' prefix,
  # (http://www.example.com/... will be redirected to http://example.com/...)
  # uncomment and adapt the following:
  # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
  # RewriteRule ^(.*)$ http://example.com/$1 [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory or in a
  # VirtualDocumentRoot and the rewrite rules are not working properly.
  # For example if your site is at http://example.com/drupal uncomment and
  # modify the following line:
  # RewriteBase /drupal
  #
  # If your site is running in a VirtualDocumentRoot at http://example.com/,
  # uncomment the following line:
  # RewriteBase /

  # Rewrite URLs of the form 'index.php?q=x'.
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]


# $Id: .htaccess,v 1.90 2007/10/05 14:43:23 dries Exp $