We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Brak połaczenia z Baza


bob123
22-01-2008, 15:12
Więc zaprzeczanie i mówienie, że nic nie robiliście na serwerze jest trochę nie na miejscu.
My niczemu nie zaprzeczamy.

W mailu aktywacyjnym podalismy adres serwera mysql (poprawny). Jezeli uzytkownicy by go przeczytali nie mieliby teraz problemow. Nie zagladamy do configow klientow, wiec nie wiemy jakiego rodzaju bledy popelniaja.

I korona by Wam (administratorom) z głowy nie spadła, jakbyście opublikowali chociaż maleńki komunikat, że coś zmieniacie, albo zareagowali szybciej na nasze pytania, a nie 2 dni po awarii
Na szczescie przez weekend odpoczywamy i mamy wolne od pracy. Dlatego dopiero w pon moglismy odpowiadac.

Nie zgadzam się z Twoim podejściem do tej sprawy.
I vice versa

Eden
22-01-2008, 14:58
Witaj bob123
Nie zgadzam się z Twoim podejściem do tej sprawy.
Niezaprzeczalnym faktem jest, że forum, którym się ja opiekuję działało bez problemu przez ponad rok, aż do feralnego dnia 18.01.2008. Z tego co widzę i tu czytam, nie jestem odosobnionym przypadkiem. Każdy kto tu jest widzi jaka jest sytuacja. Więc zaprzeczanie i mówienie, że nic nie robiliście na serwerze jest trochę nie na miejscu.
Nawet jeśli to, że fora i inne nie działają, wynika z naszego błędu, to powinieneś nam pomóc, a nie zwalać całą winę na nas, bo tak nie jest.
I korona by Wam (administratorom) z głowy nie spadła, jakbyście opublikowali chociaż maleńki komunikat, że coś zmieniacie, albo zareagowali szybciej na nasze pytania, a nie 2 dni po awarii Dzięki temu wszyscy uniknęli by całego zamieszania.

Pozdrawiam

bob123
21-01-2008, 09:02
Cały problem wziął się prawdopodobnie 18 Sty 2008, o 14:13 kiedy to OVH wprawadził małe zmiany związane z serwerem mysql i zapomniał nas o tym poinformować :P Wcześniej mieliśmy w pliku o nazwie "config.php" (np. fora na phpbb by przemo) taki wpis:
$dbhost = 'localhost';
W mailu po aktywacji konta bylo wyraznie napisane, ze nalezy korzystac z mysql.60free.ovh.org. Ty korzystasz z localhost, to nie wina OVH.

rayac
20-01-2008, 15:08
Cały problem wziął się prawdopodobnie 18 Sty 2008, o 14:13 kiedy to OVH wprawadził małe zmiany związane z serwerem mysql i zapomniał nas o tym poinformować :P Wcześniej mieliśmy w pliku o nazwie "config.php" (np. fora na phpbb by przemo) taki wpis:

$dbhost = 'localhost';
gdyż był to lokalny host ale teraz już nie jest więc musimy wpisać:
$dbhost = 'mysql.60free.ovh.org';

Jak wejdziecie do phpmyadmina zobaczycie, że tam też po lewej stronie nie ma już napisu localhost tylko mysql.60free.ovh.org

Po tych zmianach zapisujemy plik config.php i wgrywamy go na serwer przez ftp nadpisując stary plik. Gdy po tej operacji forum (strona) powróci ale nie możesz się zalogować lub wejść do panelu admina oznacza to że Twój edytor dodał do pliku config.php dziwne znaczki - wtedy edytujemy ten plik notatnikiem i usuwamy te znaki zapisujemy, przesyłamy i powinno być wszystko cacy.

morri
19-01-2008, 18:47
ok poradziłem sobie
dla innych
łączycie sie z serwerem przez ftp
znajdujecie plik config.php (ew. setup.php)
edycja
zmieniacie db_host na 127.0.0.1
i działa
przynajmniej u mnie

benio178
19-01-2008, 18:35
tia... u mnie zadziałało zmienienie localhost na 127.0.0.1

morri
19-01-2008, 17:57
Mam 7 ostatnich wiadomości w skrzynce i - nie wśród nich nie pojawia się jeszcze informacja o założeniu konta - nie mogę usunąć niepotrzebnych więc nie mogę się dostać do informacji które mi są potrzebne,
a drugie pytanie jak już będę miał informację o tym moim mysqlu to
GDZIE mam to zmieniać
czy np. w swojej stronie w cmsie ?
vmanagerze
phpmyadminie?

Izunia
19-01-2008, 16:44
a ja dalej nie wiem co mam zrobić Nic nie robiłam jak zwykle a jakiś problem jest I mam go sobie jakoś sama rozwiązać Zważcie na to że nie którzy nie są informatykami

klysio
19-01-2008, 16:10
a spróbujcie wpisać tak - mysql_connect('127.0.0.1', 'login', 'haslo')
u mnie się łączy bez problemu.

conish
19-01-2008, 15:19
Kazdy php, ktory laczy sie z mysql zawiera kod: mysql_connect('nazwa_hosta', 'login_do_mysql', 'pass_do_mysql')

Najczesciej jest to rozwiazane przez funkcje require('nazwa_pliku.php'), ktory zawiera mysql_connect.

Nazwe hosta mysql znajdziemy w mailu. Jesli go usunelismy ze skrzynki, to mozna go znalesc szukajac w menagerze:

Administracja->
Moje parametry->
Historia emaili->
mail o subject: potwierdzenie zalozenia konta 'nazwa_konta' w serwisie 60free

nie jestem pewny jak moze nazywac sie mail, gdy konto zalozone jest w innym serwisie.

morri
19-01-2008, 15:08
dobra jakoś łopatologicznie można wytłumaczyć?
gdzie się to robi ? vmanager - phpmyadmin? - potem gdzie wejść
jak nie mam tego emaila z hostem?

conish
19-01-2008, 13:22
w mailu, ktory powinien dotrzec po zalozeniu konta (nie ten z nick-handle, tylko nastepny), jest podany host mysql (ftp btw tez)

nelice
19-01-2008, 11:09
Cytat Napisał conish
zmiencie localhost na pelnego hosta mysql w mysql_connect
To znaczy co mam wpisać?? Wziąłem hostname z ze zmiennych serwera w phpmyadmin (filer5.60free.ovh.net) i też nie działa. Wywala mi błąd:
Lost connection to MySQL server at 'reading initial communication packet', system error: 111 i

klysio
19-01-2008, 11:09
u mnie to było "filer2.60free.ovh.net" i zaczeło działać normalnie
tylko teraz trzeba zmienić to we wszystkich plikach które się łączą z bazą

conish
19-01-2008, 08:36
zmiencie localhost na pelnego hosta mysql w mysql_connect

nelice
18-01-2008, 23:45
U mnie to samo. I co dziwniejsze phpmyadmin chodzi bez problemów, a cała strona leży ;/
Nie wiem co się zmieniło w konfiguracji ;/
http://nelice.ovh.org/

Topaz
18-01-2008, 22:12
U mnie ten sam problem.

http://topaz.ovh.org/PTS/index.php?typ=1

Izunia
18-01-2008, 21:22
to tak jak u mnie

www.izunia.ovh.org/IMGallery

DJ_Cysiek
18-01-2008, 18:48
Witam mam taki problem gdyz wyrzucilo mi polaczenie z baza danych mojego forum ktore chodzilo bez zarzutów.

Wyswietla mi cos takiego :


Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) in /home/d/j/c/djcysiek/www/phpBB2/db/mysql4.php on line 48
phpBB by Przemo : Critical Error

Could not connect to the database.
Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

czy moze to byc ze chaslo sie zmienilo gdzies w plikach jesli tak to w jakim pliku a zmienie je.
Prosze was o pomoc