We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Co się stało z PL literami?


Łabędź
05-10-2007, 13:25
Cytat Napisał Łabędź
Nic nie było zmieniane od ok. miesiąca czasu. Prawdopodobnie łączysz się z nie poprawnym kodowaniem. Zmień kodowanie na 'latin2' przy połączeniu, lub zaraz po połączeniu wykonaj komendę SQL 'use latin2'.

pozdrawiam
Ups... poplątało mi się... SQL z perlem

Oczywiście tak jak mówi Mariano 'set charset ...'

pozdrawiam

Blackhole
05-10-2007, 12:44
Hmm... Dodałem to, co zalecałeś, i zadziałało

Dzięki!

mariano
05-10-2007, 12:23
Ciezko powiedziec, moze masz blad gdzie indziej. Sprobuj dodac te zapytania i zobaczyc, czy rozwiaze to problem.

Blackhole
05-10-2007, 12:05
Ja używam tylko:
Kod PHP:
mysql_query("SET CHARSET latin2"); 
Znaczy to, iż od około miesiąca to nie wystarcza?

mariano
05-10-2007, 11:37
Zakladam, ze mowisz o ksiedze gosci na Waszej stronie. Jesli to Ty jestes autorem tego skryptu, to sprobuj wykonac nastepujace zapytania tuz po polaczeniu sie z baza:

Kod:
SET character_set_connection=latin2;
SET character_set_client=latin2;
SET character_set_results=latin2;
SET names latin2;
Na ogol pomaga.

Blackhole
05-10-2007, 10:13
Jeśli dobrze pamiętam, to mam tak ustawione.

Bardzo możliwe, iż około miesiąc temu właśnie się to popsuło. Co wtedy zmienialiście?

Łabędź
05-10-2007, 10:03
Cytat Napisał Blackhole
Co zostało zmienione i jak to naprawić? (Ja w kodzie i bazie nic nie zmieniałem.)

domena: jezusimarlena
Nic nie było zmieniane od ok. miesiąca czasu. Prawdopodobnie łączysz się z nie poprawnym kodowaniem. Zmień kodowanie na 'latin2' przy połączeniu, lub zaraz po połączeniu wykonaj komendę SQL 'use latin2'.

pozdrawiam

Blackhole
05-10-2007, 09:15
Od jakiegoś czasu po wpisaniu z poziomu PHP (przez formularz) tekstu z polskimi literami dostaję na stronie zamiast nich znaki zapytania
Co zostało zmienione i jak to naprawić? (Ja w kodzie i bazie nic nie zmieniałem.)

domena: jezusimarlena