We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

PHP nie działa


Red_Devil
10-12-2009, 21:25
////

puchol
16-06-2008, 23:37
no faktycznie teraz działa, ale wcześniej też były takie ustawienia i nie działało, tak jak pisałem, kilkukrotnie sprawdzałem ustawienia i o ile panel admina szedł, to strona główna już nie.
Podobnie było z jednym skryptem, który wyświetlał stronę, ale bez jednego elementu, mimo, że nic nie robiłem, po kilku dniach zaskoczył i jak na razie działa prawidłowo (skrypt był instalowany na 6 lub 7 innych serwerach i ani razu się coś takiego nie zdarzyło).

boniek00
16-06-2008, 09:17
Uprawnienia były niepoprawne. Prawidłowe to 644 dla plików, 755 dla katalogów.

Pozdrawiam,

puchol
13-06-2008, 19:11
no to i ja dołożę swoje trzy grosze
zainstalowałem sklep zen-cart i o ile mam dostęp do panelu admina, to nie ma dostępu do sklepu (panej admina leży "głębiej" w strukturze katalogów)

http://www.smokwawelski.ovh.org/zen/zen
http://www.smokwawelski.ovh.org/zen/zen/admin

w obydwu przypadkach pliki index.php mają te same uprawnienia - 644, w katalogu głównym sklepu nie działa (nawet z uprawnieniami 777), a w katalogu podrzędnym, czyli w admin działa

plik .htaccess najwyraźniej nic nie zmienia, bez względu, czy go usuwam, czy nie, to zachowanie jest takie samo :/, poza tym, to chyba nie powinien działać wybiórczo, czyli jedno blokować, a drugie nie.
W katalogu admina jest firmowy htaccess, ale również usuwanie tamtego nic nie zmienia, admin wyświetla się poprawnie, sklep nie :/

gdzie tkwi błąd ??

enjoyit
29-05-2008, 19:02
Juz sobie z tym poradzilem. Zamiast takiego include

if(empty($pokaz) or $pokaz=="news"){
include("html/news.html"); }

trzeba bylo to zrobic tak:

$open='html/'.$_GET['pokaz'].'.html';
If(is_file($open))
include($open);
else
include('html/news.html');

Dodam ze jest to includowanie do diva... pzdro

enjoyit
29-05-2008, 18:04
Witam. Mi takze php nie dziala, ale nie raportuje zadnego bledu. Moglby to obadac jakis fachowiec? Konto enjoy-it. Tego pliku nie mam, chmody folderow na 755, plikow na 644. pozdro

emonkey
19-05-2008, 15:38
Ale mi chodzi o wyniki.php xP Pokazuje Ci ile prawidlowych odp?

Edit
No fakt, chodzi Chyba po zmianei chmodow coś ten nie tak xP Hm... a dziwne

Patryk Jakubiak
19-05-2008, 12:12
Mi poprawnie działa:
zad1. Na jakim forum aktualnie znajdujesz?
a) peb.pl
b) xxx.pl
c) xxx1.pl
d) xxx2.pl
zad2. Ile mam lat? a) 10
b) 11
c) 18
d) 19
zawsze możesz ustawić dla tych plików chmod 777 (uprawnienia na wszystko)

emonkey
18-05-2008, 11:49
I znowu to samo xP Przeniosłem folder do innego katalogu i nie działa Znowu przenisłem do poprzedniego i nie działa :7

Pliku .htaccess nie mam A chmod sa 755 dla folderu i plików. Zmian w skrypicie także nie robiłem.

www.emonkey.ovh.org/biologia/wyniki.php

(www.emonkey.ovh.org/biologia/index.html)

Patryk Jakubiak
13-05-2008, 16:11
Cytat Napisał emonkey
Dzięki Pomogło
Pozdrawiam
Niema problemu :-)

Pozdrawiam
J.

emonkey
13-05-2008, 15:58
Dzięki Pomogło
Pozdrawiam

Patryk Jakubiak
12-05-2008, 20:55
Cytat Napisał emonkey
No czesc Sroki, nie sprawdzalem. Problem taki sam, link: http://www.emonkey.ovh.org/biologia/wyniki.php

Pliku .htaccess nie mam Mam pelen dostep, nawet jak ustawie chmody na 7777 nic nie pomaga

Kod
Kod PHP:
if (isset($_POST['send']))
    {
        
$liczba_pytan 2;
        
$zad[1] = $_POST['zad1'];
        
$zad[2] = $_POST['zad2'];
        if(
strlen($zad[1]) < or strlen($zad[2]) < )
            {
                print 
"Nie zaznaczyłeś wszystkich odpowiedzi";
            }
        else
            {
                for(
$i=1$i <= $liczba_pytan$i++)
                    {
                     if (
$zad[$i] == false)
                         {
                         
$blad++;
                        }
                      else
                          {
                        
$ok++;
                        }
                         
                    } 
                print 
'Liczba zdobytych punktów ' . ($ok 0);    
                print 
"";
                print 
'Złych odpowiedzi ' . ($blad 0);
            }
    }


?>
Plik zapisany jako wyniki.php
Pozdrawiam.
Witam,

Proponuje usunąć plik .htaccess. Jeżeli łączy się pan za pomocą Total Commander plik może być niewidoczny. W tym celu proszę połączyć się z serwerem FTP i przejść do menu Sieć -> FTP Pokaż ukryte pliki

Pozdrawiam
J.

czysty
12-05-2008, 17:15
witam mam ten sam problem co inni userzy moj polega na tym ze chce ukryc pliki z rozszerzeniem .html i .php za pomoca htaccess ale wywala mi błąd 705 prosze pomozcie moja strona to www.sulejczak.ovh.org

emonkey
12-05-2008, 16:03
No czesc Sroki, nie sprawdzalem. Problem taki sam, link: http://www.emonkey.ovh.org/biologia/wyniki.php

Pliku .htaccess nie mam Mam pelen dostep, nawet jak ustawie chmody na 7777 nic nie pomaga

Kod
Kod PHP:
if (isset($_POST['send']))
    {
        
$liczba_pytan 2;
        
$zad[1] = $_POST['zad1'];
        
$zad[2] = $_POST['zad2'];
        if(
strlen($zad[1]) < or strlen($zad[2]) < )
            {
                print 
"Nie zaznaczyłeś wszystkich odpowiedzi";
            }
        else
            {
                for(
$i=1$i <= $liczba_pytan$i++)
                    {
                     if (
$zad[$i] == false)
                         {
                         
$blad++;
                        }
                      else
                          {
                        
$ok++;
                        }
                         
                    } 
                print 
'Liczba zdobytych punktów ' . ($ok 0);    
                print 
"";
                print 
'Złych odpowiedzi ' . ($blad 0);
            }
    }


?>
Plik zapisany jako wyniki.php
Pozdrawiam.

boniek00
07-05-2008, 09:11
elektrownie.ovh.org na koncie w katalogu www masz plik .htaccess. Usuń go lub zakomentuj wszystkie wpisy.

Pozdrawiam,

energetyk
07-05-2008, 08:18
Mam jeszcze jedno konto www.elektrownie.ovh.org i także nie działa. Mało tego - nie jest to PHP tylko czysty html! Chmody są ustawione na katalog www - 705, na katalogi wewnątrz 755 a na pliki 644.

energetyk
06-05-2008, 20:29
Korzystam z Total Commandera i mam włączoną opcję "pokaż pliki ukryte/systemowe" i albo coś jest nie tak, albo ja jestem ślepy :-(

boniek00
06-05-2008, 13:56
W katalogu www masz plik .htaccess. Nie wiem jakiego klienta ftp używasz, ale w opcjach ustaw, żeby pokazywał ukryte pliki.

Pozdrawiam,

energetyk
06-05-2008, 11:59
Nie mam pliku .htaccess

boniek00
06-05-2008, 09:51
Masz na koncie plik .htaccess. Usuń go albo zakomentuj wpisy.

Pozdrawiam,

energetyk
06-05-2008, 07:32
Cytat Napisał voldemortsgirl
jaki to cms?
jakie dokladnie błedy wywala?
I co masz w tym pliku htaccess?

Bez podstawowych informacji nikt nic nie poradzi.
Ad.1. SmodCMS - dotychczas działał
Ad.2. Takie jak tutaj: http://www.czarnowasy.ovh.org/
Ad.3. Nie mam pliku htaccess.

Chmod na katalogi mam ustawione na 755, a na pliki 644.

voldemortsgirl
05-05-2008, 08:53
jaki to cms?
jakie dokladnie błedy wywala?
I co masz w tym pliku htaccess?

Bez podstawowych informacji nikt nic nie poradzi.

energetyk
04-05-2008, 18:25
Nie będę oryginalny, jak napiszę, że też mam ten problem co przedmówcy, a więc nie działa CMS na stronie i wywala te same błędy j.w. Proszę o pomoc administratorów OVH.

damian
04-05-2008, 10:09
Świetnie ale raczej nikt na tym forum nie jest czarodziejem.
Może tak pokazać jaki jest kod php.

Bo zakładam że umiesz czytać ze zrozumieniem i masz odpowiednie uprawnienia dla plików/folderów oraz nie masz w katalogu pliku .htaccess

Pozdrawiam

emonkey
04-05-2008, 00:58
Witam, mam podobny problem jak w temacie Link: http://www.emonkey.ovh.org/biologia/wyniki.php

Proszę o pomoc.
Pozdrawiam,
Piotrek

AdDel
28-04-2008, 21:13
Mam kolejny problem. Był już co prawda opisywany na forum ( http://forum.ovh.pl/showthread.php?t=6819 ), ale nie uzyskałem żadnej odpowiedzi. Dlatego piszę tutaj. Otóż zainstalowałem skrypt galerii zwany MG2 ( http://namir.ovh.org/galeria3/admin.php ). Próbuję zalogować się do panelu admina, wpisując hasło: 1234 ale wyskakuje mi komunikat "PERMISSION ERROR: Cannot write to 'pictures' folder! Chmod your 'pictures' folder to 777" mimo ustawienia odpowiednich chmodów. Warto dodać, że jeszcze jakiś czas temu wszystko było w porządku (wg autora przytoczonego topicu - do 2.02.2008). Chciałbym dostać odpowiedź, czy problem da się rozwiązać, czy nie, ponieważ potrzebuję galerii i zastanawiam się, czy warto szukać nowego skryptu (ten był idealny :P)...

boniek00
21-04-2008, 10:29
Zmień rozszerzenie skryptu na .php, zmień atrybuty na 644. Na 60free nie ma możliwości wysyłania maili za pomocą funkcji mail(), musisz skorzystać z phpMailera.

http://60free.ovh.org/pl/support/sup...PhpMailer.html

Pozdrawiam,

Papub
18-04-2008, 20:22
A ja mam formularz kontaktowy we flashu. Mam plik mail_form.php3 .htaccess z
SetEnv REGISTER_GLOBALS 1 ale maila nie wysyła. Swf-owi mail_form.php3 dałem atrybuty 777. Na innym serwerze formularz chodzi, a tutaj nie. Co zrobić

boniek00
16-04-2008, 09:19
Na 60free tryb safe_mode jest włączony, usuń plik .htaccess z katalogu 'www'.

Pozdrawiam,

ksimon
15-04-2008, 17:25
Witam, mam podobny problem na adresie simkomp.ovh.org proszę o pomoc

michalcelica
09-04-2008, 20:18
piszę juz po raz kolejny bo jak do tej pory nie uzyskałem odpowiedzi na moje pytanie, ani pomocy niestety chodzi mi o to jak prawidłowo w kodzie strony umiescić kod php tak aby działał poprawnie po umieszczeniu jej na serwerze. dokładnie chodzi mi o taki kod

i czy musze coś ustawiać na serwerze np: uaktywnić funkcję fopen
$handle = fopen("http://www.onet.pl/", "r");
while($cont = fread($handle, 128))
{print $cont;}
?>
Może mi ktoś pomóc jak to zrobić dokładnie i żeby działało.
Pozdrawiam i czekam na pomoc adres strony na której ma być tek kod to www.info-news.ovh.org

mariano
08-04-2008, 13:21
Gdzie ten blad, bo jakos go nie widze...?

Yuras
08-04-2008, 11:43
Witam
Mam taki problem ponieważ, zaczęły występować na mojej stronie błędy typu:

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/a/c/d/acd/www/index.php on line 5

Dodam tylko, że nie zmieniałem nic ostatnio w kodzie strony, a przedtem wszystko działało prawidłowo. Dzisiaj sprawdzałem tylko kod, niedziałających plików.

Weks
07-04-2008, 15:25
Witam,
Gdy wchodzę na moją stronę, z zewnątrz wygląda wszystko ok ale jak się zaloguje i chce kliknąć panel admina to wyskakuje mi coś takiego to samo wyskakuje po kliknięciu w jakiś button

adres strony weks.ovh.org

michalcelica
06-04-2008, 14:08
Witam czy uzyskam pomoc na zadane pytanie? nie mogę dojść dlaczego skrypt php na mojej stronie się nie wyświetla. adres strony to
info-news.ovh.org

bob123
01-04-2008, 16:26
Cytat Napisał slawgos
Witam to jest adres mojej strony www.sciarcinski.ovh.org jest na niej skrypt php emil lecz on nie działa. Skrypt jest raczej poprawny ale nie działa. Bardzo proszę o pomoc.
http://60free.ovh.org/pl/support/faq.html#faq25

slawgos
01-04-2008, 16:10
Witam to jest adres mojej strony www.sciarcinski.ovh.org jest na niej skrypt php emil lecz on nie działa. Skrypt jest raczej poprawny ale nie działa. Bardzo proszę o pomoc.

michalcelica
30-03-2008, 20:28
Witam oto strona http://info-news.ovh.org/ w prawej kolumnie jest skrypt php ale niestety nie działa po wgraniu strony na serwer. Czy mógłbym prosić o pomoc. Pozdrawiam i czekam na odpowiedź

Z tego względu prosze o pomoc gdyż php jest dla mnie jak narazie czymś nowym, i nie wiem czy to że dany skrypt nie działa na stronie jest kwestią błąednego kody php w kodzie strony czy wymaga zmian na serwerze.

FrytaMan
28-03-2008, 14:04
w tym samym momencie znalazłem w innym poście

dzieki

boniek00
28-03-2008, 13:59
nie masz katalogu www na koncie. Załóż katalog www i w nim umieść pliki.

Pozdrawiam,

FrytaMan
28-03-2008, 13:14
CHMODY - index.php ustawione na 644
Katalogów niema

i dostaje "Nie masz prawa dostępu do żądanego katalogu. W katalogu nie ma indeksu lub katalog jest zabezpieczony przed odczytem."

http://frytaman.ovh.org/index.php

mariano
20-03-2008, 10:41
Po prostu na 60free nie ma mod_rewrite. Pozostale wpisy w Twoim htaccess zreszta tez nie zadzialaja. Sprobuj cos zrobic ze swoimi skryptami php.

limek
19-03-2008, 21:26
Cytat Napisał mariano
Wywal .htaccess z tego katalogu.
heh rozumiem... odpaliło ale nie działa mi dobrze sktypt.. Dla czego ten plik .htaccess blokuje serwer?? w tym pliku widziałem ze są pewne komędy bez których nie da rady... co mam zrobic??

Poczytałem i posiedziałem. plik .htaccess zamieniłem na htaccess ... nic nie dało.... czy ja mam ten zakazany "mod_rewrite "
heh normalnie wysiadam. W pliku .htaccess mam np:

AddType application/x-httpd-php5 .php
Options FollowSymLinks
RewriteEngine On
RewriteRule szukaj/(.*)/(.*)/$ index.php?co=$1&ppidPagera=$2 [L,QSA]
RewriteRule index.html$ index.php
RewriteRule szukaj.html$ inc/search.php
RewriteRule ostatnio.html$ index.php?akcja=szukane [L,QSA]
RewriteRule podglad/mp3/([a-z0-9A-Z]+)/(.*)$ index.php?akcja=wiecej&id=$1&tytul_piosenki=$2 [L,QSA]
RewriteRule odtwarzacz$ images/odtwarzacz_mp3.swf [L,QSA]
RewriteRule odtwarzaj/mp3/([a-z0-9A-Z]+)/$ http://www.wrzuta.pl/aud/file/$1 [L,QSA]

Co tu jest nie tak. Przyznam ze jestem zielony w php...

mariano
19-03-2008, 10:20
Wywal .htaccess z tego katalogu.

limek
18-03-2008, 23:35
Hej witam:
Zauważyłem ze wiele osób ma ten sam problem jak ja. chodzi mi o ten błąd serwera..

uprawnienia do uruchamianego zasobu '/l/i/m/limek/www/w' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,
- w pliku '.htaccess' nie znajdują się nieprawidłowe wpisy

Naprawde nic nie rozumiem i nie mam pojęcia o co chodzi.
Jak by Admin mógł by wytłumaczyć jak to naprawic...Widziałem ze adm. sam naprawia...tylko że ja nie długo czyszcze kąto i wrzucam nową www. z tym skryptem.
link do nie działającego php:
limek.ovh.org/w/
Mogę liczyć na pomoc??

AdDel
17-03-2008, 22:33
Faktycznie. Mój błąd i w dodatku taki głupi... Przepraszam, że Was tak długo o to męczyłem i dziękuję za odpowiedzi

boniek00
17-03-2008, 16:15
Pliki w katalogu blog nadal mają niepoprawne chmody (-rw-rw-rw-). Ustaw chmody plików na 644, a katalogów na 755.

Pozdrawiam,

AdDel
17-03-2008, 16:02
Zmieniłem, ale nadal nie działa...

bob123
17-03-2008, 09:24
Katalog blog i jego podkatalogi maja zle uprawnienia (777). Zmien na 755

AdDel
14-03-2008, 16:47
Strona główna ładuje się poprawnie. Ale już na przykład: http://addel.ovh.org/blog/ nie....

bob123
14-03-2008, 09:08
addel.ovh.org
Strona laduje sie poprawnie. Rozumiem, ze poradziles juz sobie z problemem?

AdDel
13-03-2008, 20:17
addel.ovh.org - dodam, że jeszcze jakiś czas temu php działało bez zarzutu.

bob123
13-03-2008, 09:34
@AdDel
Podaj domene.

AdDel
12-03-2008, 19:12
Treilowi działa, ale nam nie... Czy czyszczenie FTP pomoże w tym wypadku? ;>

bob123
10-03-2008, 10:06
@treil

Php na Twoim koncie dziala prawidlowo. Nie masz pliku index.php, dlatego dostajesz blad jak go uruchmiasz.

treil
07-03-2008, 18:28
No to tak założyłem taką strone:
http://l-tunes.ovh.org/index.php
zainstalowałem na tym extreme fusion 4 i powinno wszystko działać.
chmody są prawidłowe, nie wykrywa pliku .htaccess
da sie to naprawić?
edit: po głębszym zastanowieniu wydaje mi sie że w waszej usłudze 60free jest taka wada że nie zawsze można wyświetlić ukrytych plików na serwerze ftp. przeczytałem o tym tutaj http://www1.zetosa.com.pl/arek/flashfxp/faq.htm gdzieś w trzecim akapicie. Moge sie mylić, ale niewiem dlaczego strona mi nie chce działać a powinna.

AdDel
07-03-2008, 18:24
Przy odpalaniu większości skryptów PHP (w moim wypadku: PS News, MG2)

Witamy na stronie serwisu 60free firmy OVH.

Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.

Jeżeli jesteś właścicielem tego konta i szukasz informacji na temat probmemów z błędem wewnętrznym, zapraszamy na stronę http://60free.ovh.org/pl/support/ lub sprawdź czy:

- uprawnienia do uruchamianego zasobu '/a/d/d/addel/www/blog/' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,
- w pliku '.htaccess' nie znajdują się nieprawidłowe wpisy
Chmody ustawione dobrze, htaccess nie mam...

Helpu mi

PS. Dodam, że na innych hostingach skrypty działają poprawnie.

bob123
06-03-2008, 09:52
Usun plik .htaccess

merkury777
05-03-2008, 20:07
www.klipoteka.ovh.org

Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania
wszystko ustawione na 755
prosze o pomoc

Ada$
03-03-2008, 13:47
Witam,

Mam ten sam problem co poprzednicy. Proszę o pomoc http://amkp.ovh.org/index.php

Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.

Wszystkie atrybuty są na 755 :/

Pozdrawiam.

halibucik
02-03-2008, 00:06
moja strona od dawna ma "błąd wewnętrzny" http://qlweb-seo.ovh.org/

Możemy coś z tym zrobić?

Oraz pytanie na przyszłość - (planuję nie poprzestać na jednej stronie) - z czym związany jest ten błąd, i czy ja, bez angażowania innych mogę rozwiązywać go na własne potrzeby?

dziękuję

msajgon
01-03-2008, 17:10
u mnie też nie działają skrypty php:
Kod HTML:
msar.ovh.org
Za pomoc dziękuję.

bob123
27-02-2008, 09:32
kidedy napisałem że go usunąłem
Nie usunales go. Plik jest w katalogu www.

zegarek84
26-02-2008, 18:08
kidedy napisałem że go usunąłem i nic nie chodzi ;/....

mariano
26-02-2008, 09:49
Wywal .htaccess, nie mozesz uzywac mod_rewrite na 60free.

zegarek84
25-02-2008, 23:57
mi nie dziala php - nawet jak chcę podmienić sam html to ni chula....

katalogi ustawiałem i na 705 i na 755 - pliki są na 644 - htaccess usunąłem - prawie wsio usunałem....
stronka z linkiem bezposrednim do bylejakiego php: http://krawiectwo-zofia.ovh.org/index.php
stronka jeszcze nie jest skonczona ale chciałem wypróbować ten serwis.... narazie zostala zamieszczona na: http://www.krawiectwo-jaworzno.ugu.pl/index.html

proszę o pomoc w sprawie http://krawiectwo-zofia.ovh.org/

pozatym przydał by sie jakiś tutek co do tutejszego htaccess gdyz widzialem na tym forum że wielu ma problem a ja też chciałbym dalej stosować przyjazne linki

Z GóRY DZIEKUJE ZA POMOC

bob123
20-02-2008, 09:47
Zgadza sie ustawienia masz poprane. Nie odpowiadamy za jakosc uzywanego przez Ciebie oprogramowania. Sprobuj wgrac jeszcze raz tego cmsa.

omen333
19-02-2008, 18:47
Ale mam wszystko ustawione jak powinno być. Katalog ma 0755, plik ma 0755, nie mam pliku .htaccess a stronka dalej nie działa...

bob123
19-02-2008, 09:56
Zmieniałem nawet uprawnienia na -rwxrwxrwx a na stronie z błędem serwer twierdzi, że mam ustawione na 755.
Serwer podpowiada Ci jakie powinny byc poprawne uprawnienia. Twoje sa niepoprawne.

bob123
19-02-2008, 09:54
@stoneknight
Php dziala poprawnie na Twoim koncie. Prawdopodobnie cos nie tak z Twoim cmsem

stoneknight
18-02-2008, 23:30
wszystko dobrze zainstalowałem, dobrze poustawiałem i zero efektów http://stoneknights.ovh.org/
biała strona i nie mam pojęcia o co chodzi... Widze ze duzo osob ma problem z php jak ja, mam nadzieje ze da sie zrobić coś z moja sprawa...

omen333
16-02-2008, 19:15
www.osobowice-redzin.ovh.org
Też mam problem z nieczytaniem skryptów php.
Próbowałem wszystkiego. Zmieniałem nawet uprawnienia na -rwxrwxrwx a na stronie z błędem serwer twierdzi, że mam ustawione na 755.
Czy moje działania mają na to wpływ, czy to jest chwilowy błąd serwera?
Nie chciałbym, żeby to się powtarzało, bo nie chcę więcej truć d**y adminom

conish
11-02-2008, 16:31
Kod:
Warning: session_start() [function.session-start]: open(/tmp/sess_qne6q7udn43t4uvrkcmnmdm2k6, O_RDWR) failed: Permission denied (13)
a mi sie takie o...

kemader
04-02-2008, 17:38
oo, dziękuję

boniek00
04-02-2008, 10:38
Usuń plik .htaccess z konta, na 60free nie ma rewrite'a.

Pozdrawiam,

kemader
03-02-2008, 13:58
http://kemader.ovh.org/Quick.Cms/index.php

chmody na 100% są poprawne.

Żwirek
30-01-2008, 17:19
Sprawdz co masz w pliku .htaccess czy nie ma w nim nieprawidłowych wpisów.

Pacanek
30-01-2008, 16:23
rd-zt.ovh.org

Witamy na stronie serwisu 60free firmy OVH.

Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.

Jeżeli jesteś właścicielem tego konta i szukasz informacji na temat probmemów z błędem wewnętrznym, zapraszamy na stronę http://60free.ovh.org/pl/support/ lub sprawdź czy:

- uprawnienia do uruchamianego zasobu '/r/d/-/rd-zt/www/index.php' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,
- w pliku '.htaccess' nie znajdują się nieprawidłowe wpisy

poprawnie zchmodowane

bob123
25-01-2008, 08:17
mi mail() nie działa :/
Funkcja mail nie dziala na 60free. Sprobuj tego: http://60free.ovh.org/pl/support/sup...PhpMailer.html

B16
24-01-2008, 20:15
mi mail() nie działa :/
Kod:
http://gorzyceasg.ovh.org
to moja stronka. Bob napraw prosze

bob123
23-01-2008, 08:24
Przed chwila sprawdzilem i te pliki napewna tam sa. Musisz poprawnie skonfigurowac swojego klienta ftp, zeby wyswietlal ukryte pliki.

lipers
22-01-2008, 23:15
Cytat Napisał bob123
W katalogu domowym i www masz plik .htaccess. Usun je.
Nie ma tam tych plikow, gdy je dodalem to po ponownym zalogowaniu sie zniknely, szukalem we wszytkich plikach i ich nie ma :/

kaju6
22-01-2008, 15:15
ok dzieki wielkie bardzo

mariano
22-01-2008, 12:54
Jak nie dziala, skoro dziala? Podaj dokladnego linka, gdzie niby nie dziala.

kaju6
22-01-2008, 12:38
A ja nie mam go i dalej mi nie działa

bob123
22-01-2008, 11:06
Ja rowniez mam z tym problem www.tech-slownik.ovh.org walcze z tym pol dnia i nic nie moge zrobic :/
W katalogu domowym i www masz plik .htaccess. Usun je.

lipers
21-01-2008, 23:22
Ja rowniez mam z tym problem www.tech-slownik.ovh.org walcze z tym pol dnia i nic nie moge zrobic :/

kaju6
21-01-2008, 14:20
Ja równiez mam taki problem z php

http://www.9brygada.ovh.org

Prosze o pomoc i z góry dziękuję

Inzaghi
21-01-2008, 12:40


Jest 755. Co teraz ? natomiast strony mają 644



Jeszcze jedno mało pytanko: Czy mam wpisane ten skrypt w kodzie i zmieniłem rozszerzenie z html na php tej podstrony - tak trzeba robić czy można zostać przy html ??

conish
20-01-2008, 13:08
sprawdz, czy katalog, w ktorym trzymasz ten plik jest >=755.

z modulem chodzi o to, ze mozesz zapisac sobie ten plik osobno, nie wklejac go do kodu strony a wywloac przez
Kod PHP:
require(nazwa_pliku.php); ?>

Inzaghi
20-01-2008, 00:53
http://www.bukmacherzyy.ovh.org/typyuzytkownikow.php

Mam tu system komentarzy jednak on nie działa. Co muszę jescze zrobić aby działał on poprawnie ?
Dałem na serwa ftp tą podstrone z rozszerzeniem *ftp oraz sam skrypt też dodałem.
Komentarze powinny pojawiać się na stronie jednak tego nie robią.

Treść skryptu:
Kod:


*/
if ($message)
	{
	/* uncomment the next two lines to strip out html from input */
	/* $name = strip_tags($name); */
	/* $message = strip_tags($message); */
	$message = ereg_replace("\r\n\r\n", "\n

", $message); $date = date("l, F j Y, h:i a"); $message = "$name -- $date

$message


"; $fp = fopen (basename($PHP_SELF) . ".comment", "a"); fwrite ($fp, $message); fclose ($fp); } @readfile(basename(($PHP_SELF . ".comment"))); ?>
Your name:

Your comment:

Ta część mojej podstrony gdzie jest umieszczony skrypt
Kod:
       

STRONA W BUDOWIE

*/ if ($message) { /* uncomment the next two lines to strip out html from input */ /* $name = strip_tags($name); */ /* $message = strip_tags($message); */ $message = ereg_replace("\r\n\r\n", "\n

", $message); $date = date("l, F j Y, h:i a"); $message = "$name -- $date

$message


"; $fp = fopen (basename($PHP_SELF) . ".comment", "a"); fwrite ($fp, $message); fclose ($fp); } @readfile(basename(($PHP_SELF . ".comment"))); ?>
Your name:

Your comment:

Pod koniec komentarza w tym skrypcie jest mowa o jakimś module. O co tam chodzi ?

Marcin063
19-01-2008, 20:13
Moja forum nie dziala przed chwila wgralem u tu nic.
link: http://l2jj.ovh.org/forum/ Proszę panie admin zrób coś!!
Błagam

conish
19-01-2008, 20:03
zastanawiajac sie chwile sprawa wyglada na grzebanie w apachu. glowna strona mi dziala jak najbardziej, ale pozostale nie.

Sanvean
19-01-2008, 19:19
Cytat Napisał boniek00
Miałeś niepoprawne uprawnienia plików na swoim koncie.

Poprawne uprawnienia to:
pliki: 644
katalogi: 755,

Pozdrawiam,
Jak widzę to dość popularna przypadłość
W informacji jaką otrzymuję przy próbie instalacji forum jest napisane:
- uprawnienia do uruchamianego zasobu '/t/c/g/tcgpotter/www/forum/' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,


Inni też doradzali zmianę na 755. Zmieniłem i nic się nie zmieniło, więc sądzę, że to jednak coś po stronie OVH.

Po znalezieniu tego posta zmieniłem pliki znów na 644. Katalogi były 755 więc nie ruszałem.

Proszę admina o uruchomienie PHP na stronach:
http://tcgpotter.ovh.org/
http://sanvean.ovh.org/

Z góry dzięki.

Pozdrawiam

PS. Z tym samym problemem dopisałem się do wątku "Błąd w phpbb by przemo", ale wydaje mi się, że tutaj jest bardziej właściwe miejsce, więc sorki za dublowanie

conish
19-01-2008, 16:53
blad z 755
conish.ovh.org

tyle, ze juz siedze nad tym od kilku godzin i moze byc po prostu wina zmeczenia materialu

edit:tak jak podejrzewalem zmeczenie materialu. Zle zastosowalem headera

boniek00
18-01-2008, 09:04
Już jest ok.

Pozdrawiam,

modul
17-01-2008, 18:35
Witam,

Na stronie http://www.8ideas.ovh.org/ nie działa PHP.

Proszę o pomoc

kemader
17-01-2008, 12:58
hah, dzięki było 777
teraz działa

mariano
17-01-2008, 12:45
A katalog 'www' jaki ma chmod?

kemader
17-01-2008, 12:36
Jest to w katalogu www.

mariano
17-01-2008, 11:12
Cytat Napisał kemader
U mnie również występuje ten błąd. Chmody 755.
Taaa, a katalog 'www'?

kemader
17-01-2008, 11:00
Nie wiem czy ktoś tutaj zagląda... czekam 4 dzień, ale niestety komunikat wyświetla się nadal.

kemader
13-01-2008, 20:26
U mnie również występuje ten błąd. Chmody 755.
http://kemader.ovh.org/nd/install/index.php

Z góry dziękuję za pomoc.

Korjaw
12-01-2008, 14:12
Ehhh ten sam problem :/

http://clan-gfo.ovh.org/index.php

Chmody zmienialem na 775 ale i tak nie działa ...

Mam nadzieję na szybką pomoc :]
Z góry dziękuję.

Arpeggio
11-01-2008, 14:41
U mnie to samo
www.forum-mepis.ovh.org

grzebałem grzebałem poprzestawiałem na 755 i nic nie pomaga

Bardzo proszę o pomoc

EDIT: Właśnie wszedłem na stronę i zadziałała... Dzięki

luk94
09-01-2008, 07:22
Hej
Wystąpił u mnie jakiś problem nic nie działa na serwie praktycznie..Nie moge uruchomić prostego skryptu prziekierowania:/ Po za tym serwer nie chce przyjąc pliki htaccess. Chciałem tam postawić CMS Drupal. Proszę o pomoc

http://pow2006.ovh.org/


tak wygląda odpowiedz serwera:/
================================================== ================================================== ========
serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.

Jeżeli jesteś właścicielem tego konta i szukasz informacji na temat probmemów z błędem wewnętrznym, zapraszamy na stronę http://60free.ovh.org/pl/support/ lub sprawdź czy:

- uprawnienia do uruchamianego zasobu '/p/o/w/pow2006/www/' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,
- w pliku '.htaccess' nie znajdują się nieprawidłowe wpisy

pi7er
09-01-2008, 01:06
php nie działa
pi7er.ovh.org

prosze o pomoc

krl
07-01-2008, 16:06
już działa, dziękuje za pomoc

krl
06-01-2008, 21:37
chyba nikt tutaj tego nie czyta...
wcześniej tego problemu nie miałem.
a CHMODy mam na 100% dobrze ustawione (chyba że mnie FileZilla kłamie)

Qki
06-01-2008, 16:29
witam, mam ten sam problem co wszyscy tutaj, php nie dziala. prosilbym o naprawienie.
domena: lfurman.ovh.org

xixek
05-01-2008, 23:08
Witam serdecznie. Dzisiaj założyłem konto, już aktywowane, działa html, nie działa php. nawet zmiana rozszerzenia pliku z .html na .php powoduje że przestaje on być uruchamiany...

uprzejmie proszę o naprawienie. dziękuję, pozdrawiam!
Kris

hehe, stronka: kjbuz.ovh.org z rozpędu nie napisałem

krl
04-01-2008, 21:54
ten sam problem, żaden skrypt php nie działa i nie mogę odpalić instalacji skryptu.
domena iath.ovh.org

bob123
04-01-2008, 08:23
Mi również nie działa php
Teraz powinno byc ok

btrial
03-01-2008, 19:58
Mi również nie działa php
Prosił bym o naprawę
www.ifwmpk.ovh.org

boniek00
31-12-2007, 09:47
Miałeś niepoprawne uprawnienia plików na swoim koncie.

Poprawne uprawnienia to:
pliki: 644
katalogi: 755,

Pozdrawiam,

kecal
29-12-2007, 19:31
Nie moge na koncie kecal.ovh.org uruchamiac php - komunikaty jak wyzej prosze o odblokowania
kecal

stipi
11-12-2007, 09:43
Witam

mógłybm prosic o rozwiązanie podobnego problemu:

konto: http://hrvatska.ovh.org/

Dzieki wielkie

zingug
04-12-2007, 21:15
Witam u mnie na http://www.tzygmunt.ovh.org też skrypty nie działają, wyświetla standardowy tekst Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.

Jeżeli jesteś właścicielem tego konta i szukasz informacji na temat probmemów z błędem wewnętrznym, zapraszamy na stronę http://60free.ovh.org/pl/support/ lub sprawdź czy:

- uprawnienia do uruchamianego zasobu '/t/z/y/tzygmunt/www/cms/index.php' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,
- w pliku '.htaccess' nie znajdują się nieprawidłowe wpisy

katalog ma 755, index też htaccsesa nie mam - cms nie używa bazy. Pomocy

B16
04-12-2007, 16:06
Cytat Napisał bob123
@B16
Juz powinno byc ok
jak możesz to jeszcze napraw
Kod:
http://mxclan.ovh.org/pa/dodaj.php
to

nie da się usunąć tego błędy na stałe ?

bob123
04-12-2007, 08:28
@B16
Juz powinno byc ok

B16
03-12-2007, 18:30
Mam ten sam problem co na początku
Kod:
www.mxclan.ovh.org/

bob123
30-11-2007, 08:24
@dzamik
Sprobuj teraz

dzamik
29-11-2007, 20:26
Nie działa phpinfo.php na koncie xxvlokrakow.ovh.org - ani w katalogu www, ani w www\test
Przy zmianie checkmode z 755 na 644 tracę możliwość wejscia do katalogu przez ftp. Przeglądarka IE informuje, że plik nie istnieje z tego samego powodu.

Proszę o pomoc.
Pozdrawiam.

io451
19-11-2007, 10:49
jush dziala
thx

bujo
18-11-2007, 22:47
Witam serdecznie.
Niestety ja również mam taki sam problem jak moi przedmówcy. Pomimo przeróżnych kombinacji chmod plików i katalogów na koncie sm2debica.ovh.org, nawet najprostsze skrypty php w podkatalogu test nie działają . Bardzo bym prosił o pomoc w rozwiązaniu tego problemu.

Pozdrawiam serdecznie,
Marcin

io451
18-11-2007, 10:47
i jeszcze ja: http://io451.ovh.org/
jak widze problem dosyc pospolity...

boniek00
12-11-2007, 09:09
Już powinno być OK.

Pozdrawiam,

Krukosz
11-11-2007, 14:31
U mnie to samo... skrypty php nie działają

adres http://v-forum.ovh.org

Prosze os zybką naprawe tego

mgx8
09-11-2007, 17:43
Ja mam podobny problem z PHP na koncie, konto na którym jest problem to mgx8.no-ip.pl, pomimo dobrych chmodów, system WordPress nie chcę nawet dość do instalacji, nawet jak instalowałem WordPress'a z Managera OVH, to był ten sam problem.

serdian
09-11-2007, 13:35
Korzystałem z kilku klientów ftp. Ostatnio z ftp OVH przez przeglądarkę. Ten chyba powinien działać poprawnie. Moim zdaniem problem występuje po stronie OVH, gdyż od ostatniego postu nic nie zmieniałem, a dziś PHP działa bez problemów.
Dzięki dla Administratora.

Zajonc
08-11-2007, 21:35
U mnie pomoglo wtrybienie sie przez ftp z konsoli tuxa i zmiana uprawnien recznie. Jak widac niektore klienty FTP nie radza sobie z komendami zmiany uprawnien i/lub klamia w zywe oczy jak moj GC

serdian
08-11-2007, 21:03
Mam ten sam problem, co większość. PHP nie działa, ustawienia CHMOD sprawdziłem.

http://sh-mlawa.ovh.org/

Zajonc
08-11-2007, 14:04
Hmm.. Gnome Commander co prawda jeczy mi, ze nie moze wykonac operacji zmiany uprawnien, ale po odswiezeniu widze 644. Jesli faktycznie te uprawnienia sie nie zmienily, pomimo tego co sie u mnie pokazuje, to sprobuje uzyc innego klienta niz GC.

boniek00
08-11-2007, 09:05
Nie pomogło, bo nie zmieniłeś uprawnień na prawidłowe.

Kod:
-rw-rw-rw- 1 ????? ????? 7.7K 2007-11-06 22:29 index.php
Zmień uprawnienia pliku index.php za pomocą swojego klienta ftp na prawidłowe.

http://pomoc.ovh.pl/UprawnieniaChmod

Pozdrawiam,

Zajonc
07-11-2007, 23:43
Cytat Napisał boniek00
Zmień uprawnienia pliku /home/index.php na 644.
Dalej to samo. Znaczy sie nie pomoglo.

boniek00
07-11-2007, 09:04
Zmień uprawnienia pliku /home/index.php na 644.

Pozdrawiam,

Zajonc
06-11-2007, 22:44
Witam,

Mam bodajrze identyczny problem jak autor watku. Do dzisiaj wszystko dzialalo ok, ale kiedy przed chwila postanowilem zaktualizowac jeden ze swoich plikow przez FTP to zaczalem dostawac informacje o bledzie wewnetrznym.
Sprawdzilem katalogi, maja poprawne uprawnienia. Probowalem zmienic kodowanie pliku raz na UTF-8 to znowu na ISO-8859-2 i tez nic. Inne pliki PHP wykonuja sie poprawnie, tylko ten jeden nie chce (chodzi o plik zajonc.ovh.org/home/index.php).

Czy poza pomoca mozna prosic o jakies sugestie jak sie ustrzec tego typu bledu? Wczesniej tez wrzucalem pliki przez FTP i wszystko dzialalo, wiec jesli to np. wina klienta FTP (nie pamietam czego uzywalem wczesniej, teraz wszystko leci przez gnome commandera) to taka informacja bylaby cenna.

Suchy
02-11-2007, 15:30
Znów
Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.
mimo tego, że wszystko jest dobrze poustawiane.

http://s9cropsearch.ovh.org

rtip
02-11-2007, 08:33
U mnie też nie działa php, konto:

rtip.ovh.org

bob123
30-10-2007, 08:33
@Crusty
http://60free.ovh.org/pl/support/faq.html#faq44

Crusty
29-10-2007, 21:05
Moje konto to: fms-bialystok.ovh.org

W katalogu www/phpPETITION/Connections/ mam plik petitionscript.php

Aby zainstalować moduł Petition Script PHP musiałem zmienić w tym pliku nazwę użytkownika (User_Name) oraz hasło (PASSWORD) zgodnie z tymi wskazówkami:

# FileName="Connection_php_mysql.htm"
# Type="MYSQL"
# HTTP="true"
$hostname_petitionscript = "localhost"; //<-- This setting as is usually works best
$database_petitionscript = "petitionscript"; //<-- LEAVE THIS ALONE unless... you want to host multiple petitions on the same
server, then change this name and create a blank database on your MySQL server to match this name
$username_petitionscript = "User_Name"; //<-- Replace "User_Name" with your username
$password_petitionscript = "PASSWORD"; //<-- Replace "PASSWORD" with your password
$petitionscript = mysql_pconnect($hostname_petitionscript, $username_petitionscript, $password_petitionscript) or
trigger_error(mysql_error(),E_USER_ERROR);
?>
Po edycji pliku otworzyłem instalator wpisując adres: http://www.fms-bialystok.ovh.org/phpPETITION/setup.php ale po chwili wyskoczył mi błąd:

Error Creating Security TableNo database selected
Zadałem adminowi pytanie na forum pomocy tego skryptu i otrzymałem taką odpowiedż:

Sure - love to help but you have a configuration issue in the phpPETITION\connections\petitionscript.php file.

Your error is saying that it cant find the database so the variable in the file above is no the same as what you have in MySQL. some ISP's prefix the name with your login username to the name of the database like username_PETITIONSCRIPT

this being the case change
to this
$database_petitionscript = "username_PETITIONSCRIPT"
Adminowi chodzi chyba o to, że zmienne w pliku petitionscript.php nie są takie same jak w MySQL. Niektórzy operatorzy zmieniają dane.

Czy jesteście w stanie doradzić mi coś w tej sytuacji? Szczerze powiedziawszy jestem amatorem i nie ogarniam jeszcze wszystkiego Dopiero się uczę.

Instrukcja instalacji Petition Script'a znajduje się TUTAJ

Suchy
28-10-2007, 11:39
U mnie to samo.
http://s1cropsearch.ovh.org

bob123
18-10-2007, 12:12
Powinno dzialac

Vic
17-10-2007, 18:35
i ja też mam ten sam problem...
www.ok2007.ovh.org

Proszę o pomoc ;-)

bob123
15-10-2007, 14:29
@oswwodnik
Masz zle uprawnienia na katalogu www. Poprawne to 755

oswwodnik
15-10-2007, 14:24
Proszę o pomoc, mam ten sam problem

http://www.oswwodnik.ovh.org/

pozdrawiam

bob123
15-10-2007, 08:44
Sprobuj teraz

tyoceth
12-10-2007, 23:46
Prosilbym o pomoc, mam ten sam problem

http://tyoceth.ovh.org/test.php

niestety nie dziala na 755.
pozdrawiam

boniek00
28-09-2007, 11:24
Już powinno być OK.

Pozdrawiam,

hidden_g0at
28-09-2007, 11:13
Moje konto to: yselthewitch.ovh.org
W katalogu www mam plik test.php z najprostszym skryptem:
test.php
Kod PHP:
phpinfo();
?>
i plik test2.php
Kod PHP:
echo "Witajże świecie!";
?>
Uprownienia powinny być ok, ale nie działa. Wyświetla błąd:
Kod:
 Witamy na stronie serwisu 60free firmy OVH.

Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.

Jeżeli jesteś właścicielem tego konta i szukasz informacji na temat probmemów z błędem wewnętrznym, zapraszamy na stronę http://60free.ovh.org/pl/support/ lub sprawdź czy:

- uprawnienia do uruchamianego zasobu '/y/s/e/yselthewitch/www/test.php' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,
- w pliku '.htaccess' nie znajdują się nieprawidłowe wpisy
chmody na plik ma ustawione na 755, ale próbowałem już różnie, na różnych plikach. Nic nie działa. Mogę prosić o pomoc?