We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem z MySQL


lukasgo
29-08-2007, 16:01
Niestey we wszystkich, które potrzebują sql w zapytaniach jest wartość default przy auto-increament, więc będę musiał sobie odpuścić ten dział download. Dzięki za pomoc.

mariano
29-08-2007, 15:09
Cytat Napisał lukasgo
W takim razie proszę o pomoc, w edycji zapytania. Jestem laikiem jeśli chodzi o sql i nie wiem, jak to zrobić.
Nie ma sensu, zebys poprawial za kogos oprogramowanie. Jesli te skrypty maja tak lamerskie bledy, lepiej znajdz sobie inne - po co sie meczyc...

lukasgo
29-08-2007, 14:48
W takim razie proszę o pomoc, w edycji zapytania. Jestem laikiem jeśli chodzi o sql i nie wiem, jak to zrobić. Próbowałem postawić download by bastek - tylko na php - http://urszul.ovh.org/down ale też nie reaguje

mariano
29-08-2007, 14:09
Cytat Napisał lukasgo
Podejrzewam, że to bład polecenia, lecz jest to gotowy skrypt i podobno "u innych działa"
Nie wierze, ze u innych dziala. Zob http://www.mysql.org/doc/refman/5.0/...ate-table.html

Note: There can be only one AUTO_INCREMENT column per table, it must be indexed, and it cannot have a DEFAULT value.

lukasgo
29-08-2007, 13:56
Witam! Ja mam podobny problem. Chcę zainstalować na stronie dział download. - w systemie pafiledb 3. po wrzuceniu plików na serwer, ustawieniu chmodów i wpisaniu bazy danych podczas procesu instalacji nic się nie dzieje. gdy próbowałem zaintalować inne menedżery download'u - phpdownload - to przy wykonywaniu zapytania "CREATE TABLE Downloads (
DownloadID int(11) DEFAULT '0' NOT NULL auto_increment,
Name varchar(80),
Description text,
FileSize int(11),
FileName varchar(255),
DownloadCount int(11),
Category int(11),
Redirect varchar(255) DEFAULT '',
PRIMARY KEY (DownloadID)
);" i
"CREATE TABLE Download_Cat (
DownloadCatID int(11) DEFAULT '0' NOT NULL auto_increment,
CatName varchar(50),
PRIMARY KEY (DownloadCatID)
);" baza wyrzuca błąd #1067 - Invalid default value for 'DownloadID i #1067 - Invalid default value for 'DownloadCatID' . Podejrzewam, że to bład polecenia, lecz jest to gotowy skrypt i podobno "u innych działa". Nie wiem jednak, co może być przyczyną błędów w instalacji pafiledb. Prosiłbym o pomoc. Adres do instalacji, która nie działa - urszul.ovh.org/download/install.php

sLoDkI
28-08-2007, 13:07
Cytat Napisał Macieksm
MySQL zwrócił komunikat:
#1142 - CREATE command denied to user 'macportal'@'localhost' for table 'fusion_admin'
Jak już było na forum - CREATE,INSERT,UPDATE itp są blokowane w momencie przekroczenia limitu 4MB bazy.

pozdrawiam.

MadDog
28-08-2007, 12:18
jezeli masz darmowke, to przerzuc sie tez na ten watek - widac wiecej osob ma ten problem...

http://forum.ovh.pl/showthread.php?t=6023

Macieksm
28-08-2007, 11:10
No właśnie......Mam to samo. Mogę wejść do phpMyAdmina, ale nie mogę zoptymalizować tabel i wczytać kopię bazy sprzed paru dni. Wogóle żadnych tabel nie mogę utworzyć. Co jest grane? Kto ma jakiś pomysł, bo już nie mam pojęcia jak ten problem rozwiązać.

MadDog
28-08-2007, 08:27
Nam wczoraj tez wyskoczylo to info #1142

Do tej pory oznaczalo to ze np. baza sie zapchala i nalezy ja przeczyscic - niestety nawet nie moge dokonac optymalizacji tabel bo tez mi wyskakuje info o braku dostepu.

Czy to jakas awaria bazy? (zrobilem juz truncate wielu tabel i baza zajmuje jedynie 1,7MB wiec powinno ruszyc w przypadku 'zapchania')

Macieksm
27-08-2007, 22:39
Witam.... Bardzo proszę o pomoc. Nagle zniknęły wszystkie table w bazie. Próbowałem wgrać kopię bazy, ale otrzymuję komunikat :

CREATE TABLE `fusion_admin` (
`admin_id` tinyint( 2 ) unsigned NOT NULL AUTO_INCREMENT ,
`admin_rights` char( 2 ) NOT NULL default '',
`admin_image` varchar( 50 ) NOT NULL default '',
`admin_title` varchar( 50 ) NOT NULL default '',
`admin_link` varchar( 100 ) NOT NULL default 'reserved',
`admin_page` tinyint( 1 ) unsigned NOT NULL default '1',
PRIMARY KEY ( `admin_id` )
) ENGINE = MYISAM AUTO_INCREMENT =50 DEFAULT CHARSET = latin1;


MySQL zwrócił komunikat:
#1142 - CREATE command denied to user 'macportal'@'localhost' for table 'fusion_admin'

Próbowałem inne kopie przywrócić i jest to samo. Bardzo proszę pomóżcie.....Tyle pracy poszło na marne :-(.....

Przy ponownej instalacji pojawia się komunikat :

CREATE command denied to user 'macportal'@'localhost' for table 'fusion_weblinks'Skrypt nie mógł stworzyć jednej lub więcej tabel w bazie danych.
Dlaczego tak się dzieje? Przecież instaluję tak jak zawsze...:-(