We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

dopisywanie polskich znaków do mysql


pozmywajgary
22-01-2006, 14:17
może to rozwiąże problem
http://forum.ovh.pl/showthread.php?t...=polskie+znaki
u mnie wreszcie działa
pzdr

kleksiq
01-12-2005, 14:26
mam to samo podczas importu bazy danych :/
niestety niezdołałem jak na razie rozwiązać tego problemu

qwerter
24-11-2005, 14:10
jest dokladnie tak czyli w kodowaniu strony iso w bazie kodowanie latin2_general_ci i po połączeniu przed wykonaniem zapytania właściwego set charset latin2. Niestety nie działa. Próbowałem też z latin2_bin i nie działa.

Jednak dodając w phpmyadmin polskie znaki są.

Problem rozwiązałem droga "na około", jednak mam nadzieję, że ktoś mi powie czemu nie moge zapisac ogonków do bazy

Łabędź
24-11-2005, 09:21
Cytat Napisał qwerter
Wiem ze temat czytania polskich znakow z mysql'a był poruszany, ja jednak chciałbym dpoisywac dane wprowadzone w formularzu (iso) do bazy mysql. Jednak pojawiaja sie znaki zapytania. W bazie mam ustawiony latin2, po połączeniu ustawiam ten tryb konwersji znaków. Jednak ciągle wystakują pytajniki.

jak skonwertowac dane z formularza tak aby potem mozna było odczytac polskie znaki z bazy??

z góry dziękuje za pomoc.
Nie trzeba nic konwertować.
Jak to było pisane wcześniej. Po połączeniu do bazy 'set charset latin2'. Tabela ma mieć ustawiony charset 'latin2'. Strona musi mieć ustawiony charset 'iso-8859-2'. Musi działać.

pozdrawiam

qwerter
23-11-2005, 21:13
Wiem ze temat czytania polskich znakow z mysql'a był poruszany, ja jednak chciałbym dpoisywac dane wprowadzone w formularzu (iso) do bazy mysql. Jednak pojawiaja sie znaki zapytania. W bazie mam ustawiony latin2, po połączeniu ustawiam ten tryb konwersji znaków. Jednak ciągle wystakują pytajniki.

jak skonwertowac dane z formularza tak aby potem mozna było odczytac polskie znaki z bazy??

z góry dziękuje za pomoc.