We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

upgrade


zebol
13-08-2007, 15:30
Odpaliłem
Kod PHP:
emerge --info
Portage 2.1.2.11 
(default-linux/x86/2007.0/desktopgcc-4.1.2glibc-2.5-r42.4.33grs-bipiv-ipv4-32 i686)
=================================================================
System uname2.4.33grs-bipiv-ipv4-32 i686 Intel(RPentium(R4 CPU 3.00GHz
Gentoo Base System release 1.12.9
Timestamp of tree
Sun12 Aug 2007 18:30:10 +0000
dev
-lang/python:     2.4.4-r4
dev
-python/pycrypto2.0.1-r6
sys
-apps/sandbox:    1.2.17
sys
-devel/autoconf:  2.132.61
sys
-devel/automake:  1.4_p61.51.6.31.7.9-r11.8.5-r31.9.6-r21.10
sys
-devel/binutils:  2.17
sys
-devel/gcc-config1.3.16
sys
-devel/libtool:   1.5.23b
virtual
/os-headers:  2.6.21
ACCEPT_KEYWORDS
="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=i686 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=i686 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sfperms strict"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/"
LANG="pl_PL"
LINGUAS="pl de fi en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage-ovh"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="**+curl** acl acpi alsa arts berkdb bitmap-fonts cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox gdbm gif gnome gpm gstreamer hal iconv ipv6 isdnlog jpeg kde kerberos ldap mad midi mikmod mmx mp3 mpeg mudflap ncurses ogg opengl openmp oss pam pcre pdf perl png pppd python qt3 qt3support qt4 quicktime readline reflection session spell spl sse sse2 ssl svg tcpd tiff truetype truetype-fonts type1-fonts unicode vorbis win32codecs x86 xml xorg xv" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl de fi en" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CTARGETEMERGE_DEFAULT_OPTSINSTALL_MASKLC_ALLLDFLAGSPORTAGE_COMPRESSPORTAGE_COMPRESS_FLAGSPORTAGE_RSYNC_EXTRA_OPTS 
Następnie:
emerge -pvuD system
Otrzymałem:
Kod PHP:
These are the packages that would be mergedin order:

Calculating system dependencies /
!!! 
Ebuilds for the following packages are either all
!!! masked or don't exist:
virtual/dev-manager
                                                                                                                                                           ... done!
[ebuild     U ] sys-devel/gcc-3.4.6-r2 [3.4.6-r1] USE="(-altivec) -bootstrap -boundschecking -build -d% -doc -fortran* -gcj -gtk (-hardened) -ip28 -ip32r10k (-multilib) -multislot (-n32) (-n64) -nls* -nocxx -nopie -nossp -objc -test% -vanilla" 27,700 kB

Total: 1 package (1 upgrade), Size of downloads: 27,700 kB 
Odpaliłem następnie emerge --resume

I lipa...........
make: *** [devfsd.o] Błąd 1

!!! ERROR: sys-fs/devfsd-1.3.25-r9 failed.
Call stack:
ebuild.sh, line 1632: Called dyn_compile
ebuild.sh, line 983: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
ebuild.sh, line 657: Called die
co jest nie tak ?

bob123
13-08-2007, 15:09
A probowalas pobawic sie z tym iproute2? Zobaczy czy jest zainstalowany w systemie, przekompilowac go, zrobic downgrade?

zebol
13-08-2007, 14:05
Cytat Napisał bob123
Czy emerge -pvuD system konczy sie pomyslnie?
Otrzymuje:
Kod:
These are the packages that would be merged, in order:

Calculating system dependencies... done!
[ebuild     U ] sys-libs/glibc-2.5-r4 [2.3.6-r3] USE="nls nptlonly* -build -debug% -glibc-compat20 -glibc-omitfp (-hardened) (-multilib) -nptl -profile (-selinux) (-erandom%) (-linuxthreads-tls%) (-pic%) (-userlocales%)" 0 kB
[ebuild     U ] sys-devel/gcc-3.4.6-r2 [3.4.6-r1] USE="fortran nls (-altivec) -bootstrap -boundschecking -build -d% -doc -gcj -gtk (-hardened) -ip28 -ip32r10k (-multilib) -multislot (-n32) (-n64) -nocxx -nopie -nossp -objc -test% -vanilla" 27,700 kB

Total: 2 packages (2 upgrades), Size of downloads: 27,700 kB

Edit:
Dodałem:
USE="-nptlonly -nptl -curl -X mmx sse sse2 -gtk -sdl -nptl -xpm -zlib **+curl**"

bob123
13-08-2007, 12:12
Czy emerge -pvuD system konczy sie pomyslnie?

zebol
13-08-2007, 11:12
daje polecenie emerge -e world
i zawsze konczy na:

!!! ERROR: sys-apps/iproute2-2.6.19.20061214 failed.

teraz dałem polecenie: emerge gcc - moze pomoze.

podczas proby restartu apacha mam bład:
/usr/local/apache/bin/httpd: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory

i wszystkie domeny: Internal Server Error
nie wiem gdzie jest konkretnie blad.

bob123
13-08-2007, 10:58
Kod:
Co nie wykonam - doczepia się ciągle do:
sys-apps/iproute2-2.6.19.20061214 failed.
Nie rozumiem, mozesz napisac jasniej co oznacza 'doczepia sie'?

zebol
13-08-2007, 10:50
Kombinuje jak moge.
Co nie wykonam - doczepia się ciągle do:
sys-apps/iproute2-2.6.19.20061214 failed.

I dalsza aktualizacja nie ma miejsca.
Jak to obejść ? Może reinstall systemu ?

bob123
13-08-2007, 10:33
Jezeli masz zainstalowana poczke gentoolkit to:

Kod:
equery b nazwa_pliku
W wyniku dostaniesz nawze paczki, do ktorej nalezy plik.

zebol
13-08-2007, 09:34
WYkonałem polecenie

emerge -e world
i aktualizacja zatrzymuje sie na pakiecie

!!! ERROR: sys-apps/iproute2-2.6.19.20061214 failed.
Call stack:
ebuild.sh, line 1632: Called dyn_compile
ebuild.sh, line 983: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
iproute2-2.6.19.20061214.ebuild, line 69: Called die

!!! make
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/sys-apps/iproute2-2.6.19.20061214/temp/build.log'.


Jak to naprawić ?

zebol
12-08-2007, 21:42
aktualizacja:
emerge --sync
emerge portage
emerge -uD system
emerge -uD world

Po wykonaniu otrzymuje błąd:
Kod PHP:
/usr/local/apache/bin/httpderror while loading shared librarieslibexpat.so.0cannot open shared object fileNo such file or directory 
Gdzie jest błąd ?

Mam kumunikat na wszytkich domenach : Internal Server Error