We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

jak zainstalowac pdo mysql drivers w release 2 ovh?


borec
01-10-2008, 14:45
Jeśli nie boisz się popsuć, zakomentuj linijkę z php i zrob emerge php (z odpowiednimi flagami use).

gonzek
30-09-2008, 20:23
Cytat Napisał borec
Pokaż /etc/portage/package.provided.
/etc/portage/profile/package.provided

www-servers/apache-2.0.58
dev-lang/php-5.1.4
mail-mta/qmail-1.03
net-www/apache-2.0.59

borec
22-08-2008, 11:09
Cytat Napisał danthe
u mnie to polecenie wyswietla cos takiego :

Kod:
These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

WARNING: A requested package will not be merged because it is listed in
package.provided:

  php pulled in by 'args'
Pokaż /etc/portage/package.provided.

danthe
14-08-2008, 21:26
u mnie to polecenie wyswietla cos takiego :

Kod:
These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

WARNING: A requested package will not be merged because it is listed in
package.provided:

  php pulled in by 'args'

borec
14-08-2008, 12:32
Kod:
USE="mysql pdo" emerge -av php
Spod roota oczywista.

artux
13-08-2008, 16:17
Release 2 to bardzo "specyficzna" dystrybucja. OVH nie zaleca jakiejkolwiek dłubaniny i chyba słusznie bo bardzo łatwo rozsypać system. Niestety jeśli nie wystarcza to co jest trzeba przejść na surowe distro.

danthe
13-08-2008, 15:02
rowniez przylaczam sie do pytania...

gonzek
14-07-2008, 17:59
Przyłączam się do pytania... Mi w ogóle nic nie znajduje.

Jak zainstalować sterownik PDO dla MySQLa?

PiotrKarwatka
02-08-2007, 10:29
Jak zainstalowac pdo drivers for mysql standardowo jest wsparcie tylko dla sqllite. Serwer dziala na php 5.1.4 i gento release 2 ovh. Gdy prbouje zrobic
Kod:
emerge dev-php5/pecl-pdo
otrzymuje
Kod:
Calculating dependencies ...done!
>>> emerge (1 of 2) dev-php5/pecl-pdo-1.0.3 to /
>>> md5 files   ;-) pecl-pdo-1.0.3.ebuild
>>> md5 files   ;-) files/pecl-pdo-1.0.3-verscheck.patch
>>> md5 files   ;-) files/digest-pecl-pdo-1.0.3
>>> md5 src_uri ;-) PDO-1.0.3.tgz
 *
 * Using
 *

!!! ERROR: dev-php5/pecl-pdo-1.0.3 failed.
!!! Function built_with_use, Line 1681, Exitcode 0
!!! Unable to resolve = to an installed package
!!! If you need support, post the topmost build error, NOT this status message.
Jak to zrobic? Probowal ktos? Ew. aktualizacja PHP? Wolalbym jej uniknac.

Dzieki