We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

clean url


shamanos
27-07-2007, 11:05
udało sie
Wklejałem:
Kod:
RewriteEngine on
   RewriteBase /drupal # drupal - katalog, w ktorym zainstalowalem drupala
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
zamiast
Kod:
RewriteEngine on
   RewriteBase /drupal
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
Teraz zainstalowalem sobie drupala nie uzywajac modulu i jest on bezposrednio w folderze www, czyli kod wystarczy taki:
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
????

pozdrawiam, i dziekuje za pomoc

bob123
27-07-2007, 09:14
Twoj .htaccess napewno wyglada tak? Az nie chce mi sie wierzyc, ze to nie dziala, sam testuje na 90plan i wszystko dziala
Kod:
RewriteEngine on
   RewriteBase /drupal
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

shamanos
26-07-2007, 16:06
kiedy usune drual dziala normalnie, ale przyjaznych adresow dalej nie moge wlaczyc

bob123
26-07-2007, 15:19
Upewnij sie ze poprawnie wkleiles zawartosc, bo cos jest nie tak z .htaccessem.

shamanos
26-07-2007, 15:05
gdy usune pojawia sie normalny drupal ,ale przyjaznych adresow nie da sie wlaczyc

bob123
26-07-2007, 12:52
Usun na chwile .htaccess i zobacz czy dalej bedziesz mial ten blad.

shamanos
26-07-2007, 12:18
:/ kiedy ja tak zrobie wyswietla mi sie blad jak na zdjeciu: http://img443.imageshack.us/img443/5...ordrupapq3.jpg

bob123
26-07-2007, 09:37
ale ja mam plan90
www.telefoniczna.ovh.org <--- to mnie zmililo

Ja zrobilem tak:
1. Zainstalowalem drupala z poziomu managera w katalogu drupal
2. Nastepnie w katalogu drupal (na koncie) stworzylem plik .htaccess o takiej zawartosci:

Kod:
RewriteEngine on
   RewriteBase /drupal # drupal - katalog, w ktorym zainstalowalem drupala
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
Udalo sie przejsc test i aktywowac przyjazne urle

shamanos
25-07-2007, 17:06
ale ja mam plan90

bob123
25-07-2007, 15:52
Na 60free nie uzyskasz 'przyjaznych adresow' poniewaz na serwerze nie ma mod_rewrite.

shamanos
25-07-2007, 15:48
a wiec normalnie cms drupal wyglada jak na stronce www.telefoniczna.ovh.org
Zeby wlaczyc w nim clean url trzeba przeprowadzic jakis test. Naciskam zeby przeprowadzilo i mi sie pokazujenie zawartosc strony, ale jakby nie została przerobiona przez żaden szablon-na fotce: http://img61.imageshack.us/img61/4642/cleanurlvn0.jpg
Z tego wnioskuje ze to cos z konfiguracja serwera.
Na forum http://drupal.letwist.net/node/439 ktos mial podobny problem i tm wystarczyl jakis wpis w settings.php , ale u mnie juz byl odrazu taki sam wpis i tez nie dziala :/

bob123
25-07-2007, 13:24
Ale mozesz podac wiecej szczegolow? Co dokladnie jest nie tak? Podaj jakies przyklady

shamanos
25-07-2007, 13:21
ok, ale co jest nie tak, co musze zrobic aby zaczely dzialac?

bob123
25-07-2007, 08:39
Za 'przyjazne adresy' odpowiada ta sekcja:

Kod:

  RewriteEngine on

  # If your site can be accessed both with and without the prefix www. you
  # can use one of the following settings to force user to use only one option:
  #
  # If you want the site to be accessed WITH the www. only, adapt and
  # uncomment the following:
  # RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
  # RewriteRule .* http://www.example.com/ [L,R=301]
  #
  # If you want the site to be accessed only WITHOUT the www. prefix, adapt
  # and uncomment the following:
  # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
  # RewriteRule .* http://example.com/ [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory and
  # the rewrite rules are not working properly.
  #RewriteBase /drupal

  # Rewrite old-style URLs of the form 'node.php?id=x'.
  #RewriteCond %{REQUEST_FILENAME} !-f
  #RewriteCond %{REQUEST_FILENAME} !-d
  #RewriteCond %{QUERY_STRING} ^id=([^&]+)$
  #RewriteRule node.php index.php?q=node/view/%1 [L]

  # Rewrite old-style URLs of the form 'module.php?mod=x'.
  #RewriteCond %{REQUEST_FILENAME} !-f
  #RewriteCond %{REQUEST_FILENAME} !-d
  #RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
  #RewriteRule module.php index.php?q=%1 [L]

  # Rewrite current-style URLs of the form 'index.php?q=x'.
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

shamanos
23-07-2007, 19:22
Witam kiedy robie test czy moge wlaczyc przyjazne adresy drupal przyjmuje nastepujaca postac: http://img61.imageshack.us/img61/4642/cleanurlvn0.jpg Chce rozpoczac tworzenie stronki, ale nie mam pojecia co trzeba zrobic. Prosze o pomoc
moj .htacces wyglada tak
Kod PHP:
#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "(\.(engine|inc|info|install|module|profile|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)|code-style\.pl|Entries.*|Repository|Root|Tag|Template)$">
  
Order allow,deny
FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Customized error messages.
ErrorDocument 404 /index.php

# Set the default handler.
DirectoryIndex index.php

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1.
<IfModule mod_php4.c>
  
php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session
.auto_start              0
IfModule>

# PHP 4, Apache 2.
<IfModule sapi_apache2.c>
  
php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session
.auto_start              0
IfModule>

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  
php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session
.auto_start              0
IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
  
# Enable expirations.
  
ExpiresActive On
  
# Cache all files for 2 weeks after access (A).
  
ExpiresDefault A1209600
  
# Do not cache dynamically generated pages.
  
ExpiresByType text/html A1
IfModule>

# Various rewrite rules.
<IfModule mod_rewrite.c>
  
RewriteEngine on

  
# If your site can be accessed both with and without the prefix www. you
  # can use one of the following settings to force user to use only one option:
  #
  # If you want the site to be accessed WITH the www. only, adapt and
  # uncomment the following:
  # RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
  # RewriteRule .* http://www.example.com/ [L,R=301]
  #
  # If you want the site to be accessed only WITHOUT the www. prefix, adapt
  # and uncomment the following:
  # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
  # RewriteRule .* http://example.com/ [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory and
  # the rewrite rules are not working properly.
  #RewriteBase /drupal

  # Rewrite old-style URLs of the form 'node.php?id=x'.
  #RewriteCond %{REQUEST_FILENAME} !-f
  #RewriteCond %{REQUEST_FILENAME} !-d
  #RewriteCond %{QUERY_STRING} ^id=([^&]+)$
  #RewriteRule node.php index.php?q=node/view/%1 [L]

  # Rewrite old-style URLs of the form 'module.php?mod=x'.
  #RewriteCond %{REQUEST_FILENAME} !-f
  #RewriteCond %{REQUEST_FILENAME} !-d
  #RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
  #RewriteRule module.php index.php?q=%1 [L]

  # Rewrite current-style URLs of the form 'index.php?q=x'.
  
RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond 
%{REQUEST_FILENAME} !-d
  RewriteRule 
^(.*)$ index.php?q=$[L,QSA]
IfModule>

# $Id: .htaccess,v 1.81 2007/01/09 09:27:10 dries Exp $ 
pro