We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem z .htaccess


FatBoy
19-06-2007, 11:59
znalazlem tam juz wczesniej ze to sie poprzez Manager OVH robi, problem tylko w tym, ze nie mam w nim ikonki Emaile, co wedlug przewodnika powinno byc Dlatego zapytalem sie jak to sie je by dzialalo. Jedyne co mam zwiazanego z emailem to grupy mailingowe

bob123
19-06-2007, 09:14
Przejzyj http://pomoc.ovh.pl/przewodniki, moze znajdziesz to czego szukasz.

FatBoy
19-06-2007, 00:49
jak to czasami trudno wpasc na oczywiste rozwiazanie

Tak z innej beczki, gdzie moge poczytac jak sie ustawia konta mailowe? Dokladnie chodzi o to, ze tworze konto np. admin i on ma maila admin@costam.ovh.net lub admin@nazwa_domeny.pl ??

bob123
18-06-2007, 08:24
Gdzie jest plik do konfiguracji php??
W 'wydruku' phpinfo() powinno byc: Configuration File (php.ini) Path

FatBoy
15-06-2007, 16:39
przyjazne linki dzialaja poprawnie. Zrobilem test phpinfo() i register globals sa off, jedynie przy zmiennych srodowiskowych register globals sa 1, ale mi zalezy by register globals byly on Gdzie jest plik do konfiguracji php??

plik .hataccess wyglada teraz tak:
SetEnv REGISTER_GLOBALS 1

RewriteEngine On
RewriteRule (Samochody)/(.+)/(.+)/([0-9]+)/([0-9]+) /index.php?marka=$2&model=$3&opcja=show&a=$1&idmark i=$4&idmodel=$5
RewriteRule (Samochody)/(.+)/(.+)/([0-9]+) /index.php?marka=$2&model=$3&opcja=detail&a=$1&idpo jazd=$4
RewriteRule (Samochody)/(.+)/([0-9]+) /index.php?marka=$2&opcja=listmod&a=$1&idmarki=$3
RewriteRule (Samochody) /index.php?a=$1
RewriteRule (Motocykle)/(.+)/(.+)/([0-9]+)/([0-9]+) /index.php?marka=$2&model=$3&opcja=show&a=$1&idmoto rs=$4&idmodel=$5
RewriteRule (Motocykle)/(.+)/(.+)/([0-9]+) /index.php?marka=$2&model=$3&opcja=detail&a=$1&idpo jazd=$4
RewriteRule (Motocykle)/(.+)/([0-9]+) /index.php?marka=$2&opcja=listmod&a=$1&idmotors=$3
RewriteRule (Motocykle) /index.php?a=$1
RewriteRule (Ostatnio.Dodane)/(.+) /index.php?a=dodane&data=$2
RewriteRule (Ostatnio.Dodane) /index.php?a=dodane
RewriteRule (Ranking) /index.php?a=$1
RewriteRule (Wyszukiwarka) /index.php?a=szukaj

FatBoy
15-06-2007, 11:12
Ja mam natomiast inny problem. Po wrzuceniu .htaccess do katalogu ze strona w ogole nie odczuwa sie zmian. Tak jakby go w ogole nie bylo. Przez co stronka mi zle dziala
plik wyglada tak:

SetEnv REGISTER_GLOBALS 1
SetEnv PHP_VER 5

ErrorDoc 404 "Na serwerze nie ma takiego dokumentu"
ErrorDoc 403 http://www.polkajazda.pl

RewriteEngine On
RewriteRule (Samochody)/(.+)/(.+)/([0-9]+)/([0-9]+) /index.php?marka=$2&model=$3&opcja=show&a=$1&idmark i=$4&idmodel=$5
RewriteRule (Samochody)/(.+)/(.+)/([0-9]+) /index.php?marka=$2&model=$3&opcja=detail&a=$1&idpo jazd=$4
RewriteRule (Samochody)/(.+)/([0-9]+) /index.php?marka=$2&opcja=listmod&a=$1&idmarki=$3
RewriteRule (Samochody) /index.php?a=$1
RewriteRule (Motocykle)/(.+)/(.+)/([0-9]+)/([0-9]+) /index.php?marka=$2&model=$3&opcja=show&a=$1&idmoto rs=$4&idmodel=$5
RewriteRule (Motocykle)/(.+)/(.+)/([0-9]+) /index.php?marka=$2&model=$3&opcja=detail&a=$1&idpo jazd=$4
RewriteRule (Motocykle)/(.+)/([0-9]+) /index.php?marka=$2&opcja=listmod&a=$1&idmotors=$3
RewriteRule (Motocykle) /index.php?a=$1
RewriteRule (Ostatnio.Dodane)/(.+) /index.php?a=dodane&data=$2
RewriteRule (Ostatnio.Dodane) /index.php?a=dodane
RewriteRule (Ranking) /index.php?a=$1
RewriteRule (Wyszukiwarka) /index.php?a=szukaj

RewriteEngine On
RewriteCond %{HTTP_REFERER} !^http://(www\.)polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)volkswagen\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)opel\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)fiat\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)ford\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)honda\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)bmw\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)renault\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)nissan\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)peugot\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)audi\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)romet\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)simson\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)yamaha\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)suzuki\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)mz\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)jawa\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)aprilia\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)kawasaki\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)wsk\.polskajazda\.pl [NC]
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} ^http://.*$
RewriteRule \.(jpe?g|gif|bmp|png)$ /foto/foto-mini/profil.png [NC,L]

invx
31-05-2007, 21:05
mam taki sam problem - po wrzuceniu

arg_separator.input = ";&"
arg_separator.output = "&"

wywala blad

- na innych serverach taka opcja dziala - wiec w jaki inny sposob mozna zamienic to co wyzej - bez tego lezy walidacja.

Siemen
05-05-2007, 15:21
ok rozumiem, to prosze mi powiedziec jak mam sie pozbyc &PHPSESSID=....... ktore jest doklejane do adresow ?
Prosze wpisac site:www.klikplej.pl w google ... te same strony sa indeksowane po pare razy np. www.klikplej.pl i http://www.klikplej.pl/?PHPSESSID=12...132346c0f7dc11 licze na szybka odpowiedz bo wina lezy chyba po stronie serwera (wczesniej jak mialem strone na innym serwerze to nie bylo problemu )

PS. w pierwszym poście zapomniałem wkleić jeszcze
php_value session.use_only_cookies 1
php_value session.use_trans_sid 0

ale wrzucenie tego do .htaccess też powodowało błąd


Problem rozwiązany, pomogło wrzucenie jednej linijki przed session_start();

bob123
02-05-2007, 08:36
Nie ma mozliowsci zmiany tych ustawien na sewerach wirtualnych za pomoca .htaccess

http://us2.php.net/configuration.changes

Siemen
01-05-2007, 02:53
Witam,

po wrzuceniu .htaccess do katalogu głównego wyrzuca mi błąd na stronie www.klikplej.pl


250
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, tech@ovh.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.



--------------------------------------------------------------------------------

Apache/1.3.37 Server at www.klikplej.pl Port 80
0



mój .htaccess wygląda tak:

php_value arg_separator.input ";&"
php_value arg_separator.output "&"


Wszystkim odpowiednim katalogom i skryptom nadałem CHMOD 705 lub 755

Z góry dziękuje za pomoc.