We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

K這poty z prawid這wym wy鈍ietlaniem polskich znak闚 w Coppermine Photo Gallery.


fotoarte
12-12-2006, 17:02
Cytat Napisa mariano
Mowilem Ci: pewnie jada na jakis zabytkowych wersjach mysql.
Nieprawdopodobne 瞠by軼ie to tylko Wy byli najnowocze郾iejsi na 鈍iecie, a inni pracowali na zabytkach muzealnych. A mi si nie chce w to wierzy.

mariano
12-12-2006, 09:16
Mowilem Ci: pewnie jada na jakis zabytkowych wersjach mysql.

fotoarte
12-12-2006, 08:44
Bardzo ciekawe, 瞠 na innych serwerach nie ma takich problem闚, a tylko tutaj.

mariano
12-12-2006, 08:27
Cytat Napisa fotoarte
ani te wina tw鏎c闚 Copermine Photo Gallery oraz Joomla
Kod:
        $query2 = "CREATE TABLE #__zoom ("
            . "\n catid int(11) NOT NULL auto_increment,"
           ...
            . "\n KEY rel_subcats (subcat_id)"
            . "\n ) TYPE=MyISAM";
Tworza tablice bez definiowania wlasciwego kodowania. Wszelkie zazalenia kieruj zatem do tworcow joomli albo skladnika zoom.

fotoarte
11-12-2006, 21:58
Na innym koncie zainstalowałem sobie Joomla. I w jego przypadku też są podobne problemy. W Zoom Gallery stworzyłem kategorię składającą się tylko z polskich liter. I proszę sobie zerknąć (http://mggal.ovh.org/index.php?optio...zoom&Itemid=30) i zobaczyć ile tam krzaczorów jest. Naprawdę żałosne to wszystko jest. To już chyba jednak nie moja wina jest, ani też wina twórców Copermine Photo Gallery oraz Joomla w tym, że i w galerii, i w tym CMS-ie pojawiają się takie same błędy. Wyraźnie wskazuje to na błędne ustawienia serwera, niestety. Bardzo proszę zatem zrobić coś z tym póki jeszcze nie straciłem do końca cierpliwości do tego darmowego hostingu.

fotoarte
11-12-2006, 17:35
No, niestety. Kolejne zainstalowanie CPG z innego 廝鏚豉 nic u mnie nie da這. Problem pozosta. Teraz, to juz totalna za豉mka. B璠 chyba musia poszuka sobie innego serwera.

fotoarte
11-12-2006, 16:39
Cytat Napisa mariano
Sciagnij coppermine z tej samej lokalizacji co ja: http://ovh.dl.sourceforge.net/source.../cpg1.4.10.zip.
Spr鏏uj jeszcze tej mozliwo軼i. C騜 mi pozostaje.
Cytat Napisa mariano
Moze uzywasz jakiejs archaicznej wersji.
Nie s康z. Sw鎩 plik galerii 軼i庵a貫m z http://coppermine-gallery.net/, czyli ze strony firmowej Coppermine Photo Gallery. Raczej chyba na tej stronie nie oferowaliby bubli.

mariano
11-12-2006, 16:24
Zobacz moja galerie. Zainstalowalem ja przed chwila. Wpisalem dane bazy i wszystko smiga - nie musialem nic mieszac.

Sciagnij coppermine z tej samej lokalizacji co ja: http://ovh.dl.sourceforge.net/source.../cpg1.4.10.zip. Moze uzywasz jakiejs archaicznej wersji.

fotoarte
11-12-2006, 16:04
Cytat Napisa mariano
Bo za trzecim razem ustawisz poprawnie kodowanie na iso-8859-2. Powodzenia.
Poprzednio kodowanie było ustawione tak samo. Zawsze bowiem ustawiam kodowanie na ISO-8859-2. I w tym układzie jest jeszcze większy kłopot. Bowiem na stronie jest jeszcze więcej krzaczków. Zapraszam na stronę http://komg.ovh.org/ i proszę sobie to wszystko pooglądać. Jednym słowem beznadzieja. Czy już naprawdę nie da się z tym nic zrobić?

mariano
11-12-2006, 15:03
Bo za trzecim razem ustawisz poprawnie kodowanie na iso-8859-2. Powodzenia.

fotoarte
11-12-2006, 14:54
Cytat Napisa mariano
Pisalem Ci: zainstaluj coppermine jeszcze raz ustawiajac wlasciwe kodowanie.
W徠pi aby to pomog這. Instalowa貫m bowiem CPG ju 2 razy i problem ca造 czas si powtarza. Niby dlaczego za trzecim razem mia這by by inaczej?

mariano
11-12-2006, 14:50
Pisalem Ci: zainstaluj coppermine jeszcze raz (z innym prefiksem tabel) ustawiajac wlasciwe kodowanie.

fotoarte
11-12-2006, 14:39
Cytat Napisa mariano
Nie zniechecaj sie. W koncu Ci sie uda.
Niby jak, je郵i nie wiem co mam robi?

fotoarte
11-12-2006, 14:34
Cytat Napisa mariano
Odpowiedzialnosc za ustawienie wlasciwego kodowania tabel spoczywa po stronie cms-a.
Po pierwsze, to Coppermine Photo Gallery nie jest 瘸dnym CMS-em, ale tylko i wy豉cznie skryptem galerii.
Cytat Napisa mariano
Jesli autorzy coppermine nie przewidzieli takiej opcji, to moge Ci powiedziec tylko tyle, ze uzywasz oprogramowania niedostosowanego do swoich potrzeb i umiejetnosci.
Ca造 k這pot w tym, 瞠 na innym darmowym serwerze (zrezygnowa貫m z niego, bo tam jest zakaz umieszczania jakichkolwiek reklam na stronie) ten sam Copermine Photo Gallery nie sprawia takich problem闚 jak tu.
Cytat Napisa mariano
Zaden administrator nie jest w stanie przewidziec, w jakim kodowaniu Twoj cms bedzie umieszczal dane w bazie. Dalismy domyslnie "latin2" zakladajac, ze to bedzie najpopularniejszy wybor. Jesli jednak coppermine wrzuca dane w utf-8 i w zaden sposob nie informuje o tym bazy sql, to niestety musisz pogodzic sie z tym, ze w przypadku coppermine gallery nie wszystko zrobi Ci sie "automatycznie".
Wydaje mi si, 瞠 to ju wyja郾i貫m wcze郾iej.

mariano
11-12-2006, 14:08
Cytat Napisa fotoarte
Brak mi ju nerw闚 na to wszystko. Jak dla mnie, to wszystko jest zbyt skomplikowane.
Nie zniechecaj sie. W koncu Ci sie uda.

mariano
11-12-2006, 14:05
Cytat Napisa fotoarte
Photo Gallery nawet nie zagl康a貫m do bazy, bo ona tworzy豉 si samoczynnie przy instalacji. Wed逝g mnie, to b喚dy s w samym serwerze, a nie po mojej stronie. Uwa瘸m, 瞠 jak baza danych tworzy si samoczynnie, to ju wszystko powinno by przez administratora serwera prawid這wo poustawiane, a nie 瞠bym ja jeszcze musia p騧niej si "gimnastykowa".
Odpowiedzialnosc za ustawienie wlasciwego kodowania tabel spoczywa po stronie cms-a. Jesli autorzy coppermine nie przewidzieli takiej opcji, to moge Ci powiedziec tylko tyle, ze uzywasz oprogramowania niedostosowanego do swoich potrzeb i umiejetnosci. Zaden administrator nie jest w stanie przewidziec, w jakim kodowaniu Twoj cms bedzie umieszczal dane w bazie. Dalismy domyslnie "latin2" zakladajac, ze to bedzie najpopularniejszy wybor. Jesli jednak coppermine wrzuca dane w utf-8 i w zaden sposob nie informuje o tym bazy sql, to niestety musisz pogodzic sie z tym, ze w przypadku coppermine gallery nie wszystko zrobi Ci sie "automatycznie".

Najlepiej zacznij od poczatku. Przy instalacji coppermine ustaw kodowanie znakow na iso-8859-2. Zob. punkt 4.12.2 na stronie http://coppermine-gallery.net/demo/c...l_screen_start

fotoarte
11-12-2006, 13:54
Brak mi ju nerw闚 na to wszystko. Jak dla mnie, to wszystko jest zbyt skomplikowane.

fotoarte
11-12-2006, 13:24
Cytat Napisa mariano
Hosting i bazy sql dzialaja u nas poprawnie.
A u mnie nie, niestety.
Cytat Napisa mariano
Popelniasz elementarne bledy zwiazane z kodowaniem bazy danych.
Jakie konkretnie? Przecie ja podczas instalacji Coppermine Photo Gallery nawet nie zagl康a貫m do bazy, bo ona tworzy豉 si samoczynnie przy instalacji. Wed逝g mnie, to b喚dy s w samym serwerze, a nie po mojej stronie. Uwa瘸m, 瞠 jak baza danych tworzy si samoczynnie, to ju wszystko powinno by przez administratora serwera prawid這wo poustawiane, a nie 瞠bym ja jeszcze musia p騧niej si "gimnastykowa"
Cytat Napisa mariano
Poczytaj wczesniejsze posty na forum (na gorze masz opcje "Szukaj") na ten temat.
Ju to w豉郾ie zrobi貫m, ale nie znalaz貫m nigdzie rozwi您ania tego problemu.
Cytat Napisa mariano;21797}Zacznij od: [url
http://forum.ovh.pl/archive/index.php/t-246.html[/url] (posty Labedzia).
Niewiele z tego rozumiem. Nie jestem bieg造 w PHP i temu podobnych historiach, a tam jest pe軟o skr鏒闚 my郵owych i okre郵e zrozumia造ch wy陰cznie dla fachowc闚 od PHP. Poza tym podany tam te jest link do jakiej wy陰cznie angloj瞛ycznej strony, kt鏎y do niczego mi si nie przyda, bo po prostu nie znam angielskiego.

mariano
11-12-2006, 10:46
Cytat Napisa fotoarte
Co mi si wydaje, 瞠 ten ca造 darmowy hosting i te nieszcz瘰ne forum, to jest jakie jedno wielkie nieporozumienie. Dzia pomocy w豉軼iciela tego hostingu nie jest w stanie pom鏂 i odsy豉 na te forum. Z kolei tutaj nikt nie raczy si odezwa.
A pomyslales, ze w sobote nie ma nikogo w pracy?

Hosting i bazy sql dzialaja u nas poprawnie. Popelniasz elementarne bledy zwiazane z kodowaniem bazy danych. Poczytaj wczesniejsze posty na forum (na gorze masz opcje "Szukaj") na ten temat. Zacznij od: http://forum.ovh.pl/archive/index.php/t-246.html (posty Labedzia).

fotoarte
11-12-2006, 09:51
Co mi si wydaje, 瞠 ten ca造 darmowy hosting i te nieszcz瘰ne forum, to jest jakie jedno wielkie nieporozumienie. Dzia pomocy w豉軼iciela tego hostingu nie jest w stanie pom鏂 i odsy豉 na te forum. Z kolei tutaj nikt nie raczy si odezwa. I k馧eczko si jednym s這wem zamyka. Trzeba b璠zie chyba to wszystko "nada" do programu "妃iechu warte".

fotoarte
09-12-2006, 08:06
Po zainstalowaniu CPG na darmowym koncie 60free we wszystkich wpisach dokonanych przeze mnie z poziomu administratora zamiast polskich liter pojawiają się krzaczki (http://komg.ovh.org). Usiłowałem już wcześniej uzyskać pomoc w tej sprawie pod adresami pomoc@ovh.pl i pomoc@60free.ovh.pl, ale odesłano mnie stamtąd tu, na forum. Trochę to według mnie dziwne i smieszne zarazem żeby właściciele serwera nie byli w stanie pomóc.