We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem z jportal problem z zapytaniem sql


K@iTO
09-11-2005, 00:37
OK problem rozwiazany

Oto wynik

Test pozdrowien


To jest prawidłowe zapytanie do bazy Sql
Kod:
CREATE TABLE pozdrowienia (
id int(11) NOT NULL auto_increment,
tresc text,
od text,
dla text,
ip text,
UNIQUE id (id),
PRIMARY KEY (id)
);
Błąd w opisie readme przez autora tego małego modułku

nie ustawiasz defoult i jush

Bosze a 3 godziny grzebałem się w tym module, żeby na końcu wpaść na tak oczywiste ROZWIAZANIE

Aha
żeby uniknać dalsze ciągniecie tematu odrazu daje pozdrowienia w block menu też działa

Efekt w bloku TU!

Kod:
 Od: ".$wiersz['od']." 

Dla: ".$wiersz['dla']."
".$wiersz['tresc']."
"; } if ($pozdro=="") { echo "
[ brak pozdrowień ]

"; } echo "
[Dodaj Pozdrowienie]
"; ?>
Dla leniwców i estetów dodalem małą ciekawostke tzn.

Kod:
> Od: ".$wiersz['od']." 

Dla: ".$wiersz['dla']."
".$wiersz['tresc']."
"; } if ($pozdro=="") { echo "
[ brak pozdrowień ]

"; } echo "
[Dodaj Pozdrowienie]
"; ?>
Czyli enter miedzy poszczegonymi pozdrowieniami w przypdaku bloku menu chodzi tu tylko o to by.... wygladalo lepiej ladniej

Matek_13k
08-11-2005, 16:37
dzieki tylko ze nie wiem czemu tak sie dzieje. a teraz mam problem bo sie cale rozsypalo zobacz http://www.matek1992.ovh.org dziex za pomoc ten modul jest tylko do j portala sa tez tam takie moduly jak dla klanow mozna je pobrac na http://www.jportal.safri.pl

P.S PoZdRo

K@iTO
07-11-2005, 23:51
skopjuj baze danych do pliku przeczysc baze zainstaluj ponownie jPortala wstaw baze (o ile mozesz to zrobic bo jeszcze nie jest wartosciowa) jak nie mozesz tak zrobic to reinstal jPortala no cush

chodzi tesh o to

UNIQUE id (id),

unikalne id nie moze byc nignie takiego id jak tu bedzie uzywane

hmm co jeszcze.... wywal moze te cale pozrowienia dopuki czegos nie wymyslimy hehe

wogole zapodaj link do strony skad wzioles ow modol

Matek_13k
07-11-2005, 11:40
Witam mam problem. Po raz pierwszy zainstalowalem jportal (ale instalowalem juz phpBB modified by przemo wiec to bylo latwe) wszystko przeszlo pomyslenie i wszystko dziala. sciagnelem sobie do tego skrypt pozdrowien do jPortalu i w pliku readme pisze jak zainstalowac. wiec w gralem i pisze zebym dal zapytanie do sql wpisuje wyglada on tak:
CREATE TABLE prefix_pozdrowienia (
id int(11) DEFAULT '0' NOT NULL auto_increment,
tresc text,
od text,
dla text,
ip text,
UNIQUE id (id),
PRIMARY KEY (id)
);

dalem to zapytanie w phpmyadminie i jak daje zapytaj to wyskakuje cos 'id' powiem ze chodzi o to pierwsze id bo te 2 ostatnie raz wymazalem i nic nie gadal. i powiem ze nie chodzi o prefix bo moj prefiks wyglada tak jp1_ i zmienilem to. pomozcie. chodzi tu o strone pod radio

oto link http://www.matek1992.ovh.org