We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

drupal - problem z konfiguracją


paolo_
12-09-2006, 20:32
sorry za kłopot - nie wiem jak ja to zrobiłem - teraz działa, jeszcze się tylko muszę z mysql pobawić.

dzięki za pomoc

mariano
12-09-2006, 09:08
Cytat Napisał paolo_
1. index.php ma teraz 755
Jest 766.

paolo_
11-09-2006, 22:05
1. index.php ma teraz 755, ale dalej nie idzie

2. to mam wszystkie wpisy mod_rewrite.c wyrzucić z plików ?

przykładowy wpis w pliku includes/file.inc:
if ((file_directory_path() == $directory || file_directory_temp() == $directory) && !is_file("$directory/.htaccess")) {
$htaccess_lines = "SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006\nOpt ions None\nmod_rewrite.c>\n RewriteEngine off\n";
if (($fp = fopen("$directory/.htaccess", 'w')) && fputs($fp, $htaccess_lines)) {
fclose($fp);
to co mam wyrzucić? tylko mod_rewrite.c czy cały ciąg?

edit// to mod_rewrite służy do zmiany uprawnień? czyli musiałbym wszystko ręcznie pozmieniać? tylko skąd wiedzieć jak i co?

Łabędź
11-09-2006, 17:21
Cytat Napisał paolo_
adres strony wysłałem na priv
Na 60fre nie ma obsługi mod_rewrite. Wywal wszystkie regułki to zadziała

pozdrawiam

mariano
11-09-2006, 16:48
.htaccess masz w porzadku, lecz index.php ma uprawnienia 777. Zmien na 755.

paolo_
11-09-2006, 16:34
adres strony wysłałem na priv

mariano
11-09-2006, 10:07
Cytat Napisał paolo_
uprawnienia do uruchamianego zasobu '/z/i/e/stronaaa/www/' mają wartość 755
Jaki to link?? Podaj url.

plik .htaccess nie jest wyświetlany na serwerze - tak ma być?
Tak.

paolo_
10-09-2006, 10:03
wyświetla mi się następująca strona:
Witamy na stronie serwisu 60free firmy OVH.

Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.

Jeżeli jesteś właścicielem tego konta i szukasz informacji na temat probmemów z błędem wewnętrznym, zapraszamy na stronę http://60free.ovh.org/pl/support/ lub sprawdź czy:

- uprawnienia do uruchamianego zasobu '/z/i/e/stronaaa/www/' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,
- w pliku '.htaccess' nie znajdują się nieprawidłowe wpisy
zrobiłem tak jak było tutaj, ale nie działa: http://forum.ovh.pl/showthread.php?t=3786&highlight=drupal

mój plik .htaccess wygląda tak:
#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.

Order deny,allow
Deny from all


# Set some options.
# Options -Indexes --
# Options +FollowSymLinks --

# Customized error messages.
ErrorDocument 404 /index.php

# Set the default handler.
# DirectoryIndex index.php --

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1

php_value magic_quotes_gpc 0
php_value register_globals 0
php_value session.auto_start 0


# PHP 4, Apache 2

php_value magic_quotes_gpc 0
php_value register_globals 0
php_value session.auto_start 0


# PHP 5, Apache 1 and 2

php_value magic_quotes_gpc 0
php_value register_globals 0
php_value session.auto_start 0


# Reduce the time dynamically generated pages are cache-able.

ExpiresByType text/html A1


# Various rewrite rules.
# --
# RewriteEngine on --

# If your site can be accessed both with and without the prefix www.
# you can use one of the following settings to force user to use only one option:
#
# If you want the site to be accessed WITH the www. only, adapt and uncomment the following:
# RewriteCond %{HTTP_HOST} !^www\.example\.com$ [NC]
# RewriteRule .* http://www.example.com/ [L,R=301]
#
# If you want the site to be accessed only WITHOUT the www. , adapt and uncomment the following:
# RewriteCond %{HTTP_HOST} !^example\.com$ [NC]
# RewriteRule .* http://example.com/ [L,R=301]


# Modify the RewriteBase if you are using Drupal in a subdirectory and
# the rewrite rules are not working properly.
#RewriteBase /drupal

# Rewrite old-style URLs of the form 'node.php?id=x'.
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{QUERY_STRING} ^id=([^&]+)$
#RewriteRule node.php index.php?q=node/view/%1 [L]

# Rewrite old-style URLs of the form 'module.php?mod=x'.
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
#RewriteRule module.php index.php?q=%1 [L]

# Rewrite current-style URLs of the form 'index.php?q=x'.
# RewriteCond %{REQUEST_FILENAME} !-f --
# RewriteCond %{REQUEST_FILENAME} !-d --
# RewriteRule ^(.*)$ index.php?q=$1 [L,QSA] --
#
--

# $Id: .htaccess,v 1.73 2006/04/14 09:08:26 killes Exp $
na moim koncie nie ma wogóle pliku .htaccess w katalogu www - modyfikuje go na dysku, wgrywam na serwer - transfer przebiega normalnie, ale plik .htaccess nie jest wyświetlany na serwerze - tak ma być?