We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Błąd wewnętrzny...


Ziem
28-08-2006, 22:06
Już wszystko działa. Dziękuje serdecznie za pomoc mariano!!

Ziem
28-08-2006, 21:43
Chyba o to chodziło:

RewriteEngine on

# If your site can be accessed both with and without the prefix www.
# you can use one of the following settings to force user to use only one option:
#
# If you want the site to be accessed WITH the www. only, adapt and uncomment the following:
# RewriteCond %{HTTP_HOST} !^www\.example\.com$ [NC]
# RewriteRule .* http://www.example.com/ [L,R=301]
#
# If you want the site to be accessed only WITHOUT the www. , adapt and uncomment the following:
# RewriteCond %{HTTP_HOST} !^example\.com$ [NC]
# RewriteRule .* http://example.com/ [L,R=301]


# Modify the RewriteBase if you are using Drupal in a subdirectory and
# the rewrite rules are not working properly.
#RewriteBase /drupal

# Rewrite old-style URLs of the form 'node.php?id=x'.
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{QUERY_STRING} ^id=([^&]+)$
#RewriteRule node.php index.php?q=node/view/%1 [L]

# Rewrite old-style URLs of the form 'module.php?mod=x'.
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
#RewriteRule module.php index.php?q=%1 [L]

# Rewrite current-style URLs of the form 'index.php?q=x'.
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]


# $Id: .htaccess,v 1.73 2006/04/14 09:08:26 killes Exp $
Coś ruszyło, tylko błędy się pokazują, wywaliłem te options i directoryindex.

mariano
28-08-2006, 14:04
Hmm. Na poczatku, jak zagladalem, wygladalo to troche inaczej, nie bylo linijki ... Najlepiej bedzie, jak wyrzucisz te linijke i wszystko ponizej do konca pliku. Wyrzuc tez obie linie z "Options" oraz "DirectoryIndex".

Ziem
28-08-2006, 13:03
Wywaliłem tą linijke i php-value. Tak powinno zostać?:
#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.

Order deny,allow
Deny from all


# Set some options.
Options -Indexes
Options +FollowSymLinks

# Customized error messages.
ErrorDocument 404 /index.php

# Set the default handler.
DirectoryIndex index.php

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1



# PHP 4, Apache 2



# PHP 5, Apache 1 and 2



# Reduce the time dynamically generated pages are cache-able.

ExpiresByType text/html A1


# Various rewrite rules.

RewriteEngine on

# If your site can be accessed both with and without the prefix www.
# you can use one of the following settings to force user to use only one option:
#
# If you want the site to be accessed WITH the www. only, adapt and uncomment the following:
# RewriteCond %{HTTP_HOST} !^www\.example\.com$ [NC]
# RewriteRule .* http://www.example.com/ [L,R=301]
#
# If you want the site to be accessed only WITHOUT the www. , adapt and uncomment the following:
# RewriteCond %{HTTP_HOST} !^example\.com$ [NC]
# RewriteRule .* http://example.com/ [L,R=301]


# Modify the RewriteBase if you are using Drupal in a subdirectory and
# the rewrite rules are not working properly.
#RewriteBase /drupal

# Rewrite old-style URLs of the form 'node.php?id=x'.
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{QUERY_STRING} ^id=([^&]+)$
#RewriteRule node.php index.php?q=node/view/%1 [L]

# Rewrite old-style URLs of the form 'module.php?mod=x'.
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
#RewriteRule module.php index.php?q=%1 [L]

# Rewrite current-style URLs of the form 'index.php?q=x'.
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

# $Id: .htaccess,v 1.73 2006/04/14 09:08:26 killes Exp $

mariano
28-08-2006, 12:21
Chodzi Ci o blad w linii 84 ()? Hmm... Po po prostu ja usun.

Ziem
28-08-2006, 12:13
Dzięki!
Tylko nie wiem jak naprawić ten błąd, żeby chodziło,w bo się na tym nie znam.
mariano mógłbyś mi pomóc?

mariano
28-08-2006, 09:17
Masz blad skladni w pliku .htaccess (linijka 84) w katalogu www. Wywal tez wszystkie regulki "php_value" (i tak nie beda dzialac).

Ziem
27-08-2006, 13:16
Witam!
Chciałem zainstalować sobie Drupala (CMS), niestety po wysłaniu plików na ftp wyskoczył mi błąd.
Witamy na stronie serwisu 60free firmy OVH.

Serwer napotkał błąd wewnętrzny i nie jest w stanie zrealizować twojego żądania.

Jeżeli jesteś właścicielem tego konta i szukasz informacji na temat probmemów z błędem wewnętrznym, zapraszamy na stronę http://60free.ovh.org/pl/support/ lub sprawdź czy:

- uprawnienia do uruchamianego zasobu '/z/i/e/ziem/www/' mają wartość 755,
- uprawnienia do katalogu mają wartość 755,
- w pliku '.htaccess' nie znajdują się nieprawidłowe wpisy
Co z tym fantem zrobić? Proszę o pomoc.