We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Działało - teraz nie działa


almurik
10-08-2006, 00:38
Cytat Napisał A418
JESTEŚ WIELKI
hmmm wszystkie 'psiapsiułki' też mi to mówią ale nie pomagam im z php

ps. lubię Żywiec
pss. w Żywcu

haha

Fajnie, że administracja nie psioczy na posty nie na temat.

-- zaś edit ehhh --
nie masz 'ś' w tych katalogach - no to teraz już jest prawie prawie na temat
Aha, ja nie obwiniałem administratora, broń Boże . Ewidentną winę ponosi programista.

A418
10-08-2006, 00:28
Działa !!!

Wszędzie wstawiłem ten fragment i już działa ))
Czyli jak przypuszczałeś winę za to ponosi admin serwera, ktory zmieniał jego ustawienia.

Ten brakujący znacznik ... i tak sam dodawałem strony ...


Dzieki raz jeszcze
JESTEŚ WIELKI
Pozdrawiam
Tomek

almurik
09-08-2006, 23:42


Trudno bez kodu coś powiedzieć.
1: może coś z prawami do plików się pokaszaniło
2: może zmieniałeś coś na stronie i coś nie wiem co hmmm no poburtało się
3: może coś na serwerze wyłączyli, jakąś funkcję ...

W trakcie myślenia co może być nie tak ściągnąłem sobie to coś i odpaliłem.
Stawiam na to, że wyłączyli na serwerku register_globals zmorę początkujących php’owców bo chyba ktoś taki ten skrypt pisał, i nie miał o tym zielonego pojęcia, tragedia. Myślę, że przez to nie działa. Popoprawiaj to i będzie gites. W tym przypadku, jak nie znasz kodu to najlepiej będzie walnąć na początku każdego pliku:
Kod PHP:
import_request_variables("gp""");
?>

aha i w add.php nie ma znacznika zamykającego: : ale to nie wina tego

-- edit --

Pozdrawiam

A418
09-08-2006, 21:44
Kiedyś zrobiłem stronkę o moim hobby czyli psach. Jej obecny adres to: www.psy.za.pl

Plik startowy to index.php, ale większość plików to html. Na stronie głównej w centarlnej części jest katalog stron o psach. Katalog oparty jest na plikach tekstowych, to jakiś JaxKataog o ile dobrze pamiętam.
Wszystko działało dobrze przez długi czas. Jakiś czas temu dostałem informację od odwiedzajacego stronę człowieka, że coś jest nie tak z katalogiem.
Okazało się, że po przejsciu do kategorii strony zapisane w katalogu nie wyświetlają się. Sprawdziłem na serwerze - są pliki tekstowe z zawartymi informacjami o stronach. Co się stało, niczego nie zmianiałem, a przestało działać?