We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem z instalacją Mambo


Łabędź
13-10-2005, 09:32
Cytat Napisał john23
z jakiej paki takie ustawienie nie mam pojęcia - ale działa!!!
Ponieważ w takim kodowaniu standardowo łączy się PHP. Bazie danych jest wszystko jedno. Problem by się pojawił, gdybyś chciał np. edytować dane w phpMyAdminie.

pozdrawiam

john23
12-10-2005, 20:41
no cóż jeżeli powiedziałeś że można to można ...

próbowałem chyba kilkanaście razy aż dopasowałem porównywanie napisów
na "latin1_swedish_ci"

z jakiej paki takie ustawienie nie mam pojęcia - ale działa!!!

Łabędź
11-10-2005, 21:48
Kurcze, instalowałem 2 razy Mambo 4.5.2.3 PL i ani razu nie dostałem opcji 'System porównań dla połączenia MySQL' do wyboru. Mambo zainstalowało się bez problemu, literki polskie występują i mają się dobrze...

Co mnie zaciekawiło to to, że nie mogłem zalogować się jako admin z poziomu IE! Pod Mozillą nie ma żadnych problemów. Ale z tym nie podejmuje się walczyć

pozdrawiam

Łabędź
11-10-2005, 20:35
Cytat Napisał john23
żadnej sugestii?

nikt nie pomoże?
No niestety, jestem troche zajęty, żeby odpowiadać 'na bieżąco'. Szkoda, że inni użytkownicy forum się tak mało udzielają.

Cytat Napisał john23
w takim razie poco zmianialiście wersję mysql
Prędzej czy później i tak by to nastąpiło. System kodowania w MySQL 4.1 jest nowym rozwiązaniem, stąd też biorą się problemy. Po jakimś czasie przywykniemy do tego.

Cytat Napisał john23
miełem bazę z mambo na tym serwerze i wszystko było ok!
po zmianie wersji nie mam polskich liter a w prypadku ponownej instatalacji wyskakuje błąd wymieniony wyżej
Jeżeli Mambo było zainstalowane przed zmianą wersji bazy danych, to nie ma z nim żadnego problemu. Jak się instaluje teraz, zaraz sprawdzę.

Cytat Napisał john23
przed zmianą było latin2
O to chodzi, że teraz MySQL myśli że to było latin1. Jeżeli tak się ustawi, to nie ma żadnego problemu.

pozdrawiam

john23
11-10-2005, 18:16
żadnej sugestii?

nikt nie pomoże?

w takim razie poco zmianialiście wersję mysql jeżeli teraz gdy występują problemy nikt się nie odezwie i nie zaproponuje jakiegoś rozwiązania?

jeszcze proszę o pomoc

miełem bazę z mambo na tym serwerze i wszystko było ok!
po zmianie wersji nie mam polskich liter a w prypadku ponownej instatalacji wyskakuje błąd wymieniony wyżej

wiem że jest to związane z kodowaniem znaków - porównywaniem napisów
tylko może ktoś zasugeruje jakiego ustawienia użyć
przed zmianą było latin2
teraz jak takie ustawię to brak polskich liter
jak ustawię utf8 general lub polskie to również brak polskich liter

moje konto http://kasafriko.ovh.org

john23
08-10-2005, 17:27
próbuję zainstalować mambo 4.5.2
w .htaccess ustawiłem php na wersję 4
może moje problemy spowodowane są nowym opcją "System porównań dla połączenia MySQL" (nie wiem jakie opcję wybrać)

w każdym razie w kroku 2 instalacji zwracany jest komunikat:

SQL=Specified key was too long; max key length is 1000 bytes:
- - - - - - - - - -
# Table structure for table `mos_core_acl_aro`

CREATE TABLE `mos_core_acl_aro` (
`aro_id` int(11) NOT NULL auto_increment,
`section_value` varchar(240) NOT NULL default '0',
`value` varchar(240) NOT NULL default '',
`order_value` int(11) NOT NULL default '0',
`name` varchar(255) NOT NULL default '',
`hidden` int(11) NOT NULL default '0',
PRIMARY KEY (`aro_id`),
UNIQUE KEY `section_value_value_aro` (`section_value`,`value`),
UNIQUE KEY `mos_gacl_section_value_value_aro` (`section_value`,`value`),
KEY `hidden_aro` (`hidden`),
KEY `mos_gacl_hidden_aro` (`hidden`)
) TYPE=MyISAM
= = = = = = = = = =

moje konto: kasafriko