We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem z Plesk


damianoos
02-04-2006, 19:48
Nie wiem jakim cudem, ALE SAMO sie naprawilo
Przez kilka dni w ogole sie tym nie bawilem i nagle patrze a PLESK dziala

Wytłumaczy mi to ktoś ??

A tak to dziekuje wszystkim za okazanie pomocy

anopak
31-03-2006, 09:13
Cytat Napisał Łabędź
Poza tym zabawa z bibliotekami w Plesk-u to delikatna sprawa. Plesk tego nie lubi (szczególnie zmiana glibc-ów, mysql, itp.).
zgadza się, przekonałem się na własnej skórze, gdy chciałem zmienić mysql'a... po prau dniach wkońcu udało się... takie zabiegi polecam tylko cierpliwym ;d

Łabędź
30-03-2006, 09:57
Cytat Napisał damianoos

./configure
make
make install
Przeładowałeś biblioteki? (ldconfig)?

Sprawdź czy ta biblioteka istnieje;

Kod:
ldconfig -v | grep xml
Ewentualnie zobacz czego jeszcze /usr/local/psa/admin/bin/httpsd wymaga i czy Ci czegoś nie brakuje:
Kod:
ldd /usr/local/psa/admin/bin/httpsd
Poza tym zabawa z bibliotekami w Plesk-u to delikatna sprawa. Plesk tego nie lubi (szczególnie zmiana glibc-ów, mysql, itp.).


pozdrawiam

damianoos
29-03-2006, 20:35
Po wspianiu locate pojawia mi się:
Kod:
lvps87-230-3-132:~ # locate libxml2.so
locate: /var/lib/locatedb: No such file or directory
Mogłbys dokładnie napisać jak wykonać tą operacje.. nie jestem jeszcze zbyt biegły w shellu

szczeles
29-03-2006, 17:10
Cytat Napisał anopak
to fakt, ja mam nawet 2 dowiązania
To teraz zrób jeszcze dowiązanie w /usr/local/lib/ i może zadziała

anopak
29-03-2006, 17:00
to fakt, ja mam nawet 2 dowiązania

Kod:
#locate libxml2.so
/usr/lib/libxml2.so
/usr/lib/libxml2.so.2
/usr/lib/libxml2.so.2.6.16

szczeles
28-03-2006, 23:29
Cytat Napisał damianoos
No nadal ten sam błąd..
To walnij `locate libxml2.so` i być moża na liście bedziesz miał tylko np. '/usr/lib/libxml2.so.2.6.23' => wtedy robisz dowiazanie w libxml2.so.2 i gra szafa ;-) Ja mam oba:
mario@ubuntu:~/OperaDownloads$ locate libxml2.so
/usr/lib/libxml2.so.2
/usr/lib/libxml2.so.2.6.23

damianoos
28-03-2006, 18:19
No nadal ten sam błąd..

Tu jest pełna lista plików: http://ftp.gnome.org/pub/GNOME/platf....14.0/sources/

Jak widać nie ma innego rodzaju tych bibliotek..
Chyba ze zna ktoś inne źródła...

szczeles
28-03-2006, 15:57
Cytat Napisał damianoos
Zainstalowalo się, ale niestrety nadal to samo..
Wciąż ten sam błąd? :O

A możę weź poszukaj na dysku plików libxml2.so* - na auroxie miałem często tak, że te z końcówkami 2 byly tylko dowiązaniami do parwdziwych bibliotek, a wtedy tylko ln -s i lu ;-)

damianoos
28-03-2006, 15:37
Tak niejednokrotnie..
Zawsze wywala mi taki błąd:

/usr/local/psa/admin/bin/httpsd: error while loading shared libraries: libxml2.so.2: cannot open shared object file: No such file or directory
/usr/local/psa/admin/bin/httpsdctl start: httpd could not be started
Starting Plesk: failed

Sciągnąłem więc biblioteke libxml2.so.2 stąd: ftp://ftp.gnome.org/pub/GNOME/source...-2.6.17.tar.gz

rozpakowałem i wgrałem ją:

./configure
make
make install

Zainstalowalo się, ale niestrety nadal to samo..

anopak
28-03-2006, 15:17
próbowałeś zrobić:

Kod:
/etc/init.d/psa stopall
/etc/init.d/psa start
??

damianoos
27-03-2006, 17:00
Witam
Zrobiłem reboot serwera i od tego czasu nie potrafie wejsc do PLESKa
Wyświetla mi taki komunikat po zalogowaniu się:
"Service is not available now. Please check your Plesk status here"
Po kliknięciu pisze, ze musze włączyc "psa service" :
"On this screen you may start, stop or restart your psa service, depending on its current state.
Also you may enable/disable service's Autostart option."

Jednak kazda próba włączenia tego "psa service" konczy sie fiaskiem.. Nie moge wiec korzystac z PLESKa.. Mial ktos moze podobny problem i wie co nalezy zrobic ?
Pozdrawiam