We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

PHP nie działa? :/ Kazda strona PHp zwraca blad...


matbla
22-06-2006, 13:53
_

baran_92
05-03-2006, 20:00
Dzięki ci SO MUCH w końcu będzie wszystko działac

solti
05-03-2006, 19:33
Wyczyść ftp i wgraj wszystko na nowo. Powinno pomóc. Była mała rekonfiguracja ftp'a, podczas której usunięto pewne błędy w transferze.

baran_92
05-03-2006, 18:18
Za każdym razem wyświetla sie głupi komunikat który możecie zobaczyć tu
http://baran_92.ovh.org. Jedyny plik, który działa to test.php ustawiony na 404 chmod- http://baran_92.ovh.org/test.php. Są w nim podstawowe znaczniki html + phpinfo().Inne pliki próbowałem zmienić na 404, 755, 644, ale żaden plik php oprócz test.php nie chce wejść. Pomóżcie!!!

barat
04-03-2006, 22:42
teraz działa - dziękuję

Łabędź
04-03-2006, 12:59
Cytat Napisał barat
tak - dodalem - efekt z tego taki, ze nic nie uleglo zmianie :/

To nie jest problem chmod...
Owszem - to nie był problem chmod. Wgrałeś pliki kiedy jeszcze nie był do końca skonfigurowany FTP. Zmieniłem uprawnienia dla Twoich plików ręcznie.Teraz powinno być ok.

pozdrawiam

barat
03-03-2006, 23:19
tak - dodalem - efekt z tego taki, ze nic nie uleglo zmianie :/

To nie jest problem chmod...

szczeles
03-03-2006, 22:39
Cytat Napisał barat
przeciez dafault dla plików pokroju php/html chmod jest 644 :>
Default dla wszystkich plików nieuruchomieniowych to 644 : P (to jest def przy tworzeniu pliku, nie przy uploadowaniu)

Na 100% dałeś plikom .php na serwerze chmod 755? :O

barat
03-03-2006, 22:10
przeciez dafault dla plików pokroju php/html chmod jest 644 :>

szczeles
03-03-2006, 20:04
Cytat Napisał barat
Przecież hmod 755 to dafault atrybut dla każdego katalogu stworzonego na serwerze
Ale chmody dla plików ustala klient ftp. Zwykle ustawia dokładnie takie, jak masz na dysku lokalnym ;-)
Upewnij się jeszcze raz (na wszelki wypadek, nawet jeśli LIST -la zwróci 755 to i tak daj SITE CHMOD 755 tester.php). Też kiedyś nie wiedziałem co jest grane, a miałem dla jednego z plików 775 ;-)

barat
03-03-2006, 19:48
dałem, dałem
Przecież hmod 755 to dafault atrybut dla każdego katalogu stworzonego na serwerze Skoro potrafie odpalic skrypty PHP na jednym darmowym 60free, i na 1000gp to jednak tutaj jest to wina serwera

szczeles
03-03-2006, 19:44
A dałeś chmod 755? ;-)

Moije pliki .php na 60free działają prawidłowo, więc to nie wina serwera ;-)

pawel
03-03-2006, 19:01
przyczyny trzeba szukać w poscie http://forum.ovh.pl/showthread.php?t=1890
przynajmniej tak mi sie wydaje, innego rozsądnego rozwiązania nie widzę

barat
03-03-2006, 18:56
No to mam problem , jakąś godzine temu zostało mi przyznane konto ... pliki html działają poprawnie , ale jakikolwiek plik z rozszerzeniem .php zwraca błąd:
http://poker.ovh.org/tester.php
Nie jest to wina pliku php - na innym koncie lezy i sie odpala:
http://blogszablony.ovh.org/tester.php

Żeby było śmieszniej - na tym koncie na którym działa plik php - każdy nowo wsadzony plik PHP tez nie chce działać ...

Że tak sie spytam - co jest ?