We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem z domyślnym kernelem CentOS 6.6


Spacedust
09-03-2015, 19:00
Cytat Napisał no4b
Widocznie grub.conf albo fstab nie są poprawne. Ewentualnie ten kernel nie ma wystarczającego wsparcia dla sprzętu Twojego serwera.
Niestety były poprawne. Sprawdziłem na drugim serwerze o tej samej konfiguracji i było to samo. O dziwo domyślny kernel CentOS'a zainstalowany na czysto przez OVH działa ok.

no4b
07-03-2015, 11:36
Widocznie grub.conf albo fstab nie są poprawne. Ewentualnie ten kernel nie ma wystarczającego wsparcia dla sprzętu Twojego serwera.

Spacedust
06-03-2015, 23:34
Próba instalacja na serwerach OVH kończy się takim komunikatem:

Dependencies Resolved

================================================== =======================================
Package Arch Version Repository Size
================================================== =======================================
Installing:
kernel x86_64 2.6.32-504.8.1.el6 updates 29 M
Installing for dependencies:
dracut noarch 004-356.el6 base 123 k
dracut-kernel noarch 004-356.el6 base 25 k
kernel-firmware noarch 2.6.32-504.8.1.el6 updates 14 M
libdrm x86_64 2.4.52-4.el6 base 123 k
libpciaccess x86_64 0.13.3-0.1.el6 base 24 k
plymouth x86_64 0.8.3-27.el6.centos.1 base 89 k

Transaction Summary
================================================== =======================================
Install 7 Package(s)

Total download size: 44 M
Installed size: 147 M
Is this ok [y/N]: y
Downloading Packages:
(1/7): dracut-004-356.el6.noarch.rpm | 123 kB 00:00
(2/7): dracut-kernel-004-356.el6.noarch.rpm | 25 kB 00:00
(3/7): kernel-2.6.32-504.8.1.el6.x86_64.rpm | 29 MB 00:03
(4/7): kernel-firmware-2.6.32-504.8.1.el6.noarch.rpm | 14 MB 00:01
(5/7): libdrm-2.4.52-4.el6.x86_64.rpm | 123 kB 00:00
(6/7): libpciaccess-0.13.3-0.1.el6.x86_64.rpm | 24 kB 00:00
(7/7): plymouth-0.8.3-27.el6.centos.1.x86_64.rpm | 89 kB 00:00
-----------------------------------------------------------------------------------------
Total 9.3 MB/s | 44 MB 00:04
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : kernel-firmware-2.6.32-504.8.1.el6.noarch 1/7
Installing : libpciaccess-0.13.3-0.1.el6.x86_64 2/7
Installing : libdrm-2.4.52-4.el6.x86_64 3/7
Installing : plymouth-0.8.3-27.el6.centos.1.x86_64 4/7
Installing : dracut-004-356.el6.noarch 5/7
Installing : dracut-kernel-004-356.el6.noarch 6/7
Installing : kernel-2.6.32-504.8.1.el6.x86_64 7/7
grubby fatal error: unable to find a suitable template
Verifying : plymouth-0.8.3-27.el6.centos.1.x86_64 1/7
Verifying : dracut-004-356.el6.noarch 2/7
Verifying : libdrm-2.4.52-4.el6.x86_64 3/7
Verifying : kernel-2.6.32-504.8.1.el6.x86_64 4/7
Verifying : libpciaccess-0.13.3-0.1.el6.x86_64 5/7
Verifying : kernel-firmware-2.6.32-504.8.1.el6.noarch 6/7
Verifying : dracut-kernel-004-356.el6.noarch 7/7

Installed:
kernel.x86_64 0:2.6.32-504.8.1.el6

Dependency Installed:
dracut.noarch 0:004-356.el6 dracut-kernel.noarch 0:004-356.el6
kernel-firmware.noarch 0:2.6.32-504.8.1.el6 libdrm.x86_64 0:2.4.52-4.el6
libpciaccess.x86_64 0:0.13.3-0.1.el6 plymouth.x86_64 0:0.8.3-27.el6.centos.1

Complete!
Niestety serwer mimo prawidłowego grub.conf oraz fstab nie wstaje. Z Netboot wszystko jest ok.