We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem z serwerem zrywa połączenie !!


r4nt
07-01-2015, 08:52
Witam, sprawdzałem przez ping.eu i faktycznie jest podłączane, jak to wyłączyć ??

podsyłam screen:

http://www.dvh.pl/2222.jpg

Lewyx
06-01-2015, 22:15
Przecież mikel napisał wyraźnie.
Sprawdź traceroute do siebie i zobacz czy idzie przez filtry...
Przez VAC, żeby było bardziej zrozumiale.

r4nt
06-01-2015, 00:54
A gdzie to wyłączę lub sprawdzę czy to jest włączone / wyłączone ? wiem ze w Panelu zarządzania serwerem dedykowanym ale dokładnie ??

mikel
29-12-2014, 11:04
Nie włączyłeś sobie przypadkiem permanentnej ochrony antyddos albo nie jest ona obecnie cały czas włączona ze względu na atak ? Ochrona ta ma to do siebie, że właśnie odrzuca każdą pierwszą próbę połączenia np. do ssh, przy wznowieniu jest ok a po pewnym czasie bezczynności między tobą a hostem znów będzie wymagać ponowienia. Sprawdź sobie traceroute do serwera czy nie przechodzi przez filtry antyddosowe.

r4nt
29-12-2014, 10:37
83.26........ to początek IP mojego dostawcy Internetowego czyli w tym wypadku Neostrady .

Mogę podać IP nie potrzebne żadne dochodzenie co jest pod ns340208 .
Kolejna sprawa zmieniłem DNS na googla czyli 8.8.8.8 i 8.8.4.4 ale w tym momencie wszystko działało spoko do czasu aż potrzeba było coś wrzucić na serwer za pomocą przeglądarki, ftp czy nawet pobierać z konsoli za pomocą " wget " . było to niemożliwe lub bardzo ale to bardzo powolne .

Co najlepsze posiadam kilka serwerów w OVH i każdy ma ten dns ustawiony:

search ovh.net
nameserver 127.0.0.1
nameserver 213.186.33.99
I wszystko działa bez problemu .

A na tym co wiecznie zrywa połączanie jaki ustawie DNS to wiecznie problem .

Więc wychodzi na to że problem lezy po innej stronie, albo jakiś z podzespołów serwera pada albo już nie mam pojęcia.

System jaki jest to Centos + vsftpd + apache2 + nginx i tylko tyle wszystko konfigurowane na czystym systemie .

Pozdrawiam

borec
29-12-2014, 08:58
Niesprawny/wolny DNS może powodować lagi przy łączeniu, bo ssh/ftp/coś tam innego może chcieć zresolvować IP osoby która się łączy celem zapisania hosta w logu.

desavil
28-12-2014, 19:38
Cytat Napisał OPTRONET
A co mają DNSy do tego? Przecież napisał, że łaczy się po IP.
Ma, nie ma. Miałem też podobny problem niedawno i też łączyłem się przez IP, a nie domenę - pomogła zmiana DNSów na serwerze.
Dodatkowo w /etc/ssh/sshd_config można dodać: UseDNS no

Cytat Napisał OPTRONET
Początek IP 83.26. wiele wyjaśnia...
Podał numer serwera - ns340208, więc można na właściwe IP w łatwy sposób "wpaść".

OPTRONET
28-12-2014, 16:54
A co mają DNSy do tego? Przecież napisał, że łaczy się po IP. Powodów może być wiele, nie tylko po stronie OVH jak i po stronie Twojego dostawcy (firewalle, limity połączeń, przypchane styki) Początek IP 83.26. wiele wyjaśnia...

Edit: Nigdy nie loguj się na roota, Stwórz sobie jakieś dodatkowe konto i przechodź na roota komendą su a w /etc/ssh/sshd_config zablokuj możliwość logowania się do roota i używania hasła (tylko najpierw dodaj swój klucz DSA/RSA i sprawdź czy działa)

desavil
26-12-2014, 22:55
To już pisałeś..
Próbowałeś zmienić DNSy? Co masz w pliku /etc/resolv.conf (o ile to system Debian/Ubuntu)

r4nt
25-12-2014, 14:36
Łącze się z adresem IP, ale co najlepsze to jest to iż zawsze gdy łacze się pierwszy raz przez SSH wywala błąd połączenie zostało zerwane, daje wznów połączenie i zaskakuje, to samo jest przy plikach wideo ( postawiony nginx ) przy pierwszym odpaleniu pliku z playera jwplayer wywala " error loading media ...... " ,ale wystarczy odświeżyć stronę i już zaskakuje, ciężki temat nie mogę się doszukać problemu .

desavil
22-12-2014, 11:41
Spróbuj zmienić DNSy na inne w pliku /etc/resolv.conf na np.
nameserver 8.8.8.8
nameserver 8.8.4.4
@Edit:
Łączysz się do SSH podając adres IP numerowy serwera, czy domenę?

r4nt
22-12-2014, 11:16
logi z secure:

Dec 22 11:14:12 ns340208 sshd[18509]: Accepted password for root from 83.26.*.* port 49753 ssh2
Dec 22 11:14:12 ns340208 sshd[18509]: pam_unix(sshd:session): session opened for user root by (uid=0)
Dec 22 11:14:13 ns340208 sshd[18509]: subsystem request for sftp

borec
21-12-2014, 22:10
Jakieś błędy w logach? ssh -vvv? Jaki serwer www? Jakieś błędy w jego logach? Mamy wróżyć z kuli czy fusów?

r4nt
21-12-2014, 20:13
Witam,

Zakupiłem serwer na ovh.pl z kategorii Dedykowane - > Hosting.

I tutaj jest notoryczny problem, gdy łącze się z ssh na serwer wyskakuje informacja błąd sieci, gdy połącze się ponownie jest ok, wystarczy że się rozłącze i znów ponownie się połącze to kolejny raz błąd sieci i znów musze ponownie się połączyć.

Problem tkwi również w plikach wideo, na serwerze są przetrzymywane filmiki .flv , klient gdy odpala player wywala informacja o błędzie pliku wideo ( error loading media ), ale wystarczy odświeżyć stronę tego filmiku i już normalnie się ładuje .

Ktoś miał podobny problem lub wie jak to Naprawić ?

System Centos .

Pozdrawiam