We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Brak możliwości wrzucania plików (Konfiguracja php.ini)


boneszbo
29-04-2014, 10:59
O Matko popełniłem fatalny błąd i nie mogłem domyśleć się dlaczego cały czas nie mogę wrzucać plików.

Przeglądam ustawienia jeszcze raz i zauważyłem, że wartość ustawiona dla upload_max_filesize to 64MB a nie 64M!
Teraz wszystko działa prawidłowo. Przepraszam za kłopot
Pozdrawiam

boneszbo
28-04-2014, 17:25
Witam,

Przeszedłem z hostingu OVH na VPSa i wszystko śmiga elegancko.
Nazwa hosta: vps60031.ovh.net
Adres IP: 37.187.38.206
OS: CentOS 6.5 (Final)

Mam tylko jeden mały problem a mianowicie nie działają załączniki na moim forum, gdzie wcześniej działało wszystko bez problemów na hostingu OVH.
Posiadam skrypt do obsługi Forum vBulletin 4.2.0

Diagnostyka w AdminCP:
Kod:
file_uploads:	On
open_basedir:	/var/www/vhosts/windowsmania.pl/httpdocs:/var/www/vhosts/windowsmania.pl/httpdocs/tmp
safe_mode:	Off
upload_tmp_dir:	/var/www/vhosts/windowsmania.pl/httpdocs/tmp
upload_max_filesize:	64.00 MB

No file uploaded and no local file found. The test cannot continue.
ustawiałem open_basedir oraz upload_tmp_dir różnie na /tmp, none i wszystkie możliwe warianty ale bez skutku.
CHMODY ustawiałem na 1777, 777 tworzone przez FTP czy za pomocą SSH przy użyciu konta root i zmiana chmodów bez skutku.

Nie wiem gdzie leży dokładnie problem ale jest to dosyć uciążliwe gdyż nie można wrzucać plików na forum, zmieniać avataru czy sygnatury.
Załączniki trzymam na: /var/www/vhosts/windowsmania.pl/httpdocs/upload gdzie CHMOD jest ustawiony na 777

Stare załączniki które są wgrane na serwer działają bez zarzutu więc ścieżka podana jest dobra.
Co mam zmienić w serwerze w Panelu Pleska czy za pomocą konta roota przez SSH'a?
Problem chyba tkwi w konfiguracji php.ini ale nie jestem pewniem
Jeżeli tutaj nie uda się nic wykombinować spróbuje napisać do supportu vBulletin

Z góry dziękuje za pomoc
Pozdrawiam