We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Brak zmian po edycji php.ini


Lewyx
29-11-2013, 09:52
O to, że jak jest na On, to w http://lista-serwerow.pl/a.php dalej widnieje na Off.

borec
29-11-2013, 08:26
Ale jakie cgi? Oba cytaty dotyczą apache2/php.ini, za pierwszym razem masz allow_url_include Off a za drugim On, więc o co chodzi?

Lewyx
28-11-2013, 20:23
Pisałem już, że

Kod:
 ls: nie ma dostępu do /etc/php52/cgi/php.ini: Nie ma takiego pliku ani katalogu

borec
28-11-2013, 17:28
Cytat Napisał lewyx
php -i -c /etc/php52/apache2/php.ini | grep allow_url_include
Kod:
allow_url_include => off => off
Cytat Napisał lewyx
php -i -c /etc/php52/apache2/php.ini | grep allow_url
Kod:
 allow_url_fopen => on => on
allow_url_include => on => on

wtf?!

borec
28-11-2013, 17:26
Wcze
Cytat Napisał Lewyx
php -i -c /etc/php52/apache2/php.ini | grep allow_url_include
Kod:
allow_url_include => Off => Off
Cytat Napisał Lewyx
php -i -c /etc/php52/apache2/php.ini | grep allow_url
Kod:
 allow_url_fopen => On => On
allow_url_include => On => On

Lewyx
28-11-2013, 15:52
ls -l /etc/php52/apache2/php.ini
Kod:
-rw-r--r-- 1 root root 48855 lis 26 22:51 /etc/php52/apache2/php.ini
grep allow_url /etc/php52/apache2/php.ini
Kod:
allow_url_fopen = Off
allow_url_include = On
php -i -c /etc/php52/apache2/php.ini | grep allow_url
Kod:
 allow_url_fopen => On => On
allow_url_include => On => On
Pokaż też fragment konfiguracji apacha odpowiedzialny za php/cgi.
Kod:
# Include file for virtual hosts that need to run PHP 5.2


   SetHandler application/x-httpd-php5


ScriptAlias /php52-cgi /usr/lib/cgi-bin/php52-cgi
Action application/x-httpd-php5 /php52-cgi
AddHandler application/x-httpd-php5 .php

borec
28-11-2013, 08:48
Pokaż:
Kod:
ls -l /etc/php52/apache2/php.ini
grep allow_url /etc/php52/apache2/php.ini
php -i -c /etc/php52/apache2/php.ini | grep allow_url
Pokaż też fragment konfiguracji apacha odpowiedzialny za php/cgi.

Lewyx
27-11-2013, 21:06
Zmian dokonuję w
/etc/php52/apache2/php.ini

chmuri
27-11-2013, 20:09
A gdzie masz php.ini?

Lewyx
27-11-2013, 20:07
Ok, ale Ja nie mam takiego pliku jak /etc/php52/cgi/php.ini...

rysi3k
27-11-2013, 19:25
A jak u Ciebie wygląda sprawa z tymi linkami symbolicznymi pomiędzy tymi plikami php.ini? który linkuje gdzie?
Zmień jeszcze allow_url_include na ON w /etc/php52/cgi/php.ini i wtedy sprawdź.

Lewyx
27-11-2013, 16:22
php -i | grep allow_url_include
Kod:
 allow_url_include => On => On
php -i -c /etc/php52/cli/php.ini | grep allow_url_include
Kod:
 allow_url_include => On => On
php -i -c /etc/php52/cgi/php.ini | grep allow_url_include
Kod:
allow_url_include => Off => Off
php -i -c /etc/php52/apache2/php.ini | grep allow_url_include
Kod:
allow_url_include => Off => Off

rysi3k
27-11-2013, 09:02
Nie wiem czy dobrze rozumiem to co widzę w phpinfo, plik w /etc/php52/cli/php.ini jest linkiem do /etc/php52/php.ini a ten tez linkuje do /etc/php52/apache2/php.ini ? czy tam są jakieś odzielne pliki?
Pokaż jeszcze wyniki (oczywiście z allow_url_include=On)
Kod:
php -i | grep allow_url_include
Kod:
php -i -c /etc/php52/cli/php.ini | grep allow_url_include
Kod:
php -i -c /etc/php52/cgi/php.ini | grep allow_url_include
Kod:
php -i -c /etc/php52/apache2/php.ini | grep allow_url_include
Poza tym widzę że Twojego PHPa nie obsługuje Apache tylko CGI.. więc proces cgi powinieneś restartować a nie apache

Lewyx
26-11-2013, 23:33
Nie jest nadpisany, sprawdzałem.
Wiem, że już jest niewspierany, domyślnie w systemie jest 5.4, ale jeden z userów którzy trzyma strone mnie musi miećtaką wersję.
Swoją drogą, wejdź w link który wklepałem, ale bez /a.php i zobacz jak długo się www ładuje i jaka jest rozwalona.
Wolno chodzi od zawsze, nie wiem czemu, mimo zmian w my.cnf, apache.conf, php.ini ale czemu się rozbabrała, to nie mam kuźwa pojęcia.

rysi3k
26-11-2013, 22:59
Hmm a teraz masz allow_url_include na ON ?
Sprawdz jeszcze czy w plikach w katalogu /etc/php52/conf.d/ w którymś pliku ten settings nie jest nadpisany...

BTW. PHP5.2 jest już niewspierany przez producenta nawet w kwestii krytycznych bugów.. polecam update

Lewyx
26-11-2013, 22:53
Wyłączyłem safe_mode ale to nic nie pomogło.
Cały zrzut jest tu -> http://lista-serwerow.pl/a.php

rysi3k
26-11-2013, 22:07
Hmm a czemu w tym php.ini masz allow_url_include na off ?
Masz włączony Safe Mode , czy on nie wyłącza odgórnie url includów ?
Ewentualnie daj jeszcze zrzut/output phpinfo();

Lewyx
26-11-2013, 22:01
A proszę bardzo

http://pastebin.com/RnLwQ2te

rysi3k
26-11-2013, 21:00
Wrzuć cały swój plik php.ini bo coś tu nie gra

Lewyx
26-11-2013, 19:33
Ńje ma

Załącznik 177

borec
26-11-2013, 18:47
Well, SOA#32 :P A poważnie, to sprawdź 3 razy, czy nie masz gdzieś literówki albo czy linijka nie jest zakomentowana.

Lewyx
26-11-2013, 16:45
Kod:
cat /etc/php52/apache2/php.ini|grep allow_url_include|wc -l

1

borec
26-11-2013, 11:22
Sprawdź czy w tym samym php.ini nie ma gdzieś drugiego wystąpienia allow_url_include, może nadpisuje jedno drugie.

Lewyx
25-11-2013, 20:01
Cytat Napisał adikx
Wklej wynik z:
Kod:
php -i -c /etc/php52/apache2/php.ini | grep allow_url_include
Kod:
allow_url_include => Off => Off

adikx
25-11-2013, 18:12
Wklej wynik z:
Kod:
php -i -c /etc/php52/apache2/php.ini | grep allow_url_include

Lewyx
25-11-2013, 16:02
W phpinfo() mam ściężkę

Kod:
Loaded Configuration File	/etc/php52/apache2/php.ini
I ten plik edytuje, a dokładnie zmienną allow_url_include

Kod:
allow_url_include = On
Po restarcie/reloadzie apache allow_url_include = Off w phpinfo()

borec
25-11-2013, 07:16
Masz włączone safe_mode? Pokaż jak dokładnie ustawiasz te allow_*

Lewyx
24-11-2013, 23:26
Tak, restartuje apache i widać zmianę np. w memory_limit.
Ale nie widać zmiany w allow_url_include

borec
24-11-2013, 22:54
Po zmianiach zrestartowałeś apache/php-fpm czy co tam u Ciebie obsługuje PHP? Upewnij się, że edytujesz ten plik php.ini który jest używany, tzn. stwórz plik z wywołaniem phpinfo() i sprawdź w wyniku ściężkę pod pozycją "Loaded Configuration File".

Lewyx
24-11-2013, 22:18
Sęk w tym, że w .htaccess nie ma nic takiego.

taken
24-11-2013, 20:57
Widaje mi się, że:
.htaccess a dokładniej
php_value allow_url_fopen On
php_flag allow_url_include on

Pozdr

Lewyx
24-11-2013, 20:24
Witam,
niektóre wartości nie zmieniają się, pomimo ich zmian w pliku php.ini.
Jak zmienię np. memory_limit to jest to widoczne, ale jak zmienię
Kod:
allow_url_fopen
albo
Kod:
 allow_url_include
to zmiana jest niewidoczna. Czy mogą być te dyrektywy wpisane gdzieś na sztywno?