We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

T_OBJECT_OPERATOR - czyli problem z php?


GambiT
02-01-2013, 18:45
Slaquo mi pomógł i rozwiązał problem Okazało się, że był kolejny plik .htaccess w podfolderze /www który narzucał swoje ustawienia i wystarczyło zedytować go tak jak poprzedni

Dziękuję jeszcze raz i pełen szacun dla pomocnego moderatora

slawqo
02-01-2013, 08:06
Podaj nazwę serwera (domeny) na której masz ten problem to sprawdzę ten twój .htaccess (może być na PW).

GambiT
01-01-2013, 20:33
Problem jednak niestety nadal aktualny - każdy kolejny plik muszę manualnie zmieniać na .php5 aż na końcu wyskakuje po prostu błąd bodajże 404.

Nie rozumiem jak mam zmienić na swoim serwerze zmienić PHP z 4 na 5. Zrobiłem z htaccess jak zalecali na stronie OVH, podmieniłem pliki i...... nic. Podejrzewam, że nadal mam PHP4.

GambiT
01-01-2013, 17:35
Przepraszam za spam, ale już sobie poradziłem "na czuja"

Nie usuwam tematu bo może komuś się kiedyś przyda. Poza zmianą w htaccess zmieniłem również w samym pliku k2.php końcówkę na k2.php5

GambiT
01-01-2013, 17:23
Witam serdecznie

Bardzo proszę o pomoc w jednej sprawie, która sprawiła, że padła mi cała strona

Korzystam z planu 90 na OVH a mój portal stoi na popularnej Joomli. Dziś chciałem wgrać rozszerzenie o nazwie K2 (http://www.softdesign-studio.pl/cms-...sci/item/50-k2) i tak też zrobiłem.
Niestety chwilę później moja strona siadła, nie jestem w stanie zalogować się nawet do panelu administratora, a problem brzmi tak:

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /homez.110/XXX/www/plugins/system/k2.php on line 127

Poszukałem w internecie w czym może być problem i natrafiłem na taką informację:

"the unexpected T_OBJECT_OPERATOR means you have PHP4 on your webhost. JoomlaComment 4 requires PHP version 5.x to function, please contact your webmaster/provider to update your server"
źródło - https://compojoom.com/forum/6-bug-re...rror-read-here

Idąc więc dalej znalazłem na stronach OVH takową informację:

"Tak - w serwisie 60free jest możliwość korzystania z PHP v4. Jest to możliwe poprzez nadanie skryptom rozszerzenia '.php4' (i odpowiednio dla PHP v5 - '.php5'). Rozszerzenie '.php' standardowo jest powiązane z PHP v5."

http://pomoc.ovh.pl/ProblemyZPhp

Edytowałem w notatniku swój plik .htaccess i zauważyłem, że faktycznie miałem tam wpisane SetEnv PHP_VER 4 więc zmieniłem to na SetEnv PHP_VER 5. Zmieniony plik uploadowałem i podmieniłem za stary .htaccess

Niestety błąd nie zniknął i wciąż wyświetla się ten komunikat.

Czy ktoś mógłby mi z tym pomóc? Byłbym bardzo wdzięczny.