OVH Community, your new community space.

Problem z RAID1


Spacedust
27-11-2012, 15:24
Cytat Napisał AcidWeb
Dla potomnych:
Był problem z kablami SATA.
Jak zwykle w OVH Pewnie je tak montują, że są całe pozginane i wypadają. Powinni dawać takie ze zatrzaskami.

AcidWeb
27-11-2012, 10:36
Dla potomnych:
Był problem z kablami SATA.

Spacedust
14-11-2012, 11:34
Cytat Napisał AcidWeb
Gentoo. Kernel: 3.6.5-hardened

Badblocka swojego puszczałem po pierwszej awarii - czysto.
W takim razie uszkodzona płyta lub stary BIOS.

AcidWeb
13-11-2012, 10:28
Gentoo. Kernel: 3.6.5-hardened

Badblocka swojego puszczałem po pierwszej awarii - czysto.

Spacedust
13-11-2012, 10:06
Dysk jest sprawny, firmware jest najnowszy. Bardzo dziwne. Jaki to jest system ?

Moim zdaniem jest to uszkodzony kabel lub płyta.

Przeskanuj cały dysk za pomocą badblocks -s /dev/sdb

AcidWeb
13-11-2012, 09:09
Witam,

mam problem z mdraidem na mojej maszynie i mam nadzieje że ktoś tutaj pomoże mi to zdiagnozować.
Już dwukrotnie wypięło mi tą samą partycje z tego samego dysku twardego.

Dmesg: http://pastebin.com/raw.php?i=nyAAUwBp

SMART: http://pastebin.com/raw.php?i=indpSHn8
Nie licząc minimalnego Command_Timeout wygląda zdrowo.

mdstat:
Kod:
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [multipath] [faulty]
md1 : active raid1 sda1[0] sdb1[1]
      10238912 blocks [2/2] [UU]

md5 : active raid1 sda5[0] sdb5[1]
      307198848 blocks [2/2] [UU]

md6 : active raid1 sda6[0] sdb6[1]
      307198848 blocks [2/2] [UU]

md7 : active raid1 sda7[0]
      259958656 blocks [2/1] [U_]

md8 : active raid1 sda8[0] sdb8[1]
      37690240 blocks [2/2] [UU]

md9 : active raid1 sda9[0] sdb9[1]
      37690240 blocks [2/2] [UU]

unused devices: 
W obu wypadkach wypadł mi sdb7. W obu wypadkach stało się to gdy md7 było znacznie obciążone IO. Dodatkowo przez ostatnie dni munin zglasza mi pojedyńcze i rzadkie spike Write IO Wait time na sdb.
Po ponownym przypieciu sdb7 do md7 syncuje się on bez błędów.

Z góry dziękuje za pomoc.