We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Reinstalacja mysql


h8g923
01-07-2012, 00:18
zdobądź dostęp do panelu OVH, lub zatrudnij administratora

melers
30-06-2012, 20:06
Macie moze jakiś pomysł

melers
30-06-2012, 15:05
Zacząłem bawić się z chrootem ale niestety teraz nie mogę nawet zalogować się poprzez ssh na serwer :/

maciej
29-06-2012, 21:41
Jeśli nie masz dostępu do panelu ovh i nie możesz przeinstalować systemu. W chroocie postawisz sobie system np: debian i będzie Ci działał mysql :P

melers
29-06-2012, 16:56
i co mi to da? bo zbytnio nie wiem jakby to miało mi pomóc

maciej
29-06-2012, 15:39
zrób chroota.

melers
29-06-2012, 14:20
Tylko jest problem bo nie mam dostepu do panelu ovh a jedynie do ssh :/

borec
29-06-2012, 14:14
Release 2 nie jest kompatybilny z gentoo. Zaoraj i zainstaluj coś normalnego. Była o tym mowa na forum wiele razy.

melers
29-06-2012, 14:06
Witam. Jako że na swoim serwerze miałem problem z mysql postanowiłem go usunąć i ponownie zainstalować. Usunięcie poprzez emerge obyło się bez żadnych problemów. Niestety jednak instalacja nie chce się powieść. Oto log:

Kod PHP:
ks362982 dev-lang # emerge mysql
Calculating dependencies - *
 * 
ERRORdev-lang/php4-ovh-4.4.8_pre20070816-r1 failed.
 * 
Call stack:
 *                              
ebuild.shline 1590:  Called source '/usr/local/portage-ovh/dev-lang/php4-ovh/php4-ovh-4.4.8_pre20070816-r1.ebuild'
 
*   php4-ovh-4.4.8_pre20070816-r1.ebuildline   29:  Called inherit 'php4_4-sapi'
 
*                              ebuild.shline 1312:  Called die
 * 
The specific snippet of code:
 * 
QA Notice'sed' called in global scopeeclass php4_4-sapi
 
QA Notice'sed' called in global scopeeclass php4_4-sapi
 
*              [ ! -"$location] && die "${1}.eclass could not be found by inherit()"
 
*  The die message:
 *   
php4_4-sapi.eclass could not be found by inherit()
 *
 * If 
you need supportpost the topmost build error, and the call stack if relevant.
 * 
This ebuild is from an overlay'/usr/local/portage-ovh/'
 
*                                                                                                                                                          / *
 * 
ERRORdev-lang/php5-ovh-5.2.5-r1 failed.
 * 
Call stack:
 *                  
ebuild.shline 1590:  Called source '/usr/local/portage-ovh/dev-lang/php5-ovh/php5-ovh-5.2.5-r1.ebuild'
 
*   php5-ovh-5.2.5-r1.ebuildline   26:  Called inherit 'php5_2-sapi'
 
*                  ebuild.shline 1312:  Called die
 * 
The specific snippet of code:
 * 
QA Notice'sed' called in global scopeeclass php5_2-sapi
 
QA Notice'sed' called in global scopeeclass php5_2-sapi
 
*              [ ! -"$location] && die "${1}.eclass could not be found by inherit()"
 
*  The die message:
 *   
php5_2-sapi.eclass could not be found by inherit()
 *
 * If 
you need supportpost the topmost build error, and the call stack if relevant.
 * 
This ebuild is from an overlay'/usr/local/portage-ovh/'
 
*                                                                                                                                                          \
!!! 
All ebuilds that could satisfy "mysql" have been masked.
!!! 
One of the following masked packages is required to complete your request:
dev-db/mysql-4.0.27-r1 (masked bypackage.maskmissing keyword)
/
usr/portage/profiles/package.mask:
# Jeremy Olexa  (28 Jul 2009)
# On behalf of Robin H. Johnson .
# These versions are vulnerable to GLSA's and should not be used. They will stay
# in the tree because they are useful to tracking down bugs. You have been
# warned. bug 271686

dev-db/mysql-4.1.22-r1 (masked bypackage.maskmissing keyword)
dev-db/mysql-5.0.91 (masked byrequired EAPI 2supported EAPI 1)
dev-db/mysql-5.0.92 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.0.96 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.51 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.52 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.52-r1 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.53 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.56 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.56-r1 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.57 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.58-r1 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.59 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.61 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.62 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.1.62-r1 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.5.19 (masked byrequired EAPI 4supported EAPI 1)
/
usr/portage/profiles/package.mask:
# Jorge Manuel B. S. Vicetto  (28 Jul 2011)
# A new update of the mysql / mariadb mask
# Robin H. Johnson  (01 Feb 2010)
# Mask 5.5/6.0 series that are alpha and and crazy experimental.
# Mask 5.2/5.3 virtual that exists in the overlay as well (it is MariaDB only)

dev-db/mysql-5.5.20 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.5.21 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.5.22 (masked byrequired EAPI 4supported EAPI 1)
dev-db/mysql-5.5.22-r1 (masked byrequired EAPI 4supported EAPI 1)

For 
more informationsee MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook