We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Przeniesienie domeny na VPS


Freaken
02-07-2012, 21:39
Dzięki za pomoc. Przy pomocy paru tutoriali udało mi się to skonfigurować i chyba działa tak jak powinno. No i czegoś nowego się nauczyłem przy okazji .

rootak
02-07-2012, 19:43
>>Na początku nie wiedziałem o co Ci chodzi. Chwilę googlałem - wygląda na to, że muszę dodać sekcję zone "hallofcode.com" w pliku named.conf - tak?

To Ty w ogóle tego nie ustawiałeś?
Pierwszy link z google na temat binda:

http://matipl.pl/2010/11/19/bind-ser...-konfiguracja/

dla domeny hallofcode.com zbudować coś takiego

zone "domena.pl" {
type master;
file "/etc/bind/M/domena.pl";
notify yes;
allow-transfer { XXX.XXX.XXX.XX; };
};

gdzie
file - plik na serwerze w której będzie szczegółowa konfiguracja domeny
allow-transfer to dns secondary


>>Co powinienem zawrzeć w pliku strefy? Mogę po prostu przekopiować konfigurację z managera ovh?

Tak
Zapoznaj się z opisem tego pliku na stronie której podałem, przy zmianie danych w pliku pamiętaj o zmianie numeru seryjnego.

Freaken
02-07-2012, 13:32
Na początku nie wiedziałem o co Ci chodzi. Chwilę googlałem - wygląda na to, że muszę dodać sekcję zone "hallofcode.com" w pliku named.conf - tak?
Co powinienem zawrzeć w pliku strefy? Mogę po prostu przekopiować konfigurację z managera ovh?

(jestem teraz za bardzo restrykcyjnym proxy, więc niestety tylko popołudniami mogę się tam zalogować po ssh)

rootak
02-07-2012, 13:23
A jak masz zadeklarowaną tą strefę?

type master?

Freaken
30-06-2012, 11:48
Dzięki. Mówisz o restartowaniu named? Niestety nie pomogło:
- na dig hallofcode.com dostaję connection timed out; no servers could be reached
- podobnie na host hallofcode.com

Co więcej widzę że za każdym razem jak próbuję w konfiguracji domeny zmienić pole SOA, jest ono po jakimś czasie przywracane do tego:

Kod:
@	IN SOA dns20.ovh.net. tech.ovh.net. (2012062802 86400 3600 3600000 86400)
To w porządku? Wydawało mi się że dns20 powinno być zamienione wszędzie na sdns2.

slawqo
30-06-2012, 08:17
Cytat Napisał Freaken
Chodzi o tę linijkę?
listen-on port 53 { 127.0.0.1; };
Tak. Ustaw tam:
listen-on port 53 { any; };

i wtedy po restarcie bind powinien odpowiadać na zapytania z zewnątrz.

Freaken
30-06-2012, 06:58
Kod:
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
        listen-on port 53 { 127.0.0.1; };
        listen-on-v6 port 53 { ::1; };
        directory       "/var/named";
        dump-file       "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
        allow-query     { localhost; };
        recursion yes;

        dnssec-enable yes;
        dnssec-validation yes;
        dnssec-lookaside auto;
                                                                                                                                   
        /* Path to ISC DLV key */
        bindkeys-file "/etc/named.iscdlv.key";
};

logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};

zone "." IN {
        type hint;
        file "named.ca";
};

include "/etc/named.rfc1912.zones";
Chodzi o tę linijkę?
listen-on port 53 { 127.0.0.1; };

slawqo
29-06-2012, 20:18
Sprawdź (właśnie w /etc/named.conf) czy masz ustawione, aby bind słuchał wszędzie a nie tylko na localhost. W tej chwili twój vps nie odpowiada strefą dns dla tej domeny:
Kod:
dig hallofcode.com @vps17843.ovh.net

; <<>> DiG 9.8.1-P1 <<>> hallofcode.com @vps17843.ovh.net
;; global options: +cmd
;; connection timed out; no servers could be reached

rootak
29-06-2012, 10:35
Pokaż /etc/named.conf

Freaken
28-06-2012, 15:13
Hej, widziałem że już był podobny wątek nawet w tym dziale, ale nie zupełnie o to samo tam chodziło.

Próbuję przekonfigurować domenę która była skonfigurowana dla start1m, aby wskazywała na mój nowy serwer VPS.

W managerze v3 udało mi się do tej pory skonfigurować domenę w ten sposób:
Kod:
$TTL 86400
@	IN SOA sdns2.ovh.net. tech.ovh.net. (2012062800 86400 3600 3600000 86400)
           IN NS     vps17843.ovh.net.
           IN NS     sdns2.ovh.net.
           IN MX 1   mx1.ovh.net.
           IN MX 100 mxb.ovh.net.
           IN MX 5   mx2.ovh.net.
           IN A      46.105.25.37
       600 IN TXT    "v=spf1 include:mx.ovh.com ~all"
www        IN CNAME  hallofcode.com.
Edytowałem tutaj przede wszystkim pola NS,SOA i A.

Serwery DNS również są ustawione na:
vps17843.ovh.net -primary
sdns2.ovh.net -secondary

Po stronie ustawień VPS, w zakładce "zaawansowane" udało mi się ustawić reverse DNS na hallofcode.com, dodatkowo jeszcze dodałem to samo do secondary dns (coś to zmienia? nie udało mi się wygooglać do czego do służy) ale wciąż gdy odpytuję domenę przez dig, nie dostaję pola "A" w odpowiedzi, nie mogę się też do niego dostać. Port 53 mam otwarty.
Jestem bardziej programistą niż administratorem, wydawało mi się że taka rzecz jak przepisanie domeny na inny IP powinno być rzeczą prostą, a jednak...

Będę wdzięczny za jakąkolwiek pomoc.

P.S. dodam że system mam CentOS jeśli to ma jakieś znaczenie