We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

problem dot. serwera i safe mode


Łabędź
06-09-2005, 22:54
Cytat Napisał MX^Lucas
Chmmm, widze, ze ktos probuje wyklady administratorowi porobic ;-)
I bardzo dobrze. Wiedza się zawsze przyda. No i doświadczony użytkownik, zawsze może wytknąć więcej błędów.

Cytat Napisał MX^Lucas
W takim razie, jezeli podczas uploadu suexec tworzy pliki z prawami uzytkownika, gdzie sa ograniczone do wlasnego katalogu, to czy nie prosciej byloby przerobic, by u siebie skladowac tmp?
Napewno prościej, jednakże większość użytkowników 60free ma nikłe pojęcie o PHP, HTML itd. Dlatego konfiguracja musi być jak najbardziej zbliżona do tej na 'normalnym' serwerze, aby wszyscy mogli sobie zainstalować gotowe pakiety typu Mambo, phpBB czy inne blogi.

Cytat Napisał MX^Lucas
Po co meczyc sie w /home czy /home/tmp, skoro uzytkownik nawet nie ma zadnych praw przez safe_mode, ale... w katalogu /home/f/o/t/fotoblog/www/tmp mialby...
Wbrew pozorom z 'safe_mode' jest wystarczająca ilość praw - utrudnione jest jedynie 'grzebanie u kogoś'. Niestety taka konfiguracja, w której 'safe_mode' jest praktycznie przeźroczyste jest dosyć trudna i wymaga dogrania wielu szczegółów.

pozdrawiam

Łabędź
06-09-2005, 22:46
Cytat Napisał fotoblog
Po założeniu konta na ovh.org napotkałem się na pewien problem podczas uploadowania pliku na serwer:

Warning: move_uploaded_file() [function.move-uploaded-file]: SAFE MODE Restriction in effect. The script whose uid is 9164 is not allowed to access /home owned by uid 0 in /home/f/o/t/fotoblog/www/admin/index.php on line 419

jak napisano w newsie na stronie:

zmieniliśmy ścieżkę dostępu ładowanych plików tymczasowych 'tmp_upload_dir' na '/home/tmp' co powinno rozwiązać część problemów dotyczących 'safe_mode'.

jednak z tego co głosi komunikat nie zmieniono scieżki na /home/tmp tylko na /home
Chcialbym rowniez zwrocic uwage na odpowiednie prawa dostepu do tego katalogu.
'upload_tmp_dir' jest ustawiona na '/home/tmp' - proszę zobaczyć phpinfo(),
Uprawnienia do katalogu są OK:
Kod:
60free1:/home# ls -la | grep tmp
drwxrwxrwt   2 root root    4096 Sep  6 22:07 tmp
Cytat Napisał fotoblog
Moja strona to fotoblog; niezbędne do jej działania jest prawo zapisu serwera do mojego katalogu.Inaczej nie działa.
Dostęp do katalogów użytkowników jest.

W Pana przypadku podejrzewam, że pomoże zmiana w konfiguracji strony: imagepath (tabela 'pixelpost_config') z '/home/images' zmieniłbym na conajmniej '/home/tmp', a jeszcze lepiej na jakiś katalog bezpośrednio na koncie. Bo do '/home/images' dostępu faktycznie nie ma.

Cytat Napisał fotoblog
Może to trochę pomoże adminowi w prowadzeniu serwera:
Dziękuje za chęci...

pozdrawiam

MX^Lucas
06-09-2005, 20:42
Witam ponownie...

Chmmm, widze, ze ktos probuje wyklady administratorowi porobic ;-) W takim razie, jezeli podczas uploadu suexec tworzy pliki z prawami uzytkownika, gdzie sa ograniczone do wlasnego katalogu, to czy nie prosciej byloby przerobic, by u siebie skladowac tmp? Po co meczyc sie w /home czy /home/tmp, skoro uzytkownik nawet nie ma zadnych praw przez safe_mode, ale... w katalogu /home/f/o/t/fotoblog/www/tmp mialby...

Czyli krotko mowiac, moje podworko moge stawiac co chce, a ja obce, to maja prawo zmiesc wszystko z powierzchni ziemi

Pozdrawiam serdecznie
MX^Lucas

fotoblog
06-09-2005, 18:55
Witam!
Po założeniu konta na ovh.org napotkałem się na pewien problem podczas uploadowania pliku na serwer:

Warning: move_uploaded_file() [function.move-uploaded-file]: SAFE MODE Restriction in effect. The script whose uid is 9164 is not allowed to access /home owned by uid 0 in /home/f/o/t/fotoblog/www/admin/index.php on line 419

jak napisano w newsie na stronie:

zmieniliśmy ścieżkę dostępu ładowanych plików tymczasowych 'tmp_upload_dir' na '/home/tmp' co powinno rozwiązać część problemów dotyczących 'safe_mode'.

jednak z tego co głosi komunikat nie zmieniono scieżki na /home/tmp tylko na /home
Chcialbym rowniez zwrocic uwage na odpowiednie prawa dostepu do tego katalogu.

Moja strona to fotoblog; niezbędne do jej działania jest prawo zapisu serwera do mojego katalogu.Inaczej nie działa.

Może to trochę pomoże adminowi w prowadzeniu serwera:

If you're running PHP as apache module, it will always write files as "nobody", "www", "httpd", (or whatever user your webserver runs as) unless you specify a different user/group in httpd.conf, or compile apache with suexec support.
However, if you run PHP as a CGI wrapper, you may setuid the PHP executable to whatever user you wish (*severe* security issues apply). If you really want to be able to su to other user, I recommend compiling with suexec support.
AFAIK, PHP can't NOT use SuEXEC if apache does. If PHP is configured as an apache module it will act as whatever user the apache is. If apache SuEXEC's to otheruserthergroup (e.g. root:root), that's what PHP will write files as, because it acts as a part of apache code. I suggest you double-check your SuEXEC configuration and settings. Note: you can't su to another user within the PHP code -- it has to be an apache directive, either through , or through .htaccess. Also note: I'm not sure how it all works (if it works at all) on Win32 platforms.
Check www.apache.org to see how it's done.