We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Domeny nie działają na apache w jail


dong
14-02-2012, 21:46
Idą. Access logi się zapełniają.

Linux admin
14-02-2012, 21:25
Cytat Napisał dong
Nie miałem zmieniałem na takie:

NameVirtualHost x.y.org:80
Pozostaje sprawdzić czy rzeczywiście requesty idą do tego apache: czy widać je niezależnie od tego jaki host jest w URL w głównym access logu.

Twój ostatni konfig, w którym NameVirtualHost jest taki sam jak w wygląda dla mnie OK.

no4b
14-02-2012, 19:31
Po NameVirtualHost powinno być IP i port skoro tak masz w VirtualHost.

dong
14-02-2012, 19:14
Nie miałem zmieniałem na takie:

NameVirtualHost x.y.org:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any block.
#


ServerAdmin webmaster@x.y.org
DocumentRoot "/usr/local/www/x.y.org"
ServerName x.y.org
ServerAlias www.x.y.org
ErrorLog "/var/log/apache/x.y.org-error_log"
CustomLog "/var/log/apache/x.y.org-access_log" combinedio



I nie działa...


Tak również nie działą:


NameVirtualHost x.y.org:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any block.
#


ServerAdmin webmaster@x.y.org
DocumentRoot "/usr/local/www/x.y.org"
ServerName x.y.org
ServerAlias www.x.y.org
ErrorLog "/var/log/apache/x.y.org-error_log"
CustomLog "/var/log/apache/x.y.org-access_log" combinedio



I nie działa...

Linux admin
14-02-2012, 18:43
Cytat Napisał dong
Zmieniłem:


bez zmian. nadal nie działa.
Masz w konfigu:

NameVirtualHost x.y.org:80


?

dong
14-02-2012, 13:58
Zmieniłem:


bez zmian. nadal nie działa.

no4b
14-02-2012, 13:20
Chodziło mi o to, że nie trafiają do virtualhosta.

dong
14-02-2012, 12:49
Zapytania trafiają do jaila, bo włącza się roundcube. Problem w tym, że po x.y.org powinno włączać się coś innego z tego jaila... na hoście nie mam żadnego serwera www.

Ale dodałem linijke w etc/hosts:

192.168.1.1 x.y.org

no4b
14-02-2012, 12:00
x.y.org zapewne nie wskazuje na 192.168.1.1, więc zapytania tam nie trafiają.

dong
14-02-2012, 11:36
Mam hosta z zew ip. Jail jest na 192.168.1.1

Konfiguracja vhosta wygląda tak:

DocumentRoot /usr/local/www/x.y.org
ServerName x.y.org
ServerAlias www.x.y.org
ServerAdmin webmaster@x.y.org
ErrorLog "/var/log/apache/x.y.org-error_log"
CustomLog "/var/log/apache/x.y.org-access_log" combinedio




........................

Alias / "/usr/local/www/roundcube/"
#Alias /mail "/usr/local/www/roundcube/"
#Alias /webmail "/usr/local/www/roundcube/"
#Alias /roundcube "/usr/local/www/roundcube/"

Options -Indexes
i po wpisaniu x.y.org włącza mi się roundcube mail, zamiast tej domeny. Dlaczego?

Jeszcze pf.conf

nat on em0 from 192.168.1.0/24 to any -> 188.165.227.1
# Port forwarding
rdr pass on em0 proto tcp from any to em0 port 666 -> 192.168.1.4 port 777
# Mail
rdr pass on em0 proto tcp from any to em0 port 25 -> 192.168.1.1 port 25 # SMTP
rdr pass on em0 proto tcp from any to em0 port 587 -> 192.168.1.1 port 587 # SMTP SSL, Submission
rdr pass on em0 proto tcp from any to em0 port 110 -> 192.168.1.1 port 110 # POP3
rdr pass on em0 proto tcp from any to em0 port 995 -> 192.168.1.1 port 995 # POP3 SSL
#rdr pass on em0 proto tcp from any to em0 port 12314 -> 192.168.1.1 port 80 # POP3 SSL
# HTTP
rdr pass on em0 proto tcp from any to 188.165.227.1 port 80 -> 192.168.1.1 port 80