OVH Community, your new community space.

"Nieprawidłowa konfiguracja serwera"


WMP
10-03-2012, 11:24
Cytat Napisał seal
Innym dobrym rozwiązaniem aby nie siać broadcastami ani niczym z IP failover jest przybindowanie go do loopbacka... jak by w ten sposób zrobili poradnik to problem w ogóle by nie występował
Powiedz coś więcej bo inaczej chyba nie rozwiążę tego problemu, maska /32 i broadcast taki jak failover nic nie dają.

seal
10-03-2012, 07:50
Innym dobrym rozwiązaniem aby nie siać broadcastami ani niczym z IP failover jest przybindowanie go do loopbacka... jak by w ten sposób zrobili poradnik to problem w ogóle by nie występował

pwesolek
09-03-2012, 16:38
Weź pod uwagę, że chodzi tutaj o konfigurację failover, nie głównego IP -- czyli prawdopodobnie interfejsu w rodzaju eth0:0.

W takiej sytuacji nie powinno być broadcastów z IP failover. Można tego uniknąć ustawiając maskę (255.255.255.255) i broadcast (=IP failover).

http://forum.ovh.pl/showthread.php?t=12187&page=5

WMP
10-02-2012, 12:16
Hmmm, czy to normlane że 2 różne adresy IP maja w tablicy arp ten sam mac?

no4b
10-02-2012, 12:05
Jest. Nie potrzebujesz NM na serwerze.

WMP
10-02-2012, 11:23
Kod:
Address                  HWtype  HWaddress           Flags Mask            Iface
95.168.204.130           ether   00:00:0c:9f:f0:01   C                     eth0
94.23.199.254            ether   00:00:0c:9f:f0:01   C                     eth0
94.23.199.251            ether   00:30:48:87:07:e2   C                     eth0
@slawqo: a to nie jest od NetworkManagera?

slawqo
10-02-2012, 06:58
Ja nie znam fedory i centos'a. ale czy ta linijka:
NM_CONTROLLED = yes
nie powoduje to jakiegoś problemu? Spróbuj ją usunąć i zobaczyć co będzie.

slawek.cichon
10-02-2012, 00:01
sprawdz
Kod:
arp -n
przy prawidlowo ustawionym interfejsie powinieneś mieć tylko MAC bramki, przynajmniej ja tak mam

WMP
09-02-2012, 23:06
Moja konfiguracja od tej co podałes nie różni się niczym

slawek.cichon
09-02-2012, 22:26
Miałem podobny problem, przykładowa konfiguracja z Fedory :
Kod:
DEVICE="eth0"
HWADDR="02:00:00:6C:1A:82"
BOOTPROTO="none"
ONBOOT="yes"
IPADDR=94.xxx.xxx.xxx
BROADCAST=94.255.255.255
NETMASK=255.255.255.255
NM_CONTROLLED="yes"
DNS1=213.186.33.99
GATEWAY=188.xxx.254.254[Brama fizycznej maszyny]
TYPE=Ethernet
USERCTL=yes
IPV6INIT=no
do tego jeszcze
routing :
188.xxx.254.254 dev eth0
default via 188.xxx.254.254 dev eth0

WMP
08-02-2012, 10:39
255.255.255.255

cousin
08-02-2012, 01:32
jaką maskę masz dla tego dodatkowego ip?

WMP
05-02-2012, 11:23
Ok, ślepy jestem Tylko że ten failover skonfigurowany jest jak cała gama innych, nie wiem dlaczego z tym są problemy. Po wyłaczeniu ARP dla eth0 dostałem info od OVH że maszyna nie odpowiada

desavil
04-02-2012, 20:22
Nie firewalla tylko failovera

WMP
04-02-2012, 17:57
Ja tam nie widzę firewalla tylko ustawienia interfejsów sieciowych i routingu

victor
04-02-2012, 17:34
Cytat Napisał WMP
Emmm, jakiego firewalla? W adresach w mailu który dostaję od OVH nie ma żadnych informacji o firewallu
zainwestuj w okulary bo źle czytasz. Tak jak ci kolega wyżej poradzil to znaczy że masz źle ustawione dod. IP. >> poradnik ovh

WMP
04-02-2012, 17:24
Emmm, jakiego firewalla? W adresach w mailu który dostaję od OVH nie ma żadnych informacji o firewallu

slawqo
04-02-2012, 17:20
sprawdź czy konfiguracja twojego failovera jest dokładnie taka jak w podanych tam przewodnikach. Jeżeli wszystko jest dokładnie tak jak w przewodnikach i masz dalej te maile, to wyślij konfigurację na pomoc@ovh.pl, albo otwórz ticket'a w tej sprawie.

WMP
04-02-2012, 16:44
Kod:
Państwa serwer [CIACH] wysyła zbyt dużo zapytań do naszej sieci
przez IP failover [CIACH], co wynika z jego nieprawidłowej konfiguracji.

Dbając o stabilne działanie usług zalecamy
poprawienie konfiguracji dla IP failover
[CIACH] najszybciej, jak jest to możliwe.

Zachęcamy do zapoznania się z następującymi przewodnikami:
http://pomoc.ovh.pl/DodajAliasIp
http://pomoc.ovh.pl/BridgeClient


Poniżej znajdą Państwo logi wskazujące na problem:

-------  FRAGMENT ZAPYTAŃ  -------

Fri Feb 3 21:45:04 2012 : arp who-has [CIACH] tell [CIACH]
Fri Feb 3 21:50:03 2012 : arp who-has [CIACH] tell [CIACH]
Fri Feb 3 21:52:02 2012 : arp who-has [CIACH] tell [CIACH]
Fri Feb 3 21:52:37 2012 : arp who-has [CIACH] tell [CIACH]
Fri Feb 3 22:03:22 2012 : arp who-has [CIACH] tell [CIACH]
Fri Feb 3 22:03:36 2012 : arp who-has [CIACH] tell [CIACH]
Fri Feb 3 22:24:14 2012 : arp who-has [CIACH] tell [CIACH]
Fri Feb 3 22:24:14 2012 : arp who-has [CIACH] tell [CIACH]
Fri Feb 3 23:46:03 2012 : arp who-has [CIACH] tell [CIACH]
Fri Feb 3 23:46:03 2012 : arp who-has [CIACH] tell [CIACH]

-------   KONIEC WYCINKA   -------
Co z tym zrobić? Bo na razie jest tak ż OVH blokuje IP, ja odblokowuje, oni znów blokują a ja znów odblokowuję...