We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Kimsufi, BIND9 i SERVFAIL


ks386939
25-01-2012, 11:15
Prawie każdy DNS ma wyłączoną rekursje dla zewnętrznych klientów (allow-recursion {xxx}, a większość większych nie odpowiada na zapytania z zewnątrz (allow-query {xxx} .

Tyle, że wtedy DNS odmawia REFUSED (np.: ns1.google.com)
Netart zwraca SERVFAIL, czyli problem (błąd) serwera.

Poza tym, z wyłączona rekursją powinien zwrócić w AUTHORITY SECTION listę serwerów x-dns.pl (szukaj dalej sam)

A ostatecznie chodzi o to, że klienci hostowani w netart.pl przy wysyłaniu maili do moich domen dostają informacje, ze domena (MX) nie znaleziona

no4b
25-01-2012, 10:56
Może netart nie odpowiada poza swoją siecią rekursywnie?

ks386939
25-01-2012, 09:14
Wygląda na to, że netart blokuje domeny hostowane na OVH

Sprawdziłem na kilku przypadkowych domenach utrzymywanych na OVH
Wszystkie działają prawidłowo, a DNS'y netart.pl zwracają SERVFAIL
Z tego powodu np.: nie dochodzi poczta od klientów, których serwery pocztowe są hostowane przez netart.pl

W związku z tym mam prośbę.
Czy moglibyście sprawdzić ponizszy skrypcik na swoich domenach utrzymywanych na serwerach OVH?

Kod:
@!/bin/bash

echo "$1"
dig "$1"
dig @ns1.netart.pl "$1"

ks386939
24-01-2012, 21:47
Teraz wszystkie narzędzia, np:
zwracają prawidłowe wyniki, ale taki np.: ns1.netart.pl nadal udaje, ze moich domen nie ma

Czyli temat nadal otwarty.

ks386939
24-01-2012, 20:16
Z jakiś względów NS nie może być IP tylko musi być FQDN

Czyli musiałem zmienić (zaznaczone na czerowono)
@ IN SOA ns.xxx.pl admin.xxx.pl. (
2012012401 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;

* 86400 A ##.##.##.##
ns.xxx.pl 86400 A ##.##.##.##
xxx.pl 86400 A ##.##.##.##
xxx.pl 86400 MX 10 xxx.pl
xxx.pl 86400 NS ns.xxx.pl
xxx.pl 86400 NS ns.kimsufi.com.

Moze komus sie to kiedyś przyda

ks386939
24-01-2012, 15:46
Witam
Mam na OVH serwera dedykowanego kimsufi z BIND 9.7.3
Przetransferowałem swoje domeny na OVH i podałem
primary: mój kimsufi
secondary: ns.kimsufi.com

I wszystko jest Ok z wyjątkiem kilku (wiem o ns1.netart.pl) DNS'ów, które nie "widzą" moich domen. Badanie nslookup'em zwraca
server can't find xxx.pl: SERVFAIL

W pliu strefy mam:
$TTL 86400
@ IN SOA ##.##.##.## admin.xxx.pl. (
2012012401 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;

* 86400 A ##.##.##.##
xxx.pl 86400 A ##.##.##.##
xxx.pl 86400 MX 10 xxx.pl
xxx.pl 86400 NS ##.##.##.##.
xxx.pl 86400 NS ns.kimsufi.com.

gdzie oczywiście xxx.pl - moja domena, a ##.##.##.## IP mojego kimsufi

w opcjach mam
allow-query {all;};
listen-on {all;};

a w strefach:
allow-transfer {213.186.33.199;};

I jak pisałem wszystkie znane mi hosty, serwery i DNS'y wszystko zwracają prawidłowo, z wyjątkiem tego jednego.

Czy ktoś z was się z czymś podpobnym spotkał i wie jak to rozwiązać?