We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

DHCP konfiguracja


viadro
29-08-2011, 14:43
Podobny problem z FreeBSD mialem pod VirtualBox'em na linux'ie. Musisz poprobowac z roznymi kartami sieciowymi. Realtek na bank nie dziala. Z tego co pamietam chyba poszlo mi z PCNet (nazwa urzadzenia zmieni sie z re0 na le0 chyba).

ArkadiuszL4G
24-08-2011, 23:26
przepraszam za double post

podejdę do tego z 2giej strony

proxmox :

Kod:
Interfejs : vmbr0
Port/slaves : eth0
adres ip : 188.165.194.84
maska podsieci : 255.255.255.0
brama : 188.165.194.254

......................................................
DNS

pierwszy dns : 127.0.0.1
drugi dns : 213.186.33.99
Nazwa hosta : ks211752.kimsufi.com
do tego ip failover które ma być przypisane do vps'a :

Kod:
178.33.50.103
Proszę o pomoc w przejściu przez ten punkt instalacji (zapewne w tym punkcie robię błędy )


ArkadiuszL4G
24-08-2011, 21:57
podczas restartu maszyny zauważyłem małe niezgodnosci

widzicie coś tutaj nie tak ?

no4b
24-08-2011, 21:12
Przemyśl to najpierw... Zastanów się co to robi...

ArkadiuszL4G
24-08-2011, 21:07
ok
wpisałem : cat /etc/resolv.conf
wyszło :



zrobię serwer testowy i wpisze w name serwer 127.0.0.1 zobzczymy co wyjdzie

furek
24-08-2011, 14:18
przy failover dhcp nic tutaj nie da.

FreeBSD jest dość oporny jako VPS w proxmoxie.
Ogólnie trochę trzeba się napocić, aby ustawić route na proxmoxa.

Pokaż konfiguracje dla debiana jaką zastosowałeś, aby mieć NET

Druciak
24-08-2011, 13:27
Nie wiem jak Ci pomóc, nie używam takich rzeczy jak proxmox.

Z jakiegoś powodu nie skonfigurowała się sieć na tym fbsd.
Może w managerze OVH musisz jakiś virtualny MAC dodać, nie mam pojęcia.

Może z tego fbsd spróbuj przetestować pobieranie IP z dhcp.

Na linuksie tak to robię:
# dhcpcd -T eth0
dhcpcd[17758]: version 5.2.7 starting
dhcpcd[17758]: eth0: broadcasting for a lease
dhcpcd[17758]: eth0: offered 188.165.XXX.XXX from 188.165.XXX.XXX
interface=eth0
pid=17758
reason=TEST
skip_hooks=lookup-hostname
new_broadcast_address=188.165.XXX.XXX
new_dhcp_lease_time=600
new_dhcp_message_type=2
new_dhcp_rebinding_time=525
new_dhcp_renewal_time=300
new_dhcp_server_identifier=188.165.XXX.XXX
new_domain_name_servers=213.186.33.99
new_filename=pxelinux.0
new_ip_address=188.165.XXX.XXX
new_network_number=188.165.XXX.X
new_routers=188.165.XXX.XXX
new_subnet_cidr=24
new_subnet_mask=255.255.255.0
Spróbuj coś podobnego na fbsd, powinieneś mieć jakieś polecenie z dhcp na początku, dhcpcd, dhcp-client czy coś podobnego.

W razie co, spróbuj man dhcp-client czy co tam masz... albo dhcp-client --help

ArkadiuszL4G
24-08-2011, 13:05


jeśli chodzi o proxmox to jedyne co mogę pomieszać to karta sieciowa
wybieram pierwszą

Druciak
23-08-2011, 22:27
No jak dla mnie to nie masz przypisanego adresu IP na karcie sieciowej.

Albo klienta dhcp nie ma na fbsd albo coś w proxmox jest z siecią namieszane.

no4b
23-08-2011, 21:45
Jak nie wiesz jakie są argumenty to doczytaj man route. Po to ktoś napisał tę dokumentację, żeby w razie braku wiedzy skorzystać. Anyway, Twoja aktualna konfiguracja jest bezsensowna i jeśli nie wiesz dalczego - doczyaj.

ArkadiuszL4G
23-08-2011, 20:32
id:

ifconfig

routing - nie wiem jakie są argumenty


nie wiem co robię źle ... instalowałem fbsd w sumie z 6 razy z poradnikiem www.freebsd.org

Druciak
22-08-2011, 15:31
Nie znam się na systemach BSD, ale powinno być w sumie podobnie....

w tym BSD zobacz jakie masz uprawnienia:
id

konfiguracje sieci:
ifconfig

rounting:
route
czy
route print

a co masz w resolv.conf ?
cat /etc/resolv.conf


Może tam znajdziesz odpowiedź. Może vps masz w proxmox źle skonfigurowany?

no4b
22-08-2011, 15:04
Szukaj dalej.

ArkadiuszL4G
22-08-2011, 13:51
tylko znajdę odpowiednią komendę do terminala

/// edit

gdy piszę z konta root'a

/etc/rc.conf

wyświetla mi permission denied kochany root

no4b
22-08-2011, 13:42
Sprawdź nameservery oraz czy osiągasz bramę.

ArkadiuszL4G
22-08-2011, 13:36
witam wszystkich przeglądających temat .

posiadam maszynę kimsufi 24G z postawionym gotowym systemem debian 6.0 + proxmox i 2 dodatkowe adresy ip

na maszynie stoją 2 vps'y : (Debian x86 i Freebsd 8.2)

Debiana zainstalowałem i skonfigurowałem bez problemowo a z Fbsd mam poważny problem

łącze się przez terminal proxmoxa
otóż system nie chce się połączyć z siecią zewnętrzną
Przy konfiguracji DHCP nie napotykam problemów lecz podczas próby pingowania wp.pl oraz jego ip
Kod:
ping: cannot resolve wp.pl: host name lookup failure
ping : sendto : no route to host
rozumiem że dhcp jest źle skonfigurowane ?