We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Bledy modulow w Apache...


MX^Lucas
04-09-2005, 15:15
Witam ponownie...

ldd /httpd-2.0.54/modules/mod_ssl.so
Wpisalem i pojawily sie takie informacje:

libc.so.6 => /lib/i686/libc.so.6 (0x4000f000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

Nic wiecej, jak i rowniez tak samo sie wyswietla na innych modulach. A co do obslugi dynamicznych modulow, to chyba mod_so? W takim razie to jest i wiekszosc modulow dziala, a tylko niektore, ktore sa wymienione nie dzialaja.

Wiec co moze byc?

Acha, rowniez jest taki blad z modulu suexec:

Warning: SuexecUserGroup directive requires SUEXEC wrapper.

Wiem, ze likwidujac SuexecUserGroup wszystko jest ok, ale... dlaczego pojawia sie taki blad?

I na koniec, czy jest mozliwosc zmiany, chociazby w jakichs plikach gdzie sam tworzy pliki konfiguracyjne httpd.include, tzn. chce zeby inaczej tworzyl wlasne pliki konfiguracyjne (np. zamiast sapi_apache2 wpisal mod_php5 itp).

Pozdrawiam serdecznie
MX^Lucas

Łabędź
04-09-2005, 14:48
Cytat Napisał MX^Lucas
Przy kompilacji i dodaniu modulow wszystko bylo ok, dzialalo bez zarzutow, ale podczas uruchomienia serwera Apache, to wywala takie bledy:

Kod:
Cannot load /httpd-2.0.54/modules/mod_ssl.so into server: 
Kod:
/httpd-2.0.54/modules/mod_ssl.so
: undefined symbol: ssl_cmd_SSLMutex
Najwyraźniej brak jakiejś dynamicznie ładowanej biblioteki. Proszę spróbować uruchomić:
Kod:
ldd /httpd-2.0.54/modules/mod_ssl.so
Powinno napisać jakie biblioteki są, a jakich brakuje.

Czy wkompilował Pan obsługę dynamicznie ładowanych modułów?

pozdrawiam

MX^Lucas
04-09-2005, 11:39
Witam ponownie...

Przy kompilacji i dodaniu modulow wszystko bylo ok, dzialalo bez zarzutow, ale podczas uruchomienia serwera Apache, to wywala takie bledy:

Kod:
Cannot load /httpd-2.0.54/modules/mod_ssl.so into server: /httpd-2.0.54/modules/mod_ssl.so: undefined symbol: ssl_cmd_SSLMutex

Cannot load /httpd-2.0.54/modules/mod_dav_fs.so into server: /httpd-2.0.54/modules/mod_dav_fs.so: undefined symbol: dav_fs_find_liveprop

Cannot load /home/sbin/local/httpd-2.0.54/modules/mod_dav.so into server: /httpd-2.0.54/modules/mod_dav.so: undefined symbol: dav_core_find_liveprop

Cannot load /httpd-2.0.54/modules/mod_proxy.so into server: /httpd-2.0.54/modules/mod_proxy.so: undefined symbol: ap_proxy_is_word

Cannot load /httpd-2.0.54/modules/proxy_connect.so into server: /httpd-2.0.54/modules/proxy_connect.so: undefined symbol: ap_proxyerror

Syntax error on line 257 of /httpd-2.0.54/conf/httpd.conf:
server: /httpd-2.0.54/modules/mod_deflate.so: undefined symbol: deflate

Cannot load /httpd-2.0.54/modules/mod_cache.so into server: /httpd-2.0.54/modules/mod_cache.so: undefined symbol: cache_generate_key_default

Cannot load /httpd-2.0.54/modules/mod_disk_cache.so into server: /httpd-2.0.54/modules/mod_disk_cache.so: undefined symbol: ap_cache_cacheable_hdrs_out

Cannot load /httpd-2.0.54/modules/mod_mem_cache.so into server: /httpd-2.0.54/modules/mod_mem_cache.so: undefined symbol: cache_find

Cannot load /httpd-2.0.54/modules/mod_frontpage.so into server: /httpd-2.0.54/modules/mod_frontpage.so: undefined symbol: fpcgid_handler

Cannot load /httpd-2.0.54/modules/mod_frontpage.so into server: /httpd-2.0.54/modules/mod_frontpage.so: undefined symbol: fpcgid_handler
Jak wylaczylem te moduly, to wszystko dziala bardzo ladnie...

Panie Labedz, dlaczego tak jest i co tutaj brakuje, ze nie moze zidentyfikowac te wartosci? Zaznaczam, ze mam najnowsza wersje OpenSSL, Pythoon, Apache 2.0.54 i PHP 5.0.4 :-/

Pozdrawiam serdecznie
MX^Lucas