We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem techniczny z FTP


Generals
14-05-2011, 12:57
Cytat Napisał maciej
Skoro sugeruje PASV to go włącz w kliencie. Z tego co pamiętam też tak miałem klienta ustawiłem na tryb pasywny i działało.
Dzięki za próbę pomocy, ale ciągle używam pasywnego, co zresztą jest widoczne w kodzie.
Cytat Napisał slawqo
Zamiast podawać jako adres serwera twojadomena.pl to podawaj ftp.twojadomena.pl lub ftp.cluster010.ovh.net i powinno działać prawidłowo.
Zrobione, listing działa jak należy, wielkie dzięki za pomoc! Pozdrawiam.

Temat do zamknięcia ofkoz.

slawqo
14-05-2011, 12:41
Zamiast podawać jako adres serwera twojadomena.pl to podawaj ftp.twojadomena.pl lub ftp.cluster010.ovh.net i powinno działać prawidłowo.

maciej
14-05-2011, 11:34
Skoro sugeruje PASV to go włącz w kliencie. Z tego co pamiętam też tak miałem klienta ustawiłem na tryb pasywny i działało.

Generals
14-05-2011, 11:10
Dzięki Widmo za próbę pomocy ale to nie pomaga - dzisiaj taka akcja:

Kod:
[1] PASV
[1] 227 Entering Passive Mode (87,98,***,19,251,230)
[1] Opening data connection IP: 87.98.***.19 PORT: 64486
[1] Unable connect to 87.98.***.19:64486 (Connection Timeout(10060))
[1] Listening at IP: 77.113.***.128 PORT: 50370 for data connecting
[1] PORT 77,113,***,128,196,194
[1] 200 PORT command successful. Consider using PASV.
[1] LIST
[1] 150 Here comes the directory listing.
Program sam spróbował bez trybu pasywnego. Ale rzeczywistej odpowiedzi na LIST nadal nie ma, cisza po tej komendzie. Z tego co rozumiem serwer sam sugeruje tryb pasywny. Tutaj manualnie wyłączyłem PASV:

Kod:
[1] PWD
[1] 257 "/www"
[1] Listening at IP: 77.113.***.128 PORT: 50391 for data connecting
[1] PORT 77,113,***,128,196,215
[1] 200 PORT command successful. Consider using PASV.
[1] LIST
[1] 150 Here comes the directory listing.



[1] Can't open data connection
[1] 426 Failure writing network stream.
I znowu po LIST cisza, nie są wczytywane katalogi.

Widmo
14-05-2011, 09:23
Jak się wczytasz w komunikat, to masz jasno napisane

Wyłącz passive mode w kliencie FTP

Generals
13-05-2011, 23:23
PROBLEM ROZWIĄZANY, DZIĘKI

Witam, mam na OVH hosting z domeną już od dłuższego czasu i choć z różną prędkością, FTP działało. Od kilku dni logowanie itp idzie dobrze, ale serwer nie odpowiada na komendę LIST, nie mogę dojrzeć katalogów ani plików. Pogrzebałem we wszystkich chyba możliwych ustawieniach klienta (FTP Rush) i najlepsze co udało mi się uzyskać to odpowiedź serwera "here comes the directory listing" po której zwykle ukazują się foldery, jednak po tej odpowiedzi nic już się nie dzieje. Log typowej próby połączenia:
(ocenzurowałem dane prywatne gwiazdkami

Kod:
[1] Connecting to ***
[1] Resolving ***.com...
[1] ***.com => 87.98.***.19
[1] Connecting to 87.98.***.19:21
[1] 220-
[1] 220-Bienvenue, 
[1] 220-
[1] 220-       On Vous Héberge ?
[1] 220-           
[1] 220-Vous ętes connecté sur web506.
[1] 220 
[1] USER ***
[1] 331 Please specify the password.
[1] PASS ***
[1] 230 Login successful.
[1] SYST
[1] 215 UNIX Type: L8
[1] TYPE A
[1] 200 Switching to ASCII mode.
[1] REST 1
[1] 350 Restart position accepted (1).
[1] REST 0
[1] 350 Restart position accepted (0).
[1] FEAT
[1] 211-Features:
[1]  EPRT
[1]  EPSV
[1]  MDTM
[1]  PASV
[1]  REST STREAM
[1]  SIZE
[1]  TVFS
[1] 211 End
[1] PWD
[1] 257 "/"
[1] CWD www
[1] 250 Directory successfully changed.
[1] PWD
[1] 257 "/www"
[1] PASV
[1] 227 Entering Passive Mode (87,98,***,19,159,109)
[1] Opening data connection IP: 87.98.***.19 PORT: 40813
[1] LIST
[1] 425 Failed to establish connection.
[1] NOOP
[1] 200 NOOP ok.
[1] NOOP
[1] 200 NOOP ok.
[1] NOOP
[1] 200 NOOP ok.
[1] NOOP
[1] 200 NOOP ok.
Katalogów nie widać ale jestem w folderze www, wychodzę na parent directory:

Kod:
[1] CDUP
[1] 250 Directory successfully changed.
[1] PWD
[1] 257 "/"
[1] PASV
[1] 227 Entering Passive Mode (87,98,***,19,162,9)
[1] Opening data connection IP: 87.98.***.19 PORT: 41481
[1] LIST
[1] 425 Failed to establish connection.
[1] NOOP
[1] 200 NOOP ok.
Oczywiście po każdej komendzie LIST jest długie opóźnienie przed Failed. Wszystkie inne komendy łącznie z NOOP są odpowiadane natychmiastowo.

Moja konkluzja jest taka, że to chyba problem po stronie serwera? Proszę o pomoc.

Dodam tylko, że próbowałem też innym klientem FTP, rezultat ten sam - wszystko sprawne ale LIST nie działa.