We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Subdomeny.


Zielone_Oko
19-04-2011, 12:42
http://jaredhocutt.com/programming/e...g-apache-xampp

Podaje poradnik jak to zrobić )

Wyjaśnione, dziękuje za pomoc.
Można zamknąć

Zielone_Oko
18-04-2011, 16:32
Cytat Napisał slawqo
Ty to chcesz skonfigurować na swoim desktopie czy na serwerze? Raczej nie spotykałem się z aplikacjami takimi jak xampp na serwerze.
Jak masz Apache'a to w dokumentacji: http://httpd.apache.org/docs/1.3/vhosts/ jest wszystko opisane.
Jak masz Windows Serwer to możesz zamiast Apache'a użyć MS IIS i wyklikać wszystko w zarządzaniu usługami (czy jakoś tak to się tam nazywa - nie pamiętam teraz).
Mam serwer dedykowany i mam zainstalowany program xampp, to co mi podałeś do apache to dodaję tak jak jest napisane i nie działa...

slawqo
18-04-2011, 08:11
Ty to chcesz skonfigurować na swoim desktopie czy na serwerze? Raczej nie spotykałem się z aplikacjami takimi jak xampp na serwerze.
Jak masz Apache'a to w dokumentacji: http://httpd.apache.org/docs/1.3/vhosts/ jest wszystko opisane.
Jak masz Windows Serwer to możesz zamiast Apache'a użyć MS IIS i wyklikać wszystko w zarządzaniu usługami (czy jakoś tak to się tam nazywa - nie pamiętam teraz).

Zielone_Oko
17-04-2011, 21:26
Tak dodałem wpis w strefie DNS, lecz nie wiem jak mam skonfigurować virtualhosty w programie xampp.

slawqo
17-04-2011, 18:30
Subdomeny musisz przekierować na swój serwer tworząc odpowienie wpisy w strefie dns domeny (pola A lub pola CNAME).
Na serwerze muszisz skonfigurować odpowiednio virtualhosty, ale nie jako 127.0.0.2 bo taki adres nie jest "widoczny" nigdzie poza twoim serwerem.

Zielone_Oko
17-04-2011, 09:26
Cytat Napisał no4b
Bo w to trzeba włożyć śladowe ilości myślenia. Copy/paste się nie sprawdza.
Dobrze się mówi osobie, która się na tym zna.

no4b
16-04-2011, 23:59
Bo w to trzeba włożyć śladowe ilości myślenia. Copy/paste się nie sprawdza.

Zielone_Oko
16-04-2011, 21:20
Cytat Napisał no4b
Jeśli taką masz konfigurację na serwerze dedykowanym to są to bzdury. Co najmniej IP jest do zmiany, ścieżki prawdopodobnie też. Wpisy w hosts nie są potrzebne przy prawidłowej konfiguracji domeny.
Korzystałem z poradników, które znalazłem... Więc nie wiem w takim razie jak to skonfigurować

no4b
16-04-2011, 21:12
Jeśli taką masz konfigurację na serwerze dedykowanym to są to bzdury. Co najmniej IP jest do zmiany, ścieżki prawdopodobnie też. Wpisy w hosts nie są potrzebne przy prawidłowej konfiguracji domeny.

Zielone_Oko
16-04-2011, 21:04
w pliku hosts dopisuje linijkę: (na samym dole)

127.0.0.1 localhost
127.0.0.2 forum.xxx.pl

natomiast w pliku httpd-vhosts.conf dodaje:


ServerName localhost
DocumentRoot "C:/xampp/htdocs"

AllowOverride All
Order allow,deny
Allow from all




ServerName forum.xxx.pl
DocumentRoot "C:/xampp/htdocs/forum"

AllowOverride All
Order allow,deny
Allow from all



Fajnie, wszystko działa z wyjątkiem tego, że jak chcę się połączyć z innego komputera to nic się nie dzieje.

Zielone_Oko
16-04-2011, 20:38
Cytat Napisał no4b
Nie no, takie pytania i stan wiedzy uniemożliwiają skuteczną pomoc. Sorry, to nie ma sensu.
to może masz link do poradnika, który mi pozwoli to nadrobić... Wybacz, ale jak bym wiedział co i jak to bym nie pisał na forum - a chyba forum od tego jest...

no4b
16-04-2011, 20:33
Nie no, takie pytania i stan wiedzy uniemożliwiają skuteczną pomoc. Sorry, to nie ma sensu.

Zielone_Oko
16-04-2011, 19:58
Obsługiwana jest przez wirtualkę Apache?

masz na myśli, bo nie rozumiem?

@edit
jeżeli chodzi o to nie mam pojęcia jak to zrobić czytałem kilka poradników na forach, lecz moje zmagania z tym są bezradne...

no4b
16-04-2011, 19:53
Config Apache.

Ścieżki dostosowałeś? Domena dobrze wskazuje? Obsługiwana jest przez wirtualkę Apache?

Zielone_Oko
16-04-2011, 19:33
Cytat Napisał no4b
Pokaż config.
config, czego?

korzystałem z tego poradnika, ale wszystko działa na locahlost.

http://revo.pl/index.php/blog/detailed/51

no4b
16-04-2011, 17:16
Pokaż config.

Zielone_Oko
16-04-2011, 11:28
Witam,

mam problem z utworzeniem subdomeny tzn. gdy połączę się na serwerze dedykowanym to wszystko działa, lecz gdy próbuje się połączyć z innego komputera to mnie łączy z głównym katalogiem.

Chcę utworzyć subodmene dla forum, zamiast

domena.pl/forum chcę aby się użytkownicy łączyli z nią za pomocą forum.domenta.pl

Z góry dziękuje za pomoc.