We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Soap w PHP


ollerm
04-10-2010, 10:01
Ta, dokładnie. MoM czy tam Manager.. na jedno wychodzi.

griz
04-10-2010, 09:42
Cytat Napisał ollerm
Raz dwa da się to zrobić.
Ok. Czyli mam zainstalować czysty system Gentoo w wersji 10.1 64bit poprzez MoM czy może w inny nie znany mi sposób?

ollerm
04-10-2010, 09:33
Cytat Napisał griz
Z postawieniem czystego, z kolei wiąże się kolejny nakład czasu na dopracowanie go do funkcjonalności obecnego systemu, a wolałbym go uniknąć, bo to serwer dla klienta.
Raz dwa da się to zrobić.

griz
04-10-2010, 09:01
Cytat Napisał borec
Release 2, zaoraj i postaw czyste gentoo, bo na tym będzie Ci baaardzo cięzko uzyskać cokolwiek dodatkowego w php.
Najbardziej mnie boli fakt że już sobie wszystko pokonfigurowałem, ftp,mysql,apache, tylko trochę za późno wpadłem na to że potrzebuje soap w php...i tutaj sprawa pogrzebana.

Z postawieniem czystego, z kolei wiąże się kolejny nakład czasu na dopracowanie go do funkcjonalności obecnego systemu, a wolałbym go uniknąć, bo to serwer dla klienta.

borec
04-10-2010, 08:56
Release 2, zaoraj i postaw czyste gentoo, bo na tym będzie Ci baaardzo cięzko uzyskać cokolwiek dodatkowego w php.

griz
04-10-2010, 08:52
Cytat Napisał no4b
Release 2?
Hmm. Przepraszam za moją lakoniczną odpowiedź, ale nie jestem pewien.

Wybrałem opcję Gentoo gotowego do użytku podczas wyboru systemu na tym RPS. Nigdzie nie widziałem tam choćby informacji o wydaniu. Natomiast w emailu mam informacje o wersji Gentoo 2006.0 - 64 bits

W menadżerze:
System (OS): gentoo-ovh_64

no4b
04-10-2010, 08:46
Release 2?

griz
04-10-2010, 08:42
Witam

Chciałbym dołączyć rozszerzenie Soap do bieżącej kompilacji php (konfiguracja domyślna z ovh), ale napotykam następujące problemy z maskowaniem jak sądze.

Kod:
r35084 ~ # USE="soap" emerge -av php


!!! /etc/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)



These are the packages that would be merged, in order:

Calculating dependencies -
!!! All ebuilds that could satisfy "dev-lang/php" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/php-5.3.3-r1 (masked by: EAPI 2)
- dev-lang/php-5.2.14 (masked by: EAPI 2)
- dev-lang/php-5.2.13 (masked by: missing keyword)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.

r35084 ~ # USE="soap" emerge -av php-5.3.3-r1


!!! /etc/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)



These are the packages that would be merged, in order:

Calculating dependencies \

!!! 'php-5.3.3-r1' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
r35084 ~ # USE="soap" emerge -av =php-5.3.3-r1


!!! /etc/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)



These are the packages that would be merged, in order:

Calculating dependencies \
!!! All ebuilds that could satisfy "=dev-lang/php-5.3.3-r1" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/php-5.3.3-r1 (masked by: EAPI 2)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.

r35084 ~ # emerge portage


!!! /etc/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


Calculating dependencies \
!!! All ebuilds that could satisfy "sys-apps/portage" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/portage-9999 (masked by: EAPI 2)
- sys-apps/portage-2.2_rc88 (masked by: EAPI 2)
- sys-apps/portage-2.2_rc67 (masked by: EAPI 2)
- sys-apps/portage-2.1.9.12 (masked by: EAPI 2)
- sys-apps/portage-2.1.8.3 (masked by: EAPI 2)
- sys-apps/portage-2.1.7.17 (masked by: EAPI 2)
- sys-apps/portage-2.1.6.13 (masked by: missing keyword)
- sys-apps/portage-2.1.6.7 (masked by: missing keyword)
- sys-apps/portage-2.1.4.4 (masked by: )

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.

r35084 ~ # emerge =portage-2.2_rc88


!!! /etc/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


Calculating dependencies \
!!! All ebuilds that could satisfy "=sys-apps/portage-2.2_rc88" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/portage-2.2_rc88 (masked by: EAPI 2)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
Ma ktoś jakieś rady, sugestie jak mam sobie z tym poradzić?