We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

aktualizacja clamav za pomocą emerge


mrbookt
16-04-2010, 15:07
Wybierz ta dystrybucje na ktorej sie najlepiej znasz, masz znajomych ktorzy ci pomoga etc.
Wlasciwie kazda "czysta" dystrybucja bedzie sie lepiej sprawowala niz gentoo ovh.
Na innych maszynach uzywam cent os i nogdy nie mialem z nim problemow.

pozdrawiam

MrBookt

hantle
16-04-2010, 15:03
dziękuje bardzo za pomoc.

Co w takim razie mam wybrać. Bo chce przerzucić się na dedyka.

mrbookt
16-04-2010, 14:54
Dystrybucja gentoo ovh r2 to jest jakas zenada. Juz od dawna pojawialy sie komunikaty ze clamav przestaje wspierac wersje 0.93 i ze beda sie teraz pojawialy sygnatury nieobslugiwane przez ta wersje (On 15 April 2010 all ClamAV installations older than 0.95 will be disabled. See http://www.clamav.net/eol-clamav-094/ for more details.)
Oczywiscie zadnego info chocby na forum nie bylo, a w oficjalnych repo ovh gentoo updatow nie ma (nie mowiac juz o innych rzeczach).
Trzeba by odmaskowac pakiety z oficjalnego repo gentoo (jest tam wersja 0.95 ) ale nie wiem czy to zadziala.

W tej chwili tymczasowym rozwiazaniem awaryjnym jest wylaczenie clamd i usuniecie wpisow w var/qmail/bin/qmail-scanner-queue.pl:

## scanners installed
my @scanners_installed=("clamdscan_scanner","spamassa ssin","perlscan_scanner");
## scanners default
my @scanners_default=("clamdscan_scanner","spamassass in","perlscan_scanner");
na:
my @scanners_installed=("spamassassin","perlscan_scan ner");
my @scanners_default=("spamassassin","perlscan_scanne r");
a, nastepnie zrestartowanie qmail.

Pytanie do adminow ovh:

Kiedy beda dostepne updaty dla clamav oraz innego oprogramowania?
Zainstalowalem gentoo ovh tylko dlatego ze potrzebowalem w ciagu 10 min skonfigurowanego serwera. Ovh podawalo informacje, iz ta dystrybucja jest przez nich wspierana oraz ciagle aktualizowana.
Nie ma updatow zwiazanych z bezpieczenstwem nie mowiac juz o updatach ktore pozwalaja na normalne funkcjonowanie serwera!

MrBookT

hantle
16-04-2010, 13:38
po tym wszystkim mam niby nową wersje clamav, ale przy komendzie
Kod:
emerge -u clamav
Dostaje

Kod:
Calculating dependencies \ *
 * ERROR: dev-lang/php4-ovh-4.4.8_pre20070816-r1 failed.
 * Call stack:
 *                              ebuild.sh, line 1590:  Called source '/usr/local/portage-ovh/dev-lang/php4-ovh/php4-ovh-4.4.8_pre20070816-r1.ebuild'
 *   php4-ovh-4.4.8_pre20070816-r1.ebuild, line   29:  Called inherit 'php4_4-sapi'
 *                              ebuild.sh, line 1312:  Called die
 * The specific snippet of code:
 * QA Notice: 'sed' called in global scope: eclass php4_4-sapi
 * QA Notice: 'sed' called in global scope: eclass php4_4-sapi
 *              [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
 *  The die message:
 *   php4_4-sapi.eclass could not be found by inherit()
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * This ebuild is from an overlay: '/usr/local/portage-ovh/'
 *                                                                                                                                                         ... done!
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
Proszę o pomoc. Szybką !!!

Elber
16-04-2010, 12:37
Spróbuj usunąć starą baze wirusów i zaaktualizować go na nowo:

cd /var/lib/clamav/
rm *
freshclam
Po tym ten błąd już nie powinien wyskakiwać

Co do aktualizacji do nowej wersji to się nie znam na Gentoo ale widzę że ma portage więc najpierw powinieneś zaktualizować portage do najnowszej wersji

emerge --sync
emerge -u portage
a potem

emerge clamav

hantle
16-04-2010, 12:32
Witam,

Dziś ukazał mi się komunikat po restarcie clamav:
Kod:
 * Caching service dependencies ...                                                                                                                    [ ok ]
 * Stopping clamd ...
 * Failed to stop clamd                                                                                                                                [ !! ]
 * Stopping freshclam ...                                                                                                                              [ ok ]
 * Starting clamd ...
LibClamAV Warning: ***********************************************************
LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ***********************************************************
LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see  www.clamav.net/eol-clamav-094 and www.clamav.net/download (length: 169)
LibClamAV Error: Problem parsing database at line 742
LibClamAV Error: Can't load daily.ndb: Malformed database
LibClamAV Error: cli_tgzload: Invalid size in header
LibClamAV Error: Can't load /var/lib/clamav/daily.cld: Malformed database
ERROR: Malformed database
 * Failed to start clamd                                                                                                                               [ !! ]
 * Starting freshclam ...
Jak zainstalować nowszą wersje clamav.
Jak daje emerge --search clamav
to wyszukuje mi tylko wersje 0.93 jak zainstalować wersje 0.95 za pomoca emerge

Ps. Szukam i szukam ciagle rozwiazania na Google ale proby jak dotąd nie dały żadnego efektu. Jak ktoś okaże litość to prosze o pomoc.