We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Konfiguracja domeny


rielev
18-01-2010, 14:31
Planuję coś 'grubszego", ale na razie ćśśśś :>

ollerm
17-01-2010, 01:54
Rielev, napisz jakieś howto dla zielonych

rielev
17-01-2010, 01:44
Nie wiem, czy to będzie niegrzeczne, jak powiem, że już tyle razy pisałam na ten temat, że już mi się nie chce ;p. Wystarczy użyć opcji "szukaj".

tabi19
16-01-2010, 10:41
Ten serial mi wygenerowało na stronce podanej wyżej Zmieniłem wszystko tak jak mówiłeś, zrestartowałem binda i czekam na efekt - strasznie muli u mnie ta zmiana DNS'ów..

Edit:// dalej to samo ...

ollerm
16-01-2010, 10:22
w named.conf.options zakomentuj jeszcze
Kod:
auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { ::1; };
w pliku strefy tam gdzie masz
Kod:
down4free.pl                    IN      A               188.165.49.232
down4free.pl - po tym powinna byc kropka
i serial zmień na ludzki 2010011605

tabi19
16-01-2010, 10:16
named.conf

http://wklej.to/ylr8

named.conf.options

http://wklej.to/yJwd

named.conf.local

http://wklej.to/jczf


plik strefy /etc/bind/down4free.pl

http://wklej.to/MfkA

ollerm
16-01-2010, 10:10
no to już coś innego. Jeszcze raz konfigi podeślij

tabi19
16-01-2010, 10:05
Dalej coś w stylu:

Kod:
Jan 15 23:53:20 stock named[25311]: invalid command from 127.0.0.1#44141: bad auth
Jan 16 00:01:47 stock named[25311]: invalid command from 127.0.0.1#45617: bad auth

http://wklej.to/LvA8 - tak wyglądają logi

ollerm
16-01-2010, 10:00
bo wogóle bind ci nie wstaje. co masz w logach teraz?

tabi19
16-01-2010, 09:14
Zakomentowałem, zrestartowałem binda, a nadal jest błąd:

"Strefa SOA dla domeny down4free.pl nie jest dostępna na serwerze dns: r30612.ovh.net"..

ollerm
16-01-2010, 02:41
w named.conf zakomentuj:
Kod:
server 213.251.188.140 {
        };
server 188.165.49.232 {
        };
key rndc-key {
        algorithm hmac-md5;
        secret "+fvlU00F9We3/ko161efMg==";
        };
controls {
        inet 127.0.0.1 port 953 allow { 127.0.0.1; } keys { rndc-key; };
        };

tabi19
16-01-2010, 00:22
A może lepiej skorzystać z darmowej strefy w stylu: http://freedns.sgh.waw.pl/ ?

tabi19
16-01-2010, 00:03
named.conf.local

http://wklej.to/L225

/etc/bind/down4free.pl

http://wklej.to/uQ3M

named.conf.options

http://wklej.to/ixIn

named.conf

http://wklej.to/t0Fj


i jeszcze najnowsze logi:

http://wklej.to/Vu5s


No tak to wygląda na chwilę obecną, dalej ten sam błąd ...

Pozdrawiam !

tabi19
15-01-2010, 23:45
Nie zmieniałem.. Hmm... Teraz mi się to trochę pokręciło, bo jeszcze coś z poziomu webmina pozmieniałem, zaraz to zrobię od nowa i powiem Ci, co i jak..

ollerm
15-01-2010, 23:38
zmieniałeś coś w pliku strefy?

tabi19
15-01-2010, 22:37
http://wklej.to/c7Z9

Mi się wydaje, czy jakiś błąd jest tutaj ?

Kod:
Jan 15 20:58:26 stock named[25311]: /etc/bind/named.conf.local:12: undefined ACL 'ns1.down4free.pl'
Tylko na co poprawić to ns1.down4free.pl ?

ollerm
15-01-2010, 22:29
/var/log/daemon.log

tabi19
15-01-2010, 22:15
Cytat Napisał ollerm
bo twoj bind nie nasłuchuje na zewnętrznym ip. Zakomentowałeś tą linie listen-on?
Tak, zakomentowałem..

sprawdź co masz w logach
w /var/log/ nie mam żadnego pliku ani katalogu odnośnie binda .. On ma jakiś inny folder z logami czy jak ?

ollerm
15-01-2010, 22:13
bo twoj bind nie nasłuchuje na zewnętrznym ip. Zakomentowałeś tą linie listen-on? sprawdź co masz w logach

tabi19
15-01-2010, 22:01
No ok, wszystko poprawione, bind zrestartowany, a dalej wyświetla:

Kod:
Strefa SOA dla domeny down4free.pl nie jest dostępna na serwerze dns: r30612.ovh.net
:/

ollerm
15-01-2010, 21:55
Po co chcesz to dodawać jak już tam jest dodane? Postaw // na początku linii.
No może być. Przeładowałeś binda?

tabi19
15-01-2010, 21:54
nowy named.conf:

Kod:
// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, *BEFORE* you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include "/etc/bind/named.conf.options";

// prime the server with knowledge of the root servers
zone "." {
        type hint;
        file "/etc/bind/db.root";
};

// be authoritative for the localhost forward and reverse zones, and for
// broadcast zones as per RFC 1912

zone "localhost" {
        type master;
        file "/etc/bind/db.local";
};

zone "127.in-addr.arpa" {
        type master;
        file "/etc/bind/db.127";
};

zone "0.in-addr.arpa" {
        type master;
        file "/etc/bind/db.0";
};

zone "255.in-addr.arpa" {
        type master;
        file "/etc/bind/db.255";
};

zone "down4free.pl" {
        type master;
        file "/etc/bind/down4free.pl";
        allow-transfer { 188.165.49.232; 213.251.188.140; };
        notify yes;
};

include "/etc/bind/named.conf.local";
server 213.251.188.140 {
        };
server 188.165.49.232 {
        };
key rndc-key {
        algorithm hmac-md5;
        secret "+fvlU00F9We3/ko161efMg==";
        };
controls {
        inet 127.0.0.1 port 953 allow { 127.0.0.1; } keys { rndc-key; };
        };

tabi19
15-01-2010, 21:49
"w named.conf.options zakomentuj:"

w sensie mam dodać to, co napisałeś ?

"a gdzie w named.conf masz ładowanie konfiguracji strefy Twojej domeny? "
no właśnie ja to dodawałem w jakimś innym pliku ;/ zaraz przerobię ten plik i "dam Ci do sprawdzenia"

Wiem, że może moje pytania są "lamerskie", ale dopiero uczę się obsługi debiana i to jest właściwie moja pierwsza domena..

ollerm
15-01-2010, 21:45
w named.conf.options zakomentuj:
Kod:
listen-on { 127.0.0.1; };
a gdzie w named.conf masz ładowanie konfiguracji strefy Twojej domeny?

tabi19
15-01-2010, 21:40
named.conf

Kod:
// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, *BEFORE* you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include "/etc/bind/named.conf.options";

// prime the server with knowledge of the root servers
zone "." {
        type hint;
        file "/etc/bind/db.root";
};

// be authoritative for the localhost forward and reverse zones, and for
// broadcast zones as per RFC 1912

zone "localhost" {
        type master;
        file "/etc/bind/db.local";
};

zone "127.in-addr.arpa" {
        type master;
        file "/etc/bind/db.127";
};

zone "0.in-addr.arpa" {
        type master;
        file "/etc/bind/db.0";
};

zone "255.in-addr.arpa" {
        type master;
        file "/etc/bind/db.255";
};

include "/etc/bind/named.conf.local";
server 213.251.188.140 {
        };
server 188.165.49.232 {
        };
key rndc-key {
        algorithm hmac-md5;
        secret "+fvlU00F9We3/ko161efMg==";
        };
controls {
        inet 127.0.0.1 port 953 allow { 127.0.0.1; } keys { rndc-key; };
        };

named.conf.options

Kod:
options {
        directory "/var/cache/bind";

        // If there is a firewall between you and nameservers you want
        // to talk to, you may need to fix the firewall to allow multiple
        // ports to talk.  See http://www.kb.cert.org/vuls/id/800113

        // If your ISP provided one or more IP addresses for stable
        // nameservers, you probably want to use them as forwarders.
        // Uncomment the following block, and insert the addresses replacing
        // the all-0's placeholder.

        // forwarders {
        //      0.0.0.0;
        // };

        auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { ::1; };
        listen-on { 127.0.0.1; };
        allow-recursion { 127.0.0.1; };
};
Tamten plik poprawiłem już

ollerm
15-01-2010, 21:34
Cytat Napisał tabi19
Dobrze jest wypełniony ten plik ?
Nie

Kod:
@       IN      SOA     r30612.ovh.net. sdns1.ovh.net. (
powinno być:
Kod:
@       IN      SOA     r30612.ovh.net. twoj.mail.pl. (
twoj@mail.pl -> w bindzie wpisujesz twoj.mail.pl

[CODE]
IN NS NS.OVH.NET.
IN NS DNS.OVH.NET.
[CODE]
powinno być:

[CODE]
IN NS sdns1.ovh.net.
IN NS r30612.ovh.net.
[CODE]

[CODE]
2005070901 ; Serial
[CODE]
myślałem, że mamy już 2010 rok
powinno być
[CODE]
2010011501 ; Serial
[CODE]
przy każdej zmianie w strefie zwiększasz serial, czyli kolejna zmiana dzisiaj bedzie miała serial 2010011502.. itd

Pokaż jeszcze named.conf i named.conf.options

tabi19
15-01-2010, 21:17
IP serwera: 188.165.49.232 / r30612.ovh.net
Domena: down4free.pl

plik strefy /etc/bind/down4free.pl:

Kod:
$TTL 86400
$ORIGIN down4free.pl.

@       IN      SOA     r30612.ovh.net. sdns1.ovh.net. (
        2005070901 ; Serial
        10800      ; Refresh
        3600       ; Retry
        2419200    ; Expire
        10800 )    ; NXDOMAIN TTL

        IN      NS              NS.OVH.NET.
        IN      NS              DNS.OVH.NET.

        IN      MX      5       mail.down4free.pl.

@       IN      A               188.165.49.232
www     IN      A               188.165.49.232
mail    IN      A               188.165.49.232
ftp     IN      CNAME           down4free.pl.
Dobrze jest wypełniony ten plik ?

ollerm
15-01-2010, 21:11
Pewnie coś źle skonfigurowałeś. Sprawdź logi. Podaj ip serwera i nazwe domeny

tabi19
15-01-2010, 20:59
No ok, już sobie jakoś poradziłem z konfiguracją tego, jednak nadal mam błąd:
"Strefa SOA dla domeny nazwa_domeny nie jest dostępna na serwerze dns: rXXXXX.ovh.net"..

Co mogłem zrobić źle ?

ollerm
15-01-2010, 20:56
Giasek już Ci odpisał co zrobić. Skonfiguruj strefy

tabi19
15-01-2010, 20:10
Wpadłem na pomysł zainstalowania bind9 na debianie, chciałem jednak zasięgnąć Waszych porad na ten temat ..

giasek
15-01-2010, 20:01
Może to pomoże

tabi19
15-01-2010, 18:46
Witam ! Kupiłem w ovh domenę PL, chciałbym ją skonfigurować z moim RPS'em.. Mógłby mnie ktoś pokierować, jak to zrobić ? Na RPS'ie jest system Debian 5.0 "lenny". Dodałem domenę z poziomu Managera OVH do DNS Secondary RPS'a i teraz gdy chcę dodać do domeny adresy DNS (tj. Primary: rXXXX.ovh.net Secondary: sdns1.ovh.net ) to wyskakuje komunikat:
"Strefa SOA dla domeny nazwa_domeny nie jest dostępna na serwerze dns: rXXXXX.ovh.net".. Mógłby ktoś pomóc ?

Pozdrawiam !