We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

DNS/Domeny


safemode
19-10-2009, 10:47
Dziękuję za pomoc.

ollerm
18-10-2009, 22:54
no jest ok teraz:

Kod:
bok.chaltura.pl.	86400	IN	A	188.165.55.127
w ścieżce chyba sam /bok wpisujesz

safemode
18-10-2009, 22:43
Cytat Napisał ollerm
jak dodawałeś w ispconfigu domene to w nazwie hosta postawiłeś kropke na końcu? "bok.chaltura.pl."
No w sumie faktycznie było bez kropki...
Dodałem kropkę i niestety nadal lipa.
W konfiguracji subdomeny wpisuję w Redirect path całą ścieżkę dostepu do katalogu, czy wystarczy wpisać /bok/(katalog jest w dokładnie w /web/bok/?

I powiedzcie mi proszę o co chodzi z tymi flagami?
Z góry dziękuję.

MBorowiec
18-10-2009, 20:21
hmm generalnie chyba sie znajduja w ronych katalogach?
Tak wyglada struktura katalogow:

wedlug konfiguracji samego serwera jest poprawna:
website_basedir=/var/www
website_path=/var/www/clients/client[client_id]/web[website_id]
website_symlinks=/var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/

ollerm
18-10-2009, 19:55
no to wychodzi na to ze te dwa vhosty korzystają z tego samego katalogu. umieść je w różnych

MBorowiec
18-10-2009, 19:39
Hmm webmin nie odpowiadał mi jednak za bardzo, strasznie toporny był, więc jeszcze jedna szansa dla ISPC, sprawa wygląda tak:
Domena dodana, i teoretycznie działa, a dlaczego teoretycznie ... nie mogę wykopać domeny (dig) wywala:
;; connection timed out; no servers could be reached
Ale to nic, mam w panelu dodane 2 domeny (według guide rielev) i 2 strony (websites) dla dwóch klientów(użytkowników), no i zaczynają się teraz jaja ...
Pierwsza domena którą dodałem to: mchojnacki.eu
Druga domena: arbre.pl
i wygląda na to że arbre.pl "nadpisuje zawartość mchojnacki.eu", a chodzi o to że dla testów, zmieniłem kolor tła nagłówka na mchojnacki.eu na niebieski, a arbre.pl został defaultowo zielony, no i teraz wchodząc na arbre.pl jest ok, ALE, wchodząc na mchojnacki.eu jest ta sama strona co na arbre.pl!
W panelu w strefach na liście w tabeli przy plou NS widnieje ns2 (sdns1.ovh.net), przy who.is serwery dns pokazują się w takiej kolejności
Nameservers:
sdns1.ovh.net
r29118.ovh.net
czyli tak jakby na odwrót?

Szablon strefy wygląda tak:
[ZONE]
origin={DOMAIN}.
ns={NS1}.
ns={NS2}.
mbox={EMAIL}.
refresh=28800
retry=7200
expire=604800
minimum=86400
ttl=86400

[DNS_RECORDS]
A|{DOMAIN}.|{IP}|0|86400
A|www|{IP}|0|86400
A|mail|{IP}|0|86400
NS|{DOMAIN}.|{NS1}.|0|86400
NS|{DOMAIN}.|{NS2}.|0|86400
MX|{DOMAIN}.|mail.{DOMAIN}.|10|86400
dlaczego się to nadpisuje?

ollerm
18-10-2009, 18:01
jak dodawałeś w ispconfigu domene to w nazwie hosta postawiłeś kropke na końcu? "bok.chaltura.pl."

safemode
18-10-2009, 17:49
Dokładnie taki sam jak dla głównej domeny.

ollerm
18-10-2009, 17:39
wpisałeś poprawny IP w tym rekordzie A dla bok?

safemode
18-10-2009, 17:12
OK. nadal niestety nie rozwiązałem problemu...
Przeinstalowałem na Debiana z panelem ISPconf.
W panelu dodałem nową stronę i subdomenę bok.chaltura.pl skierowałem ją na adres /web/bok/.
W zakładce DNS dodałem Record A o wartości bok.chaltura.pl w domenie chaltura.pl.
I nadal nie może znaleźć strony...

safemode
17-10-2009, 17:04
http://r29150.ovh.net/~virtu3m -- domena główna
dodałem do niej subdomenę forum.nazwadomeny.pl

Teraz niestety niewiele można zobaczyć, bo właśnie robi się reinstall na Debiana...

Pik-Pok
17-10-2009, 16:58
a jaka jest nazwa tej subdomeny?

safemode
17-10-2009, 16:36
Chyba troszkę sie nie zrozumieliśy.
Subdomenę dodawałem z poziomu Webmina > OVHm.
We wpisach serwera DNS subdomena sie pojawia, w katalogu domowym pojawia się katalog równorzędny z www o nazwie sd, w którym z kolei jest older o nazwie konta subdomeny.

Jaki adres wpisać w przegladarkę, żeby zobaczyć zawartość z tego folderu?
Pozdrawiam.
T

ollerm
17-10-2009, 16:08
w konfiguracji dnsa zmień ip dla subdomeny żeby wskazywała na rxxxx.ovh.net a na serwerze w ovh utwórzy odpowiedni vhost

safemode
17-10-2009, 16:00
Nie będę otwierał nowego tematu, bo moje pytanie dotyczy także konfiguracjin DNS, a konkretnie subdomeny.
Podpowiedzcie mi proszę, jak wejść na adres subdomeny, która wpisaną ma domene, która nie jest jeszcze skonfigurowna w DNS-ach (jest jeszcze na innym serwerze, a tu powstaje jej nowa wersja).
O ile z domeną główną problemu nie ma, wiadomo: http://rxxxx.ovh.net/~nazwakonta, to z subdomena poradzić sobie nie mogę.

Jaki adres wpisać w przegladarce, żeby móc na niej pracować?
Aktualnie używam Gentoo Release2 ale zastanawiam się nad przesiadką na chwalonego wszem i wobec Debiana. Jeżeli więc mogę prosić, podajcie rozwiązanie w obu przypadkach (chyba, że jest jedno).
Z góry dziekuję.
T.O.

rielev
16-10-2009, 14:00
Cytat Napisał ollerm
rielev, przyda sie dla potomnych
faktycznie można było zmienić templatke, i wtedy ma sie "gotowca", ale przy dodawaniu strefy można było dorzucić odpowiednie rekordy i też by banglało
No właśnie tak też próbowałam i nie bardzo banglało.
Po dignięciu domeny było zwracane tylko SOA, zupełnie tak, jakbym zrobiła dig borg.net.pl SOA, pomimo tego, że dodałam wszytkie pozostałe pola. A może poprostu ja coś źle zrobiłam, bo szczerze, to ISPConfig nie znam za dobrze

ollerm
16-10-2009, 13:38
rielev, przyda sie dla potomnych
faktycznie można było zmienić templatke, i wtedy ma sie "gotowca", ale przy dodawaniu strefy można było dorzucić odpowiednie rekordy i też by banglało

rielev
16-10-2009, 13:24
OK, to tak: działa

A jak zrobiłam, że działa:
Domeny dodawałam nie za pomocą DNS => add new dns zone (soa), tylko najpierw zajżałam do sekcji templates. Tam zmieniłam defaultową templatkę, dodałam drugie pole NS ( w sekcji [ZONE] trzeba dodać linijkę ns={NS2}. pod ns={NS1}. ).
Następnie w sekcji add DNS zone (menu po lewej) dodałam strefę korzystając ze zmodyfikowanej defaultowej templatki.
Jako ns1 podałam adres swojego rps'a, a jako ns2 sdns1.ovh.net (wcześniej dodałam domenę do DNS secondary w managerze). Utworzyła się poprawna strefa, wraz ze wszystkimi potrzebnymi wpisami. Nie modyfikowałam jej już, zostawiłam tak jak została stworzona z automatu, tylko w sekcji zones wybrałam stworzoną strefę i dodałam w Allow zone transfers to these IPs IP sdns1.ovh.net.

Po około 3 godzniach sdns1.ovh.net odpowiadał poprawnie dla tej domeny, a dzisiaj:

Kod:
:~$ dig borg.net.pl

; <<>> DiG 9.5.1-P2 <<>> borg.net.pl
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63171
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;borg.net.pl.			IN	A

;; ANSWER SECTION:
borg.net.pl.		86400	IN	A	188.165.46.253

;; AUTHORITY SECTION:
borg.net.pl.		86400	IN	NS	sdns1.ovh.net.
borg.net.pl.		86400	IN	NS	r11209.ovh.net.

;; ADDITIONAL SECTION:
sdns1.ovh.net.		75957	IN	A	213.251.188.140
r11209.ovh.net.		86393	IN	A	91.121.62.254

;; Query time: 108 msec
;; SERVER: 10.40.0.1#53(10.40.0.1)
;; WHEN: Fri Oct 16 13:13:31 2009
;; MSG SIZE  rcvd: 125

rielev
15-10-2009, 12:22
Jestem w trakcie testów.
Jak będę coś wiedzieć, to dam znać

ollerm
14-10-2009, 23:43
możliwe że coś jest skopane w tym gotowcu z ispconfig. bo czysta instalacja debiana + ispconfig działa bez problemów

MBorowiec
14-10-2009, 23:29
Przeinstalowałem serwer (srogo namieszałem innymi pierdołami :P) powrotnie na gentoo+webmin (release2) dodałem domeny, transfery stref w bindzie dodane i uwaga uwaga działa tak więc dziękuję wszystkim za wszelką pomoc,
pozdrawiam i zabieram się powolutku do pracy

rielev
14-10-2009, 20:39
Na moje, to coś masz skopane w konfiguracji mydns.

Kod:
:~ $ dig mborowiec.pl @r29118.ovh.net

; <<>> DiG 9.3.2 <<>> mborowiec.pl @r29118.ovh.net
; (1 server found)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 932
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mborowiec.pl.                  IN      A

;; Query time: 1 msec
;; SERVER: 87.98.164.144#53(87.98.164.144)
;; WHEN: Wed Oct 14 20:35:43 2009
;; MSG SIZE  rcvd: 30
A to jest cokolwiek dziwne, bo po południu jeszcze odpowiadał poprawnie.

MBorowiec
14-10-2009, 17:52
Coś strasznie długo, nie można zmienić delegacji dla domeny...
Cały czas, sdns1 nie rozpoznaje domeny hmm, dziwne, dziwne...

rielev
14-10-2009, 11:43
IP jest ok.

Może nie mieszaj tak w strefie, to się przeniesie? Popatrz na swoje SOA
2009101404

MBorowiec
14-10-2009, 11:10
W panelu mam ustawiony transfer strefy (chyba (?)) na ip secondary ns, screen ponizej, co jednak nie skutkuje ...

rielev
14-10-2009, 10:35
Jeżeli nie zezwolisz na transfer strefy, to sdns1.ovh.net jej nie pobierze i nie będzie poprawnie odpowiadał dla tej domeny niestety.

MBorowiec
14-10-2009, 10:30
Tak, jest Mydns, support odpisał tak jak rielev.
w mydns.conf z tego co wyczytałem nie da się od tak ustawić transferu strefy.
Allow-axfr a później grzebać w bazie danych ?

ollerm
14-10-2009, 09:51
w ispconfig jest mydns. Ostatnio robiłem takie instalacje i nie było problemów. działały out-of-the-box. Nie musiałem ustawiać żadnych ip dla transferu stref

rielev
14-10-2009, 08:08
Zezwoliłeś na transfer strefy w pliku konfiguracyjnym serwera nazw?
(dla binda to jest allow-transfer { lista_IP }; )

MBorowiec
14-10-2009, 01:09
Will see, puki co czas na trochę snu, cały dzień pracy nie jest fajny

ollerm
14-10-2009, 00:51
raczej nie w sumie dobrze zrobiłeś, bo to gentoo z ovh to starsze od węgla jest. twój serwer poprawnie odpowiada na zapytanie o domene. poczekaj co odpiszą z ovh

MBorowiec
14-10-2009, 00:46
Wysłąłem ticketa do supportu, zobaczymy...
Najdziwniejsze, że inna domena zachowuje się identycznie.
IMO, tak jakby Manager OVH nie banglał?

Hmmm, zamawiałem serwer z dystrybucją Gentoo, ale przeinstalowałem na Debiana, może to przez ten manewr?

ollerm
14-10-2009, 00:38
no dziwne, sdns1.ovh.net twierdzi że nie zna domeny

MBorowiec
14-10-2009, 00:30
no i jest tak ustawione od początku, i już powoli wysiadam ...

ollerm
14-10-2009, 00:26
w managerze ustaw: 87.98.164.144 (r29118.ovh.net)

MBorowiec
14-10-2009, 00:20
mborowiec.pl. 86400 IN A 87.98.164.144

;; AUTHORITY SECTION:
mborowiec.pl. 86400 IN NS r29118.ovh.net.
mborowiec.pl. 86400 IN NS sdns1.ovh.net.
hmm wpisy dodane jak widać, ALE home.pl ma jednak inne zdanie co do sdns1.ovh.net ...
Błąd:
Pole DNS2: serwer "sdns1.ovh.net" nie jest skonfigurowany dla domeny "mborowiec.pl". Skontaktuj się z administratorem docelowego serwera DNS, celem skonfigurowania obsługi domeny!
Wygląda na to, że jakoś manager ovh szwankuje (?).

Hmm mam jeszcze jedno pytanie, przy dodawaniu sdns przez manager ovh, mam przy polu IP do wyboru 2, jedno z rXXX a truge z rpsYYY (różne ip, i numerki po "r" i "rps" ...) czy to od ip failover ?

ollerm
14-10-2009, 00:01
dig mborowiec.pl @r29118.ovh.net

; <<>> DiG 9.4.3-P3 <<>> mborowiec.pl @r29118.ovh.net
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 3378
;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;mborowiec.pl. IN A

;; AUTHORITY SECTION:
mborowiec.pl. 86400 IN SOA r29118.ovh.net. mail.mborowiec.pl. 2009101302 28800 7200 604800 86400

;; Query time: 383 msec
;; SERVER: 87.98.164.144#53(87.98.164.144)
;; WHEN: Wed Oct 14 00:01:00 2009
;; MSG SIZE rcvd: 85
dodaj drugi NS i odpowiednie rekordy do strefy

MBorowiec
13-10-2009, 23:55
hmm, dziwna sprawa,
Wywaliłem strefy, dodałem na nowo, i kurde secondary dns'a nie widać w ogole teraz, dziwna sprawa, juz nic z tego nie rozumie ;/

ollerm
13-10-2009, 23:35
no ciekawe troche, zazwyczaj nie miałem problemów z dodaniem domeny do sec dns ovh

MBorowiec
13-10-2009, 23:14
Wpis poprawiony,
Swoją drogą, dlaczego, domyślny wpis dokładnie taki się pojawił?

Generalnie problem nie ustąpił, home.pl, cały czas mi mówi że sdns1.ovh.net jest nie skonfigurowany dla domeny, co imo jest conajmniej dziwne...

ollerm
13-10-2009, 22:56
masz zły NS wpisany w konfiguracji strefy

dig mborowiec.pl @r29118.ovh.net

; <<>> DiG 9.4.3-P3 <<>> mborowiec.pl @r29118.ovh.net
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29925
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;mborowiec.pl. IN A

;; ANSWER SECTION:
mborowiec.pl. 86400 IN A 87.98.164.144

;; AUTHORITY SECTION:
mborowiec.pl. 86400 IN NS ns91735.ovh.net.
mborowiec.pl. 86400 IN NS sdns1.ovh.net.

;; Query time: 426 msec
;; SERVER: 87.98.164.144#53(87.98.164.144)
;; WHEN: Tue Oct 13 22:55:49 2009
;; MSG SIZE rcvd: 95

MBorowiec
13-10-2009, 22:54
r29118.ovh.net

ollerm
13-10-2009, 22:49
podaj adres twojego rpsa

MBorowiec
13-10-2009, 21:35
To też tak robię, tylko że cały czas dostaję komunikat zwrotny (HOME):
Błąd:
Pole DNS1: serwer "rXXXXX.ovh.net" nie jest skonfigurowany dla domeny "mborowiec.pl". Skontaktuj się z administratorem docelowego serwera DNS, celem skonfigurowania obsługi domeny!
Pole DNS2: serwer "sdns1.ovh.net" nie jest skonfigurowany dla domeny "mborowiec.pl". Skontaktuj się z administratorem docelowego serwera DNS, celem skonfigurowania obsługi domeny!
Primary DNS'a przyjęło ale jest problem z secondary, ten który mam w manager3 czyli:
sdns1.ovh.net
Nie działa, co jest nie tak ?

ollerm
13-10-2009, 21:27
no to jak ustawiłeś domene to zmień jej delegacje u rejestratora domeny, podając za pierwszy dns twój adres serwera (rxxxxx.ovh.net) a drugi secondary z ovh (w managerze musisz dodać domene do sec dns)

MBorowiec
13-10-2009, 21:20
Witam,
Posiadam RPS'a I @ Debian + ISPC i mam problem z podpięciem domeny, dokładniej rzecz biorąc jak muszę to wykonać?
W ISPC dodałem domenę, i co teraz?
Generalnie nie znam procedury na RPS'ie, proszę o nakierowanie