We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem z logowaniem do serwera przez FTP.


rielev
14-10-2009, 15:08
nie ma sprawy

safemode
14-10-2009, 14:39
Widocznie coś spsułem, bo był off dla domeny którą dodałem.
I jak już sobie przypomniałem okno dodawania domeny w Webminie, to mnie oświeciło, że przeciez tam tworzy się jednocześnie użytkownika ftp. Już się zalogowałem!
Dziękuję za pomoc.

rielev
14-10-2009, 13:58
Jak masz release 2, to proftpd jest już uruchomiony (chyba, że coś spsułeś )
Tak, musisz stworzyć użytkownika, bo na root się nie zalogujesz po ftp.

safemode
14-10-2009, 13:44
Czyli jeśli dobrze rozumiem, to trzeba uruchomić proftpd i dodać nowego użytkownika? Na koncie root się nie zaloguję?
Pozdrawiam.

Solitpapa
05-10-2009, 21:47
Nazwę serwera oraz IP wysłałem na priv.
Dodałem jeszcze raz użytkownika poprzez panel Webmin tak jak pisałem wcześniej i nadal nic to nie daje... Przy próbie połączenia się z serwerem przez program FTP program pokazuje błąd : "Połaczenie z serwerem zresetowane".

Czy ktoś jest w stanie mi pomóc? Byłbym wdzięczny.

edit:
problem reinstalacji systemu rozwiązał sprawę.

rielev
05-10-2009, 21:12
No to tak:

na czystym release 2 tworzysz użytkownika i po chwili można bez problemu połączyć się z ftp.
Opcje, jakie zmieniałam dla użytkownika, to tylko hasło otwartym tekstem, jak się ustawi grupę users to działa, ale z grupą ftp też działa.
Jaki błąd Ci się pojawia? Najlepiej podaj nazwę serwera albo IP.

Solitpapa
05-10-2009, 20:44
Byłbym bardzo wdzięczny. W takim razie czekam na informację.

rielev
05-10-2009, 20:40
Na Release 2 jest zainstalowany serwer ftp.
Właśnie instaluję sobie release 2 na rpsie, to dam znać, jak się zalogować na ftp, za jakieś 20 minut

Solitpapa
05-10-2009, 20:37
Po wpisaniu w linii komend podanego przez Ciebie polecenia netstat wyskoczyły mi "Active Internet connections (only servers)" i pod tym lista adresów IP, adresu z portem 21 niestety nie ma żadnego, oraz "Active UNIX domain sockets (only servers)" i pod tym kolejne wpisy.

Mam rozumieć, że w takiej sytuacji nie mam zainstalowanego żadnego serwera FTP?

Cuddles
05-10-2009, 20:21
Sprawdź czy masz zainstalowanego i działającego proftpd, jeżeli nie to zainstaluj.
Jeżeli nie wiesz jak sprawdzić - netstat -nl i sprawdź czy coś nasłuchuje na porcie 21 (X:21).

Solitpapa
05-10-2009, 20:05
Witam.
Proszę Was o pomoc, ponieważ mam problemy aby zalogować się na swój serwer poprzez ftp. Jestem początkujący w tym temacie więc proszę o odpowiedź jak dla laika.
Posiadam serwer RPSIII z systemem Release 2.
Dodałem użytkownika w panelu Webmin poprzez System > Użytkownicy i grupy > Utwórz nowego użytkownika.
Tutaj wypełniłem pola "Nazwa użytkownika" oraz "Hasło otwartym tekstem". Dodałem mu jako grupę podstawową grupę "ftp". Reszta ustawień pozostała bez zmian.
Następnie próbuję połączyć się z serwerem przez program ftp, jako hosta wpisując rXXXXX.ovh.net a jako usera i hasło podane przy zakładaniu konta dane.
Niestety na nic się to zdaje. Ponieważ program pokazuję że nie może ustanowić połączenia.
Jak bawiłem się Webminem na jego stronie domowej to w zakładce serwery był ProFTPD, u mnie czegoś takiego nie ma, więc być może z tego wynika ten problem.
Jednakże w opisie systemu Release 2 jest podana informacja, że standardowo możliwe jest połączenie ftp bez żadnej ingerencji ze strony użytkownika. Także nie wiem w czym jest problem. Proszę Was o pomoc.

Pozdrawiam.