We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Serwer padł, co zrobić w rescue?


Aimar
25-06-2009, 23:59
a probowales bootowac serwer po sieci, ale nie w vKVM tylko w normalnym trybie?
tak, tak działa w tym momencie...
...ale to nie stanowi rozwiązania problemu, chcę go bootować z jego hdd

Pik-Pok
25-06-2009, 21:22
@Aimar:
a probowales bootowac serwer po sieci, ale nie w vKVM tylko w normalnym trybie?

yfr
25-06-2009, 21:18
Od poniedziałku mam ten sam problem na RPSie. Jeśli zmiana pomogła dajcie proszę znać

Aimar
25-06-2009, 14:19
No raczej mam tylko, że chyba uszkodzony skoro nie chce ruszyć

r24180 ~ # ls -la /boot/
razem 4104
drwxr-xr-x 2 root root 4096 VI 19 15:38 .
drwxr-xr-x 18 root root 4096 VI 19 15:52 ..
lrwxrwxrwx 1 root root 1 V 21 17:06 boot -> .
-rw-r--r-- 1 root root 512 V 21 17:12 boot.0800
-rw-r--r-- 1 root root 512 VI 19 15:16 boot.b
-rw-r--r-- 1 root root 3267416 V 29 2008 bzImage-2.6.24.5-xxxx-grs-ipv4-32
-rw-r--r-- 1 root root 0 IV 20 2007 .keep
-rw-r--r-- 1 root root 0 XI 12 2007 .keep_sys-boot_lilo-0
-rw------- 1 root root 70656 VI 19 15:38 map
-rw-r--r-- 1 root root 830824 V 29 2008 System.map-2.6.24.5-xxxx-grs-ipv4-32
r24180 src # ls -l
razem 4
lrwxrwxrwx 1 root root 22 V 22 20:21 linux -> linux-2.6.28-gentoo-r5
drwxr-xr-x 22 root root 4096 V 22 20:21 linux-2.6.28-gentoo-r5
no i w /

-rw-r--r-- 1 root root 2408448 V 21 17:12 initrd-iscsi.img

Pik-Pok
25-06-2009, 12:36
a masz jakis kernel na dysku? z tego, co napisales wynika, ze nie i bootujesz serwer po sieci.

Aimar
25-06-2009, 12:35
mala poprawka: probowales uruchomic serwer z dysku.

P.S. zamiast z dysku, zaznacz w vKVM opcje Uruchom z sieci

Tak też zrobiłem. Raz uruchomiłem z dysku, aby sprawdzić, co jest nie tak (załączony obrazek), a raz z sieci, żeby sprawdzić, czy w ten sposób ruszy.. i ruszyło.
Ale jednak wolę naprawić ten kernel na dysku i startować z niego

no4b
24-06-2009, 22:45
@Aimar: http://www.columbia.edu/~ariel/acpi/acpi_howto.txt (konkretnie pci=routeirq).

Pik-Pok
24-06-2009, 21:58
przeciez wlasnie z vKVM uruchamialem serwer z jego wlasnego hdd a pozniej z netboot'a dla porownania :/
mala poprawka: probowales uruchomic serwer z dysku.

P.S. zamiast z dysku, zaznacz w vKVM opcje Uruchom z sieci

Aimar
24-06-2009, 19:01
pomoc ovh nie przestaje mnie zadziwiać...

Witam,
VKVM nie dizała dla serwerów RPS.
przeciez wlasnie z vKVM uruchamialem serwer z jego wlasnego hdd a pozniej z netboot'a dla porownania :/

(włącz routing IRQ w kenelu)
szczerze mówiąc, niebardzo wiem jak... jakaś pomoc, poza linkiem do google'a?

no4b
23-06-2009, 14:42
Wygląda na problem z IRQ (włącz routing IRQ w kenelu) lub niezaładowany sterownik do karty sieciowej.

Aimar
23-06-2009, 14:01
any idea? :/

Aimar
21-06-2009, 00:44
Jak startuje z dysku to dostaję coś takiego:



z kolei startując z dowolnego innego netboot'a śmiga ładnie..
Jest jakaś możliwość naprawy wyżej pokazanego błędu?

Aimar
19-06-2009, 15:51
uruchomienie "lilo" pokazuje mi:

rescue / # lilo
Warning: '/proc/partitions' does not match '/dev' directory structure.
Name change: '/dev/uba' -> '/tmp/dev.0'
Warning: '/dev' directory structure is incomplete; device (180, 0) is missing.
Warning: Name change: '/dev/uba1' -> '/tmp/dev.1'
Warning: '/dev' directory structure is incomplete; device (180, 1) is missing.
Added linux *
4 warnings were issued.
i chyba przyczyna:
rescue etc # rc-update -s
* Broken runlevel entry: /etc/runlevels/default/postfix
* Broken runlevel entry: /etc/runlevels/default/open-iscsi
apache2 | default
bootmisc | boot
checkfs | boot
checkroot | boot
clock | boot
consolefont | boot
hostname | boot
keymaps | boot
local | default nonetwork
localmount | boot
modules | boot
mysql | default
named | default
net.dummy0 | default
net.lo | boot
netmount | default
open-iscsi | default
rmnologin | boot
sendmail | default
sshd | default
syslog-ng | default
urandom | boot
vixie-cron | default
vsftpd | default
* Broken runlevel entry: /etc/runlevels/default/open-iscsi

Da się to jakoś naprawić?

//Edit:

Wykonałem polecenia
rc-update del open-iscsi default
rc-update add open-iscsi default
rc-update del postfix defult

ale... to nic nie dało, serwer dalej z własnego hdd nie rusza :/

JarekMk
19-06-2009, 15:17
W tym trybie masz możliwość jedynie zamontowania swojego dysku - tak mi się wydaje.

Aimar
19-06-2009, 15:06
Witam,

Na moim czystym gentoo (nie ovh release) doinstalowałem tylko apache'a, mysql, php, tcl, irssi ... i to chyba tyle...
działało to sprawnie, nawet po początkowych rebootach, dziś ustawiłem iptables, ale zapomniałem o pingach z ovh i ... serwer znowu się zrestartował, ale... już nie wrócił - pojawił się po 30min w trybie rescue, ale usunięcie reguł iptables nic nie dało, dalej nie chce sie wlaczyc z hd.

Jak w trybie rescue zdiagnozowac, co uniemozliwia wlaczenie serwera z jego wlasnego hd?

pozdrawiam,
Aimar

//Edit: lilo.conf:

prompt
timeout=50
default=linux
boot=/dev/sda
map=/boot/map
install=/boot/boot.b
lba32
#serial=0,9600n8

image=/boot/bzImage-2.6.24.5-xxxx-grs-ipv4-32
label=linux
read-only
root=/dev/ram0
initrd=/initrd-iscsi.img
append="libusual.bias=ub"
/var/log/messages:
Jun 19 12:10:12 aimar mptctldrivers/message/fusion/mptctl.c::mptctl_ioctl() @600 - ioc0 not found!
Jun 19 12:10:12 aimar mptctldrivers/message/fusion/mptctl.c::mptctl_ioctl() @600 - ioc0 not found!
Jun 19 12:11:01 aimar cron[1411]: (root) CMD (/usr/local/rtm/bin/rtm >/dev/null 2>/dev/null)
Jun 19 12:11:12 aimar mptctldrivers/message/fusion/mptctl.c::mptctl_ioctl() @600 - ioc0 not found!
Jun 19 12:11:13 aimar mptctldrivers/message/fusion/mptctl.c::mptctl_ioctl() @600 - ioc0 not found!
Jun 19 12:11:26 aimar shutdown[1483]: shutting down for system reboot
Jun 19 12:11:26 aimar init: Switching to runlevel: 6
Jun 19 12:11:34 aimar iscsid: iscsid shutting down.
Jun 19 12:11:57 aimar sshd[4716]: Received signal 15; terminating.
Jun 19 12:12:06 aimar named[4513]: shutting down: flushing changes
Jun 19 12:12:06 aimar named[4513]: stopping command channel on 127.0.0.1#953
Jun 19 12:12:07 aimar named[4513]: no longer listening on 127.0.0.1#53
Jun 19 12:12:07 aimar named[4513]: exiting
Jun 19 12:12:13 aimar syslog-ng[4059]: syslog-ng version 1.6.11 going down